summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2016-04-16 17:05:35 +0200
committergrufo2016-04-16 17:05:35 +0200
commit9ee02e25958f1557f37404d0e5c6bcaa042fd058 (patch)
tree83f963da1b8dc4577fd47249bd1632680b69c124
downloadaur-9ee02e25958f1557f37404d0e5c6bcaa042fd058.tar.gz
Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition.
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD58
-rw-r--r--popcorntime-ce.desktop9
-rw-r--r--popcorntime-ce.install12
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e2c28e21932
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = popcorntime-ce-bin
+ pkgdesc = Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition.
+ pkgver = 0.4.0
+ pkgrel = 2
+ url = http://popcorntime.ag/
+ install = popcorntime-ce.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = gconf
+ depends = gtk2
+ depends = libnotify
+ depends = libxtst
+ depends = nodejs
+ depends = nss
+ depends = python
+ depends = ttf-font
+ optdepends = net-tools: necessary for the new vpn feature
+ optdepends = ttf-liberation: open source ttf fonts
+ provides = popcorntime
+ provides = popcorntime-ce
+ conflicts = popcorntime-ce
+ conflicts = popcorntime-ce-git
+ options = !strip
+ source = https://github.com/PopcornTime-CE/desktop/releases/download/v0.4.0-2/popcorn-time-community-v0.4.0-2-64bit.tar.xz
+ source = popcorntime-ce.install
+ source = popcorntime-ce.desktop
+ sha1sums = ee6a1b9314cbcb8eeabe76e9d6928f8c0bee4f42
+ sha1sums = 2c22a3f1d1335abe8d7ac7dd6a33933720ba30e4
+ sha1sums = 219a9c7033361e1286967452868721302b1d6da7
+
+pkgname = popcorntime-ce-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..093c7c10da1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: grufo <madmurphy333@gmail.com>
+
+pkgname="popcorntime-ce-bin"
+_pkgname="popcorntime-ce"
+pkgver="0.4.0"
+pkgrel="2"
+pkgdesc="Stream movies from torrents. Skip the downloads. Launch, click, watch. Repos of the original community edition."
+arch=("x86_64" "i686")
+url="http://popcorntime.ag/"
+license=("GPL3")
+depends=("alsa-lib" "desktop-file-utils" "gconf" "gtk2" "libnotify" "libxtst" "nodejs" "nss" "python" "ttf-font")
+optdepends=("net-tools: necessary for the new vpn feature" "ttf-liberation: open source ttf fonts")
+provides=("popcorntime" "popcorntime-ce")
+conflicts=("popcorntime-ce" "popcorntime-ce-git")
+options=("!strip")
+install="popcorntime-ce.install"
+
+sha1sums=("ee6a1b9314cbcb8eeabe76e9d6928f8c0bee4f42"
+ "2c22a3f1d1335abe8d7ac7dd6a33933720ba30e4"
+ "219a9c7033361e1286967452868721302b1d6da7")
+
+_platform="64bit"
+
+if [ "$CARCH" = "i686" ]; then
+ _platform="32bit"
+ sha1sums[0]="369da992f097e1b872a0f7d00a62361ac9192c93"
+fi
+
+source=("https://github.com/PopcornTime-CE/desktop/releases/download/v${pkgver}-${pkgrel}/popcorn-time-community-v${pkgver}-${pkgrel}-${_platform}.tar.xz"
+ "popcorntime-ce.install"
+ "popcorntime-ce.desktop")
+
+
+package() {
+
+ cd "${srcdir}"
+
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin"
+
+ # Program
+ install -Dm755 "${srcdir}/Popcorn-Time" "${pkgdir}/usr/share/${_pkgname}/Popcorn-Time-CE"
+ install -Dm644 "${srcdir}/"{CHANGELOG.md,icudtl.dat,libffmpegsumo.so,LICENSE.txt,nw.pak,package.json,README.md} "${pkgdir}/usr/share/${_pkgname}/"
+
+ # Directories
+ cp -a "${srcdir}/${_reldir}/"{node_modules,src} "${pkgdir}/usr/share/${_pkgname}/"
+
+ # Link to program
+ ln -s "/usr/share/${_pkgname}/${_execname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+
+ # Icon
+ install -Dm644 "${srcdir}/${_reldir}/src/app/images/icon.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+
+}
+
diff --git a/popcorntime-ce.desktop b/popcorntime-ce.desktop
new file mode 100644
index 000000000000..b221e2318f52
--- /dev/null
+++ b/popcorntime-ce.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Popcorn Time CE
+Comment=Watch Movies and TV Shows instantly
+Exec=popcorntime-ce %U
+Icon=popcorntime-ce
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;
+StartupNotify=false
+Categories=AudioVideo;Video;Network;Player;P2P;
+Type=Application
diff --git a/popcorntime-ce.install b/popcorntime-ce.install
new file mode 100644
index 000000000000..156132729af4
--- /dev/null
+++ b/popcorntime-ce.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ echo
+ echo "WARNING: Popcorn Time CE streams movies from Torrents"
+ echo "Downloading copyrighted material may be illegal in your country!"
+ echo "Use at your own risk!"
+ echo
+}
+
+post_upgrade() {
+ post_install
+}