summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-07-27 17:25:13 -0400
committerJean Lucas2018-07-27 18:14:08 -0400
commit13d2d480244a5ca62dd62b52bff7eebdb7476dda (patch)
treedc97daff9851a74ab301d3dcd42fb0170d790a54
parent661382b7b19a1259cb5c205813bedff9afbf2940 (diff)
downloadaur-13d2d480244a5ca62dd62b52bff7eebdb7476dda.tar.gz
Add unzip to makedepends, quote pkgdir, remove unnecessary variables,
update pkgdesc
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD39
-rw-r--r--popcorntime.desktop2
3 files changed, 21 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc10078b5838..6cb7e9fe5083 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Sun Jul 22 17:05:26 UTC 2018
+# Fri Jul 27 22:12:07 UTC 2018
pkgbase = popcorntime-git
- pkgdesc = Stream movies and TV shows from torrents
+ pkgdesc = BitTorrent client with integrated media player
pkgver = 0.3.10+6288+be800aa9
pkgrel = 3
url = https://popcorntime.sh
@@ -10,6 +10,7 @@ pkgbase = popcorntime-git
license = GPL3
makedepends = git
makedepends = wget
+ makedepends = unzip
depends = alsa-lib
depends = gconf
depends = gtk2
@@ -22,9 +23,7 @@ pkgbase = popcorntime-git
conflicts = popcorntime-ce
options = !strip
source = git+https://github.com/popcorn-official/popcorn-desktop#branch=development
- source = popcorntime.desktop
sha512sums = SKIP
- sha512sums = 5a5ddbe76a8290a3a2789b7241865e91f8bb954273c49a39854226da6d34eb5dfbc3a18691da77853e1e72affa528355bacab4b0efd44b079d5bc7c2471b8cc7
pkgname = popcorntime-git
diff --git a/PKGBUILD b/PKGBUILD
index 9fc72e757ae9..f81e8c7b8fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,22 @@
# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
pkgname=popcorntime-git
-_pkgname=popcorntime
-_gitname=popcorn-desktop
pkgver=0.3.10+6288+be800aa9
pkgrel=3
-pkgdesc='Stream movies and TV shows from torrents'
+pkgdesc='BitTorrent client with integrated media player'
arch=(i686 x86_64)
url=https://popcorntime.sh
license=(GPL3)
depends=(alsa-lib gconf gtk2 nss ttf-font libxtst libnotify)
-makedepends=(git wget)
+makedepends=(git wget unzip)
provides=(popcorntime)
conflicts=(popcorntime popcorntime-ce)
options=(!strip)
-source=(git+https://github.com/popcorn-official/$_gitname#branch=development
- $_pkgname.desktop)
-sha512sums=(SKIP
- 5a5ddbe76a8290a3a2789b7241865e91f8bb954273c49a39854226da6d34eb5dfbc3a18691da77853e1e72affa528355bacab4b0efd44b079d5bc7c2471b8cc7)
+source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development)
+sha512sums=(SKIP)
pkgver() {
- cd $_gitname
+ cd popcorn-desktop
echo $(git tag)+$(git rev-list --count HEAD)+$(git rev-parse --short HEAD)
}
@@ -33,33 +29,32 @@ _nwjsver=0.18.6 _nwjsffmpeg=$_nwjsver-linux-$_nwjsffmpegarch
prepare() {
msg2 'Using upstream NW.js instead of downstream...'
- sed -i s#get.popcorntime.sh/repo/nw#dl.nwjs.io# $_gitname/gulpfile.js
+ sed -i s#get.popcorntime.sh/repo/nw#dl.nwjs.io# popcorn-desktop/gulpfile.js
msg2 'Using custom open-source NW.js FFmpeg version...'
[ -f $_nwjsffmpeg.zip ] || wget https://github.com/iteufel/nwjs-ffmpeg-prebuilt/releases/download/$_nwjsver/$_nwjsffmpeg.zip
}
build() {
msg2 'Using temporary Node.js toolchain...'
- _nodever=6.14.3
- _node=node-v$_nodever-linux-$_arch
+ _nodever=6.14.3 _node=node-v$_nodever-linux-$_arch
[ -f $_node.tar.xz ] || wget https://nodejs.org/dist/v$_nodever/$_node.tar.xz
tar xfp $_node.tar.xz
- PATH=$PWD/$_node/bin:$PWD/$_gitname/node_modules/.bin:$PATH
+ PATH=$PWD/$_node/bin:$PWD/popcorn-desktop/node_modules/.bin:$PATH
npm_config_cache=$PWD/npm_cache
- cd $_gitname
+ cd popcorn-desktop
npm install
gulp build
}
package() {
- install -Dm 644 $_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
- cd $_gitname/build/Popcorn-Time/$_platform
- install -Dm 644 src/app/images/icon.png $pkgdir/usr/share/icons/hicolor/256x256/apps/$_pkgname.png
- install -d $pkgdir/usr/{share/$_pkgname,bin}
- unzip -o $srcdir/$_nwjsffmpeg.zip -d lib
- cp -a . $pkgdir/usr/share/$_pkgname
- cd $pkgdir/usr/share/$_pkgname
+ install -Dm 644 ../popcorntime.desktop "$pkgdir"/usr/share/applications/popcorntime.desktop
+ cd popcorn-desktop/build/Popcorn-Time/$_platform
+ install -Dm 644 src/app/images/icon.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/popcorntime.png
+ install -d "$pkgdir"/usr/{share/popcorntime,bin}
+ unzip -o $/$_nwjsffmpeg.zip -d lib
+ cp -a . "$pkgdir"/usr/share/popcorntime
+ cd "$pkgdir"/usr/share/popcorntime
find . -type f -exec chmod 644 {} +
chmod +x Popcorn-Time
- ln -s /usr/share/$_pkgname/Popcorn-Time $pkgdir/usr/bin/$_pkgname
+ ln -s /usr/share/popcorntime/Popcorn-Time "$pkgdir"/usr/bin/popcorntime
}
diff --git a/popcorntime.desktop b/popcorntime.desktop
index 544a50fa78ed..b40066b4382a 100644
--- a/popcorntime.desktop
+++ b/popcorntime.desktop
@@ -3,7 +3,7 @@ Type=Application
Name=Popcorn Time
Icon=popcorntime
Exec=popcorntime %U
-Comment=Stream movies and TV shows from torrents
+Comment=BitTorrent client with integrated media player
MimeType=application/x-bittorrent;x-scheme-handler/magnet;
Categories=AudioVideo;Video;Player;Network;FileTransfer;P2P;
Terminal=false