summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFirstAirBender2020-11-16 23:30:49 -0600
committerFirstAirBender2020-11-16 23:30:49 -0600
commitc0488ee5ada6f7b59bc9f03b45ea3ea85b2797b9 (patch)
treea5d8fc724b0ea762db0be826f2cf4bb4dc5d4a5b
parentecc9d2f6e25a2c2bd90a9975d8494efb8ae5bc9b (diff)
downloadaur-c0488ee5ada6f7b59bc9f03b45ea3ea85b2797b9.tar.gz
update versioning and remove permission fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD36
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5adcecbabaf9..d6443d01b219 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = popcorntime-git
pkgdesc = Popcorn Time is a multi-platform, free software BitTorrent client that includes an integrated media player.
- pkgver = v0.4.2+r6586+gef22f16d
+ pkgver = 0.4.2.r527.g7e39bad5
pkgrel = 1
url = https://github.com/popcorn-official/popcorn-desktop
arch = i686
@@ -17,7 +17,7 @@ pkgbase = popcorntime-git
conflicts = popcorntime
conflicts = popcorntime-bin
options = !emptydirs
- source = git+https://github.com/popcorn-official/popcorn-desktop#branch=development
+ source = popcorntime::git+https://github.com/popcorn-official/popcorn-desktop#branch=development
source = popcorntime.desktop
sha512sums = SKIP
sha512sums = 81a447cd3365b439964c1b9eba14bcf31de05e62123ce032590ac2109a447c5db0306bf4c593fe30f075d2b3674a1611a81b7554e43acba152ef34652c819a33
diff --git a/PKGBUILD b/PKGBUILD
index fb384d9bd456..69e4dc957db4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
# Contributor: Attila Bukor <r1pp3rj4ck [at] w4it [dot] eu>
-# https://jlk.fjfi.cvut.cz/arch/manpages/man/PKGBUILD.5
-pkgname=popcorntime-git
-pkgver=v0.4.2+r6586+gef22f16d
+_pkgname=popcorntime
+pkgname="${_pkgname}-git"
+pkgver=0.4.2.r527.g7e39bad5
pkgrel=1
pkgdesc='Popcorn Time is a multi-platform, free software BitTorrent client that includes an integrated media player.'
arch=(i686 x86_64)
@@ -17,18 +17,19 @@ makedepends=(git yarn npm)
provides=(popcorntime)
conflicts=(popcorntime popcorntime-bin)
options=(!emptydirs)
-source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development
+source=("$_pkgname"::git+https://github.com/popcorn-official/popcorn-desktop#branch=development
popcorntime.desktop)
sha512sums=('SKIP'
'81a447cd3365b439964c1b9eba14bcf31de05e62123ce032590ac2109a447c5db0306bf4c593fe30f075d2b3674a1611a81b7554e43acba152ef34652c819a33')
pkgver() {
- cd popcorn-desktop
- echo "$(git describe --abbrev=0)+r$(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)"
+ # https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver()_function
+ cd "$_pkgname"
+ echo "$(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
}
build() {
- cd popcorn-desktop
+ cd "$_pkgname"
yarn config set yarn-offline-mirror ./node_modules/
yarn install --ignore-engines
yarn build
@@ -36,21 +37,18 @@ build() {
# https://wiki.archlinux.org/index.php/creating_packages
package() {
- cd popcorn-desktop
+ cd "$_pkgname"
- install -d "$pkgdir"/usr/{share,bin}
+ # create directories
+ install --directory --mode='755' "$pkgdir"/usr/{share,bin}/
- cp -a build/Popcorn-Time/$([ $CARCH = x86_64 ] && echo linux64 || echo linux32) \
- "$pkgdir/usr/share/popcorntime"
-
- # Fix file permissions
- find "$pkgdir/usr/share/popcorntime" -type f -not -name 'Popcorn-Time' -exec chmod 644 {} +
- find "$pkgdir/usr/share/popcorntime" -type d -exec chmod 755 {} +
+ # copy everything to pkgdir
+ cp --archive build/Popcorn-Time/* "$pkgdir/usr/share/${_pkgname}"
# Symlink binary to /usr/bin/popcorntime
- # See: https://bbs.archlinux.org/viewtopic.php?id=143970
- ln -sv /usr/share/popcorntime/Popcorn-Time "$pkgdir/usr/bin/popcorntime"
+ ln --symbolic "../share/${_pkgname}/Popcorn-Time" "$pkgdir/usr/bin/${_pkgname}"
- install -Dm 644 "$srcdir/popcorntime.desktop" -t "$pkgdir/usr/share/applications"
- install -Dm 644 src/app/images/icon.png "$pkgdir/usr/share/icons/hicolor/256x256/apps/popcorntime.png"
+ install -D --mode='644' "$srcdir/popcorntime.desktop" -t "$pkgdir/usr/share/applications"
+ # https://specifications.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#directory_layout
+ install -D --mode='644' './src/app/images/icon.png' "$pkgdir/usr/share/icons/hicolor/256x256/apps/popcorntime.png"
}