summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFirstAirBender2020-03-15 17:06:33 -0600
committerFirstAirBender2020-03-15 17:06:33 -0600
commitee96bfa0030abe567567bcede99e1e102e925eb3 (patch)
tree032a63248e02c7b7be7589cf1ea58da38b189a3a
parent09d18ed6cb64942200b23ae186355cc36228df74 (diff)
downloadaur-ee96bfa0030abe567567bcede99e1e102e925eb3.tar.gz
remove nwjs patch as this has been fixed upstream
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD26
-rw-r--r--nwjs-patch.diff13
3 files changed, 16 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecac6df8311a..225dfdb0b4d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,45 +1,26 @@
pkgbase = popcorntime-git
- pkgdesc = BitTorrent client with integrated media player (git)
- pkgver = 0.3.10+r6429+g1537575b
+ pkgdesc = Popcorn Time is a multi-platform, free software BitTorrent client that includes an integrated media player. Desktop ( Windows / Mac / Linux ) a Butter-Project Fork
+ pkgver = 0.3.10+r6475+gef48d491
pkgrel = 1
- url = https://popcorntime.sh
+ url = https://popcorntime.app
arch = i686
arch = x86_64
license = GPL3
makedepends = git
makedepends = yarn
makedepends = npm
- depends = alsa-lib
- depends = atk
- depends = cairo
- depends = gdk-pixbuf2
depends = gtk3
- depends = libcups
- depends = libx11
- depends = libxcb
- depends = libxcomposite
- depends = libxcursor
- depends = libxdamage
- depends = libxext
- depends = libxfixes
- depends = libxi
- depends = libxrandr
- depends = libxrender
depends = libxss
- depends = libxtst
- depends = nspr
depends = nss
- depends = pango
+ depends = nodejs
provides = popcorntime
conflicts = popcorntime
conflicts = popcorntime-ce
options = !strip
source = git+https://github.com/popcorn-official/popcorn-desktop#branch=development
source = popcorntime.desktop
- source = nwjs-patch.diff
sha512sums = SKIP
sha512sums = abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd
- sha512sums = 4749e7e521b0e784a956231baccb0841a0f28a7f7415d6e47f24ba3138e4fe88c2e6d9defcd10acbe86718a42a6b99dcbddaa20d95df584c71ad2ad653a180cf
pkgname = popcorntime-git
diff --git a/PKGBUILD b/PKGBUILD
index ebf20884381e..d93d1f14903b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,31 @@
# Contributor: FirstAirBender <noblechuk5 [at] web [dot] de>
pkgname=popcorntime-git
-pkgver=0.3.10+r6429+g1537575b
+pkgver=0.3.10+r6475+gef48d491
pkgrel=1
-pkgdesc='BitTorrent client with integrated media player (git)'
+pkgdesc='Popcorn Time is a multi-platform, free software BitTorrent client that includes an integrated media player. Desktop ( Windows / Mac / Linux ) a Butter-Project Fork'
arch=(i686 x86_64)
-url=https://popcorntime.sh
+url=https://popcorntime.app
license=(GPL3)
-depends=(alsa-lib atk cairo gdk-pixbuf2 gtk3 libcups libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango)
+depends=(gtk3 libxss nss nodejs)
makedepends=(git yarn npm)
provides=(popcorntime)
conflicts=(popcorntime popcorntime-ce)
options=(!strip)
source=(git+https://github.com/popcorn-official/popcorn-desktop#branch=development
- popcorntime.desktop
- nwjs-patch.diff)
+ popcorntime.desktop)
sha512sums=('SKIP'
- 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd'
- '4749e7e521b0e784a956231baccb0841a0f28a7f7415d6e47f24ba3138e4fe88c2e6d9defcd10acbe86718a42a6b99dcbddaa20d95df584c71ad2ad653a180cf')
+ 'abf5d406467422168944244b95eac0d2c23ca4140cd803afeea852e9a15a5176a019a5772be919234fe01ceec0d8d135158900e828144b0079018015662f7dcd')
pkgver() {
cd popcorn-desktop
echo $(git tag)+r$(git rev-list --count HEAD)+g$(git rev-parse --short HEAD)
}
-prepare() {
- cd popcorn-desktop
- patch -p1 --binary < "$srcdir/nwjs-patch.diff"
-}
+# prepare() {
+# cd popcorn-desktop
+# patch -p1 --binary < "$srcdir/nwjs-patch.diff"
+# }
build() {
cd popcorn-desktop
@@ -46,10 +44,10 @@ package() {
install -d "$pkgdir"/usr/{share,bin}
cp -a build/Popcorn-Time/$([ $CARCH = x86_64 ] && echo linux64 || echo linux32) \
- "$pkgdir"/usr/share/popcorntime
+ "$pkgdir/usr/share/popcorntime"
# Fix file permissions
- find "$pkgdir"/usr/share/popcorntime -type f -not -name Popcorn-Time -exec chmod 644 {} +
+ find "$pkgdir/usr/share/popcorntime" -type f -not -name Popcorn-Time -exec chmod 644 {} +
ln -s /usr/share/popcorntime/Popcorn-Time "$pkgdir"/usr/bin/popcorntime
diff --git a/nwjs-patch.diff b/nwjs-patch.diff
deleted file mode 100644
index b76a0dea7252..000000000000
--- a/nwjs-patch.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/gulpfile.js b/gulpfile.js
-index 989cb2f4..3124e8be 100644
---- a/gulpfile.js
-+++ b/gulpfile.js
-@@ -3,7 +3,7 @@
- /********
- * setup *
- ********/
--const nwVersion = '0.33.4',
-+const nwVersion = '0.39.2',
- availablePlatforms = ['linux32', 'linux64', 'win32', 'win64', 'osx64'],
- releasesDir = 'build',
- nwFlavor = 'sdk';