summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAuguste Pop2015-06-15 12:54:06 +0800
committerAuguste Pop2015-06-15 12:54:06 +0800
commitdec98f348f35127fd5f1a9eae402b2266795f415 (patch)
treeb70d7f1c9f5587195f64797300e5f8c3016fa1ed
downloadaur-popeye.tar.gz
migrate from aur
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ebdbd587dd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = popeye
+ pkgdesc = A chess problem solving and testing software
+ pkgver = 4.69
+ pkgrel = 1
+ url = http://sourceforge.net/projects/popeye-chess/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = http://downloads.sourceforge.net/project/popeye-chess/Popeye/4.69/popeye-4.69-sources.zip
+ md5sums = 507191b2d95f5937c112541b92f10c26
+
+pkgname = popeye
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2da33f9a646
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Auguste Pop <auguste [at] gmail [dot] com>
+
+pkgname=popeye
+pkgver=4.69
+pkgrel=1
+pkgdesc="A chess problem solving and testing software"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/popeye-chess/"
+license=('GPL2')
+source=("http://downloads.sourceforge.net/project/${pkgname}-chess/Popeye/${pkgver}/${pkgname}-${pkgver}-sources.zip")
+md5sums=('507191b2d95f5937c112541b92f10c26')
+
+build()
+{
+ cd "$srcdir/$pkgver"
+ CFLAGS="$CFLAGS -march=native -mtune=native" make -f makefile.unx
+}
+
+package()
+{
+ cd "$srcdir/$pkgver"
+
+ install -m 755 -D py "$pkgdir/usr/bin/py"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -m 644 py-*.txt "$pkgdir/usr/share/doc/$pkgname"
+}