summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2020-01-24 12:24:00 +0000
committerPaul Gideon Dann2020-01-24 12:24:00 +0000
commit39246c68ecc7e60d217c132a2108fdca623a9470 (patch)
treea636758b37bb162e91247595780c1f746a1a6dbc
parenta64a52f7ebc11fdd7f5222fd480d6a9ad0189600 (diff)
downloadaur-39246c68ecc7e60d217c132a2108fdca623a9470.tar.gz
Update for Poppler 0.84.0
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch10
-rw-r--r--0002-Setting-default-Qt5-backend-to-Cairo.patch6
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch26
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch8
-rw-r--r--PKGBUILD12
6 files changed, 41 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8b2e60e18ee..bab8e1cd9940 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.82.0
+ pkgver = 0.84.0
pkgrel = 1
url = https://github.com/giddie/poppler-cairo-backend
arch = i686
@@ -10,22 +10,22 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt5-base
depends = cairo
- depends = poppler>=0.82.0
- provides = poppler-qt=0.82.0
- provides = poppler-qt5=0.82.0
+ depends = poppler>=0.84.0
+ provides = poppler-qt=0.84.0
+ provides = poppler-qt5=0.84.0
conflicts = poppler-qt
conflicts = poppler-qt4
conflicts = poppler-qt5
- source = http://poppler.freedesktop.org/poppler-0.82.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.84.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt5-wrapper.patch
source = 0002-Setting-default-Qt5-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = 4d6106c2382c5e66072e0b355acc3640
- md5sums = f31f432315c9312754df0f609178d947
- md5sums = 5e2a29257eea07ff3372e28e89679433
- md5sums = 9bdd2b300287685a00f6b4ec63f345ed
- md5sums = 8ed4526a04b880acd370ca198f5df559
+ md5sums = e14a8aca8809908ad4364c32c17bcb92
+ md5sums = 2aefa37d415d1f036eb4a836582aea8e
+ md5sums = 799cd74020f6afd680ecdbddf6b8281d
+ md5sums = 9abe68a954e5018a429aeb1d56aa58d5
+ md5sums = 8ff59d6d9b90bdbef531cb2fc8712a15
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 9634d3f2ce5a..a916d07c68e6 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From 3a7e0da0618def03a1913ceb0b1f4543f2ea32ef Mon Sep 17 00:00:00 2001
+From c9ef97b68af1327131793d68d273e751a7d90329 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index ca1f2478..af19e065 100644
+index 643f56a1..eaadd0c0 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -66,7 +66,7 @@ index ba9b86cd..d4336d3f 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 69006754..8b31ec60 100644
+index c9987761..034b9c2b 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
@@ -48,6 +48,7 @@
@@ -168,7 +168,7 @@ index 69006754..8b31ec60 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index 1460690f..96f1b986 100644
+index c501f67f..e9ec5f10 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
@@ -1151,7 +1151,8 @@ delete it;
@@ -198,5 +198,5 @@ index 5abcbc45..99c12b9f 100644
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
--
-2.24.0
+2.24.1
diff --git a/0002-Setting-default-Qt5-backend-to-Cairo.patch b/0002-Setting-default-Qt5-backend-to-Cairo.patch
index 23069a10a73f..53d36a9706db 100644
--- a/0002-Setting-default-Qt5-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt5-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From c82ac5c7d6c1009afbe00a0a62e051e39f40730e Mon Sep 17 00:00:00 2001
+From 6cc2fe9d62aeef19ae68ffca81de9465753fc8fa Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:37:38 +0100
Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
@@ -8,7 +8,7 @@ Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qt5/src/poppler-private.cc b/qt5/src/poppler-private.cc
-index 6553eb08..93a4e0a2 100644
+index 3c9bf512..33906aa0 100644
--- a/qt5/src/poppler-private.cc
+++ b/qt5/src/poppler-private.cc
@@ -255,7 +255,7 @@ namespace Debug {
@@ -21,5 +21,5 @@ index 6553eb08..93a4e0a2 100644
m_hints = 0;
m_optContentModel = nullptr;
--
-2.24.0
+2.24.1
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index a7bb1a72ce5e..0f7f2d341b9f 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From 525a5ce46ce45f3125b2b9e502e7ac680f2672d7 Mon Sep 17 00:00:00 2001
+From 93573105c0c73cee4acb451bcb9e99a34ce2daea Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -74,10 +74,10 @@ index 78d24bb5..d482ceb5 100644
g_timer_stop (timer);
diff --git a/glib/poppler-page.cc b/glib/poppler-page.cc
-index 8b5b4da0..709b760e 100644
+index 319edc50..71752304 100644
--- a/glib/poppler-page.cc
+++ b/glib/poppler-page.cc
-@@ -2447,3 +2447,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
+@@ -2438,3 +2438,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
return g_list_reverse(attributes);
}
@@ -104,7 +104,7 @@ index f99f0920..8ff914f4 100644
/* A rectangle on a page, with coordinates in PDF points. */
#define POPPLER_TYPE_RECTANGLE (poppler_rectangle_get_type ())
diff --git a/poppler/CairoFontEngine.cc b/poppler/CairoFontEngine.cc
-index bcfa0954..aa05fe12 100644
+index 1f637cf5..3de0a45e 100644
--- a/poppler/CairoFontEngine.cc
+++ b/poppler/CairoFontEngine.cc
@@ -124,7 +124,7 @@ CairoFont::getSubstitutionCorrection(GfxFont *gfxFont)
@@ -135,7 +135,7 @@ index bcfa0954..aa05fe12 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index cbfd0bdd..b10b7e32 100644
+index eac8ed09..b842818f 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
@@ -206,6 +206,13 @@ void CairoOutputDev::setCairo(cairo_t *c)
@@ -152,7 +152,7 @@ index cbfd0bdd..b10b7e32 100644
/* save the initial matrix so that we can use it for type3 fonts. */
//XXX: is this sufficient? could we miss changes to the matrix somehow?
cairo_get_matrix(cairo, &orig_matrix);
-@@ -1432,6 +1439,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+@@ -1431,6 +1438,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
void CairoOutputDev::endString(GfxState *state)
{
int render;
@@ -160,7 +160,7 @@ index cbfd0bdd..b10b7e32 100644
if (!currentFont)
return;
-@@ -1449,6 +1457,18 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1448,6 +1456,18 @@ void CairoOutputDev::endString(GfxState *state)
goto finish;
}
@@ -179,7 +179,7 @@ index cbfd0bdd..b10b7e32 100644
if (!(render & 1)) {
LOG (printf ("fill string\n"));
cairo_set_source (cairo, fill_pattern);
-@@ -1499,6 +1519,10 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1498,6 +1518,10 @@ void CairoOutputDev::endString(GfxState *state)
}
finish:
@@ -191,10 +191,10 @@ index cbfd0bdd..b10b7e32 100644
glyphs = nullptr;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index ec2b4b35..8fecd682 100644
+index 58c36fcb..1aea6090 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
-@@ -4604,6 +4604,47 @@ void Gfx::doImage(Object *ref, Stream *str, bool inlineImg) {
+@@ -4602,6 +4602,47 @@ void Gfx::doImage(Object *ref, Stream *str, bool inlineImg) {
error(errSyntaxError, getPos(), "Bad image parameters");
}
@@ -257,7 +257,7 @@ index e8ff605f..f615d789 100644
void drawForm(Object *str, Dict *resDict, const double *matrix, const double *bbox,
diff --git a/poppler/Page.cc b/poppler/Page.cc
-index d137ec4b..5950b964 100644
+index 87621ca2..87039190 100644
--- a/poppler/Page.cc
+++ b/poppler/Page.cc
@@ -336,6 +336,19 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
@@ -278,8 +278,8 @@ index d137ec4b..5950b964 100644
+}
+
void Page::replaceXRef(XRef *xrefA) {
- Object obj1;
Dict *pageDict = pageObj.getDict()->copy(xrefA);
+ xref = xrefA;
diff --git a/poppler/Page.h b/poppler/Page.h
index 01f056f9..d6547a79 100644
--- a/poppler/Page.h
@@ -295,5 +295,5 @@ index 01f056f9..d6547a79 100644
Object getAnnotsObject(XRef *xrefA = nullptr) { return annotsObj.fetch(xrefA ? xrefA : xref); }
// Add a new annotation to the page
--
-2.24.0
+2.24.1
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index e1d15c102cbb..3e3ecbe27a43 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From 28de47991ea5bfe6516d2d746672df0ef272bf92 Mon Sep 17 00:00:00 2001
+From ce960d5e890abd58fae3ff669bb841b5c96d43e1 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,7 +8,7 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 17 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 36f65874..546d281d 100644
+index ef987a86..9c9fffe4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -491,23 +491,6 @@ if(TIFF_FOUND)
@@ -21,7 +21,7 @@ index 36f65874..546d281d 100644
-else()
-add_library(poppler ${poppler_SRCS})
-endif()
--set_target_properties(poppler PROPERTIES VERSION 92.0.0 SOVERSION 92)
+-set_target_properties(poppler PROPERTIES VERSION 94.0.0 SOVERSION 94)
-if(MINGW AND BUILD_SHARED_LIBS)
- get_target_property(POPPLER_SOVERSION poppler SOVERSION)
- set_target_properties(poppler PROPERTIES SUFFIX "-${POPPLER_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -36,5 +36,5 @@ index 36f65874..546d281d 100644
install(FILES
poppler/Annot.h
--
-2.24.0
+2.24.1
diff --git a/PKGBUILD b/PKGBUILD
index 31156d37a3f1..eba81cfb1887 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.82.0
+pkgver=0.84.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt5-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('4d6106c2382c5e66072e0b355acc3640'
- 'f31f432315c9312754df0f609178d947'
- '5e2a29257eea07ff3372e28e89679433'
- '9bdd2b300287685a00f6b4ec63f345ed'
- '8ed4526a04b880acd370ca198f5df559')
+md5sums=('e14a8aca8809908ad4364c32c17bcb92'
+ '2aefa37d415d1f036eb4a836582aea8e'
+ '799cd74020f6afd680ecdbddf6b8281d'
+ '9abe68a954e5018a429aeb1d56aa58d5'
+ '8ff59d6d9b90bdbef531cb2fc8712a15')
build() {
cd "${srcdir}/poppler-${pkgver}"