summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2020-07-08 11:25:29 +0100
committerPaul Gideon Dann2020-07-08 11:25:29 +0100
commit4a4e77849cd1fd9fe961bfbae422d3526b57af22 (patch)
treeeb48a3c2c0d3b4c249d6f02928fdfcdb41e5850f
parent6d6dc240e75c09b53c04d86147ad34b2bb79b84c (diff)
downloadaur-4a4e77849cd1fd9fe961bfbae422d3526b57af22.tar.gz
Update for Poppler 0.90.0
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch26
-rw-r--r--0002-Setting-default-Qt5-backend-to-Cairo.patch4
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch26
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch10
-rw-r--r--PKGBUILD12
6 files changed, 49 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5a87f3ddbef..72fd93876f9b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.88.0
+ pkgver = 0.90.0
pkgrel = 1
url = https://github.com/giddie/poppler-cairo-backend
arch = i686
@@ -10,22 +10,22 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt5-base
depends = cairo
- depends = poppler>=0.88.0
- provides = poppler-qt=0.88.0
- provides = poppler-qt5=0.88.0
+ depends = poppler>=0.90.0
+ provides = poppler-qt=0.90.0
+ provides = poppler-qt5=0.90.0
conflicts = poppler-qt
conflicts = poppler-qt4
conflicts = poppler-qt5
- source = http://poppler.freedesktop.org/poppler-0.88.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.90.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt5-wrapper.patch
source = 0002-Setting-default-Qt5-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = d9aafddce4c079c9ebc7405e42ac25ba
- md5sums = 509c1fe07f26f42fdd99b0e458d6f27b
- md5sums = 0eccec2fea8406c4b5a24a2c895e2685
- md5sums = 324828a54029ddcd040f602675a96a53
- md5sums = 68bb39cdc915e614267115054ec764cc
+ md5sums = 5af9e25d8d2b9efc0d538ce2213be22e
+ md5sums = b1a858ca760121cb90e124a8abccaf54
+ md5sums = f49c3fd78d35a10a51823cf22fdbe062
+ md5sums = d294271efda705ddf9599845d1f11278
+ md5sums = 814117bb456f8106f59562ec6783d9fe
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index be0d58866e38..d27ff02216f3 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From 42db0fc6f3eab00c3eb2ba1589a5ca8d792a2c56 Mon Sep 17 00:00:00 2001
+From 827a4c097a92a60888499d9d5e4f292e5625b038 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index e75b5730..23ec62e8 100644
+index 0247fa3f..f52e4a3b 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -39,7 +39,7 @@ index e75b5730..23ec62e8 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.24.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.25.0 SOVERSION 1)
if(MINGW AND BUILD_SHARED_LIBS)
@@ -46,6 +58,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -52,10 +52,10 @@ index e75b5730..23ec62e8 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index cba9da39..89607ca5 100644
+index cc6f01ad..882db5c8 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -709,6 +709,9 @@ namespace Poppler {
+@@ -721,6 +721,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -66,10 +66,10 @@ index cba9da39..89607ca5 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 35bec6c9..b19cd692 100644
+index 3e67fedd..170728a1 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -49,6 +49,7 @@
+@@ -50,6 +50,7 @@
#include <QtGui/QPainter>
#include <config.h>
@@ -77,7 +77,7 @@ index 35bec6c9..b19cd692 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -62,6 +63,9 @@
+@@ -63,6 +64,9 @@
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
#endif
@@ -87,7 +87,7 @@ index 35bec6c9..b19cd692 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -626,6 +630,70 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -639,6 +643,70 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -158,7 +158,7 @@ index 35bec6c9..b19cd692 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -651,6 +719,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -664,6 +732,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
return renderToArthur(&arthur_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,10 +168,10 @@ index 35bec6c9..b19cd692 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index 665f98a4..1f1eb5de 100644
+index 06f6d021..35d8cc17 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1153,7 +1153,8 @@ delete it;
+@@ -1154,7 +1154,8 @@ delete it;
*/
enum RenderBackend {
SplashBackend, ///< Splash backend
@@ -198,5 +198,5 @@ index b01d0835..561cb5dd 100644
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
--
-2.26.2
+2.27.0
diff --git a/0002-Setting-default-Qt5-backend-to-Cairo.patch b/0002-Setting-default-Qt5-backend-to-Cairo.patch
index 08d1fe2dc50d..d953635a0172 100644
--- a/0002-Setting-default-Qt5-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt5-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From d409a937a8bd240c5e20b4dc8a96295fe01e6522 Mon Sep 17 00:00:00 2001
+From a4f2390cb3695569ed09b679d381a0f80e90e0a1 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:37:38 +0100
Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
@@ -21,5 +21,5 @@ index 02fb96e6..8e3ed4a6 100644
m_hints = 0;
m_optContentModel = nullptr;
--
-2.26.2
+2.27.0
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index fc221619355f..5973df5f42a9 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From 1fd8b739df535d27f6e1ea7f6b4ad6d528741496 Mon Sep 17 00:00:00 2001
+From f7b6ba8787b2bf6c0a9c9f3b7465c88e0c9ece08 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -74,10 +74,10 @@ index 78d24bb5..d482ceb5 100644
g_timer_stop (timer);
diff --git a/glib/poppler-page.cc b/glib/poppler-page.cc
-index 7723af16..b08c0e5b 100644
+index f237bb69..73afea17 100644
--- a/glib/poppler-page.cc
+++ b/glib/poppler-page.cc
-@@ -2565,3 +2565,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
+@@ -2693,3 +2693,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
return g_list_reverse(attributes);
}
@@ -135,10 +135,10 @@ index 1f637cf5..3de0a45e 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index 34c02667..520fdb4e 100644
+index 83f1c78d..7f1442f1 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
-@@ -204,6 +204,13 @@ void CairoOutputDev::setCairo(cairo_t *c)
+@@ -205,6 +205,13 @@ void CairoOutputDev::setCairo(cairo_t *c)
}
if (c != nullptr) {
cairo = cairo_reference (c);
@@ -152,7 +152,7 @@ index 34c02667..520fdb4e 100644
/* save the initial matrix so that we can use it for type3 fonts. */
//XXX: is this sufficient? could we miss changes to the matrix somehow?
cairo_get_matrix(cairo, &orig_matrix);
-@@ -1428,6 +1435,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+@@ -1455,6 +1462,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
void CairoOutputDev::endString(GfxState *state)
{
int render;
@@ -160,7 +160,7 @@ index 34c02667..520fdb4e 100644
if (!currentFont)
return;
-@@ -1445,6 +1453,18 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1472,6 +1480,18 @@ void CairoOutputDev::endString(GfxState *state)
goto finish;
}
@@ -179,7 +179,7 @@ index 34c02667..520fdb4e 100644
if (!(render & 1)) {
LOG (printf ("fill string\n"));
cairo_set_source (cairo, fill_pattern);
-@@ -1495,6 +1515,10 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1522,6 +1542,10 @@ void CairoOutputDev::endString(GfxState *state)
}
finish:
@@ -191,10 +191,10 @@ index 34c02667..520fdb4e 100644
glyphs = nullptr;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index 9773b60c..945210d2 100644
+index 37a8996a..7f75efb1 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
-@@ -4595,6 +4595,47 @@ void Gfx::doImage(Object *ref, Stream *str, bool inlineImg) {
+@@ -4597,6 +4597,47 @@ void Gfx::doImage(Object *ref, Stream *str, bool inlineImg) {
error(errSyntaxError, getPos(), "Bad image parameters");
}
@@ -257,10 +257,10 @@ index e8ff605f..f615d789 100644
void drawForm(Object *str, Dict *resDict, const double *matrix, const double *bbox,
diff --git a/poppler/Page.cc b/poppler/Page.cc
-index 670768ab..5b87fdc3 100644
+index a875f7bd..c296555a 100644
--- a/poppler/Page.cc
+++ b/poppler/Page.cc
-@@ -341,6 +341,19 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
+@@ -342,6 +342,19 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
return dict ? dict->copy(xrefA) : nullptr;
}
@@ -295,5 +295,5 @@ index 2b19a089..57ead29c 100644
Object getAnnotsObject(XRef *xrefA = nullptr) { return annotsObj.fetch(xrefA ? xrefA : xref); }
// Add a new annotation to the page
--
-2.26.2
+2.27.0
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index 1d4901163764..ceeea3e22191 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From 83f742559e9aa85de9d57c92b653232c922d2394 Mon Sep 17 00:00:00 2001
+From 4d7f9500478ada96e135d64d3609c007a48d649d Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,10 +8,10 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 17 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 45d89346..7d92acb6 100644
+index 533abb03..6eb8b9fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -528,23 +528,6 @@ ADD_GPERF_FILE(TimesItalicWidths)
+@@ -533,23 +533,6 @@ ADD_GPERF_FILE(TimesItalicWidths)
ADD_GPERF_FILE(TimesRomanWidths)
ADD_GPERF_FILE(ZapfDingbatsWidths)
@@ -21,7 +21,7 @@ index 45d89346..7d92acb6 100644
-else()
-add_library(poppler ${poppler_SRCS})
-endif()
--set_target_properties(poppler PROPERTIES VERSION 99.0.0 SOVERSION 99)
+-set_target_properties(poppler PROPERTIES VERSION 101.0.0 SOVERSION 101)
-if(MINGW AND BUILD_SHARED_LIBS)
- get_target_property(POPPLER_SOVERSION poppler SOVERSION)
- set_target_properties(poppler PROPERTIES SUFFIX "-${POPPLER_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -36,5 +36,5 @@ index 45d89346..7d92acb6 100644
install(FILES
poppler/Annot.h
--
-2.26.2
+2.27.0
diff --git a/PKGBUILD b/PKGBUILD
index fc7cc978f665..32cf22407bb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.88.0
+pkgver=0.90.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt5-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('d9aafddce4c079c9ebc7405e42ac25ba'
- '509c1fe07f26f42fdd99b0e458d6f27b'
- '0eccec2fea8406c4b5a24a2c895e2685'
- '324828a54029ddcd040f602675a96a53'
- '68bb39cdc915e614267115054ec764cc')
+md5sums=('5af9e25d8d2b9efc0d538ce2213be22e'
+ 'b1a858ca760121cb90e124a8abccaf54'
+ 'f49c3fd78d35a10a51823cf22fdbe062'
+ 'd294271efda705ddf9599845d1f11278'
+ '814117bb456f8106f59562ec6783d9fe')
build() {
cd "${srcdir}/poppler-${pkgver}"