summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2018-05-23 14:37:56 +0100
committerPaul Gideon Dann2018-05-23 14:38:21 +0100
commit5a210b22ca8b865d74a663d7bb8242214e2e6fde (patch)
tree3595fbc57c926ba4de6f883d4400b8dd755a01d5
parentf3f1e9b1124dc2481cb0e7646267fe27613d1afb (diff)
downloadaur-5a210b22ca8b865d74a663d7bb8242214e2e6fde.tar.gz
Update for Poppler 0.64.0
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch30
-rw-r--r--0002-Setting-default-Qt5-backend-to-Cairo.patch8
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch40
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch10
-rw-r--r--PKGBUILD12
6 files changed, 61 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d553a74dd97f..079a2f1fa826 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Apr 4 15:56:26 UTC 2018
+# Wed May 23 13:38:15 UTC 2018
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.63.0
+ pkgver = 0.64.0
pkgrel = 1
url = https://github.com/giddie/poppler-cairo-backend
arch = i686
@@ -12,22 +12,22 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt5-base
depends = cairo
- depends = poppler>=0.63.0
- provides = poppler-qt=0.63.0
- provides = poppler-qt5=0.63.0
+ depends = poppler>=0.64.0
+ provides = poppler-qt=0.64.0
+ provides = poppler-qt5=0.64.0
conflicts = poppler-qt
conflicts = poppler-qt4
conflicts = poppler-qt5
- source = http://poppler.freedesktop.org/poppler-0.63.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.64.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt5-wrapper.patch
source = 0002-Setting-default-Qt5-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = 66a54da4896b1408611699feda5c1821
- md5sums = 45b1cb3f22736d743753b8f343d06087
- md5sums = 4b41a9385811d24747820dec0b240045
- md5sums = fe0f21ce215ae3c92917c79b1c9c2cb4
- md5sums = d6913e1dd7449b271fa2fd296cfda457
+ md5sums = f7f687ebb60004f8ad61994575018044
+ md5sums = 912040a5f767a7b28f138238914d81a5
+ md5sums = 4f3a6fb3dc2ca63320720a64a4ce4b3b
+ md5sums = 1a16d27e7b83e7cdfc8e4d1e59035ac5
+ md5sums = ae1a96566ea48135cc83d2f4bbd6d7e0
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 5f0cfdcff2c6..533a851da087 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,18 +1,18 @@
-From fb0f060b9528e38122026fc5c5074b742a712cd8 Mon Sep 17 00:00:00 2001
+From 2967bef4990c00b014ec02cd18017f0a618c36db Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
---
- qt5/src/CMakeLists.txt | 15 ++++++++++
+ qt5/src/CMakeLists.txt | 15 ++++++++
qt5/src/poppler-document.cc | 3 ++
- qt5/src/poppler-page.cc | 70 +++++++++++++++++++++++++++++++++++++++++++++
+ qt5/src/poppler-page.cc | 70 +++++++++++++++++++++++++++++++++++++
qt5/src/poppler-qt5.h | 3 +-
- qt5/tests/CMakeLists.txt | 5 ++++
+ qt5/tests/CMakeLists.txt | 5 +++
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 5ae42f52..04e3fcdf 100644
+index 7100ebb3..3582fdbb 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -7,6 +7,11 @@ include_directories(
@@ -39,7 +39,7 @@ index 5ae42f52..04e3fcdf 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.13.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.14.0 SOVERSION 1)
if(MINGW)
@@ -36,6 +48,9 @@ if(MINGW)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -52,10 +52,10 @@ index 5ae42f52..04e3fcdf 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 0eeb923f..e1b7a71c 100644
+index 102bd820..4f20ebe7 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -672,6 +672,9 @@ namespace Poppler {
+@@ -673,6 +673,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -66,10 +66,10 @@ index 0eeb923f..e1b7a71c 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 381a608b..21e96fe2 100644
+index b48ee959..d2d52069 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -45,6 +45,7 @@
+@@ -46,6 +46,7 @@
#include <QtGui/QPainter>
#include <config.h>
@@ -77,7 +77,7 @@ index 381a608b..21e96fe2 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -58,6 +59,9 @@
+@@ -59,6 +60,9 @@
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
#endif
@@ -87,7 +87,7 @@ index 381a608b..21e96fe2 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -596,6 +600,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
+@@ -621,6 +625,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
img = tmpimg;
break;
}
@@ -158,7 +158,7 @@ index 381a608b..21e96fe2 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -618,6 +686,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -643,6 +711,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
QImageDumpingArthurOutputDev arthur_output(painter, nullptr);
return renderToArthur(&arthur_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,7 +168,7 @@ index 381a608b..21e96fe2 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index 3adbf02f..5422482a 100644
+index b70644f7..f4b1ba71 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
@@ -1054,7 +1054,8 @@ delete it;
@@ -198,5 +198,5 @@ index 1e67e6ec..9131568d 100644
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
--
-2.16.3
+2.17.0
diff --git a/0002-Setting-default-Qt5-backend-to-Cairo.patch b/0002-Setting-default-Qt5-backend-to-Cairo.patch
index ffa2db435be9..4cf2f96a6fb1 100644
--- a/0002-Setting-default-Qt5-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt5-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From cced8f3763d151f3876689e8efee568c9404e1b0 Mon Sep 17 00:00:00 2001
+From 4030fb1de971c9d56d7eda0f449f6b29641f6275 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:37:38 +0100
Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
@@ -8,10 +8,10 @@ Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qt5/src/poppler-private.cc b/qt5/src/poppler-private.cc
-index e3a540ab..6fcccf29 100644
+index 78751f8e..e0060d5d 100644
--- a/qt5/src/poppler-private.cc
+++ b/qt5/src/poppler-private.cc
-@@ -243,7 +243,7 @@ namespace Debug {
+@@ -244,7 +244,7 @@ namespace Debug {
void DocumentData::init()
{
@@ -21,5 +21,5 @@ index e3a540ab..6fcccf29 100644
m_hints = 0;
m_optContentModel = nullptr;
--
-2.16.3
+2.17.0
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index 31e95086b211..14fec8ee3ef0 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From a5b9c280ba0870c8e61f7068b08f4b0353b1387e Mon Sep 17 00:00:00 2001
+From 5fb553246687437173e97e68a28118106e723f45 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -6,15 +6,15 @@ Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
Source:
https://github.com/zhou13/poppler-subpixel/blob/master/poppler/poppler-subpixel.patch
---
- glib/demo/render.c | 25 ++++++++++++++++++---
- glib/poppler-page.cc | 10 +++++++++
+ glib/demo/render.c | 25 +++++++++++++++--
+ glib/poppler-page.cc | 10 +++++++
glib/poppler-page.h | 1 +
- poppler/CairoFontEngine.cc | 6 ++---
- poppler/CairoOutputDev.cc | 24 ++++++++++++++++++++
- poppler/Gfx.cc | 56 ++++++++++++++++++++++++++++++++++++++++++++++
- poppler/Gfx.h | 3 +++
- poppler/Page.cc | 14 ++++++++++++
- poppler/Page.h | 3 +++
+ poppler/CairoFontEngine.cc | 6 ++--
+ poppler/CairoOutputDev.cc | 24 ++++++++++++++++
+ poppler/Gfx.cc | 56 ++++++++++++++++++++++++++++++++++++++
+ poppler/Gfx.h | 3 ++
+ poppler/Page.cc | 14 ++++++++++
+ poppler/Page.h | 3 ++
9 files changed, 136 insertions(+), 6 deletions(-)
diff --git a/glib/demo/render.c b/glib/demo/render.c
@@ -135,10 +135,10 @@ index 91deac46..aad28564 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index f0c4b040..cc26f431 100644
+index 18124b8f..b5ffe071 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
-@@ -213,6 +213,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
+@@ -214,6 +214,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
}
if (cairo != nullptr) {
this->cairo = cairo_reference (cairo);
@@ -152,7 +152,7 @@ index f0c4b040..cc26f431 100644
/* save the initial matrix so that we can use it for type3 fonts. */
//XXX: is this sufficient? could we miss changes to the matrix somehow?
cairo_get_matrix(cairo, &orig_matrix);
-@@ -1440,6 +1447,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+@@ -1441,6 +1448,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
void CairoOutputDev::endString(GfxState *state)
{
int render;
@@ -160,7 +160,7 @@ index f0c4b040..cc26f431 100644
if (!currentFont)
return;
-@@ -1457,6 +1465,18 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1458,6 +1466,18 @@ void CairoOutputDev::endString(GfxState *state)
goto finish;
}
@@ -179,7 +179,7 @@ index f0c4b040..cc26f431 100644
if (!(render & 1)) {
LOG (printf ("fill string\n"));
cairo_set_source (cairo, fill_pattern);
-@@ -1507,6 +1527,10 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1508,6 +1528,10 @@ void CairoOutputDev::endString(GfxState *state)
}
finish:
@@ -191,10 +191,10 @@ index f0c4b040..cc26f431 100644
glyphs = nullptr;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index 4f6c33f8..22a59256 100644
+index 08132072..dbc822ec 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
-@@ -4605,6 +4605,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
+@@ -4614,6 +4614,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
error(errSyntaxError, getPos(), "Bad image parameters");
}
@@ -258,10 +258,10 @@ index 4f6c33f8..22a59256 100644
// check the effect of compositing objects as a group:
// look for ExtGState entries with ca != 1 or CA != 1 or BM != normal
diff --git a/poppler/Gfx.h b/poppler/Gfx.h
-index 8e2f66cc..62328f8c 100644
+index 2ea0d9fa..3f0b4ce7 100644
--- a/poppler/Gfx.h
+++ b/poppler/Gfx.h
-@@ -192,6 +192,9 @@ public:
+@@ -195,6 +195,9 @@ public:
// Get the current graphics state object.
GfxState *getState() { return state; }
@@ -297,7 +297,7 @@ index d4799dd1..4a0e559e 100644
Object obj1;
Dict *pageDict = pageObj.getDict()->copy(xrefA);
diff --git a/poppler/Page.h b/poppler/Page.h
-index 61570791..eb747c8d 100644
+index 7151ee5b..41c1fd75 100644
--- a/poppler/Page.h
+++ b/poppler/Page.h
@@ -185,6 +185,9 @@ public:
@@ -311,5 +311,5 @@ index 61570791..eb747c8d 100644
Object getAnnotsObject(XRef *xrefA = nullptr) { return annotsObj.fetch(xrefA ? xrefA : xref); }
// Add a new annotation to the page
--
-2.16.3
+2.17.0
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index a4cef0245072..76a9e4a112fe 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From a54cc3fc192f46a521086b9f8f76d8496ed7182f Mon Sep 17 00:00:00 2001
+From 02e73aefa8cbca851ffe2f8c0d5fb6829ab1afdf Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,10 +8,10 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 18 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index eecd41fb..c300e69f 100644
+index ac186d53..a3d94e82 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -476,24 +476,6 @@ if(TIFF_FOUND)
+@@ -484,24 +484,6 @@ if(TIFF_FOUND)
set(poppler_LIBS ${poppler_LIBS} ${TIFF_LIBRARIES})
endif()
@@ -22,7 +22,7 @@ index eecd41fb..c300e69f 100644
-else()
-add_library(poppler ${poppler_SRCS})
-endif()
--set_target_properties(poppler PROPERTIES VERSION 74.0.0 SOVERSION 74)
+-set_target_properties(poppler PROPERTIES VERSION 75.0.0 SOVERSION 75)
-if(MINGW)
- get_target_property(POPPLER_SOVERSION poppler SOVERSION)
- set_target_properties(poppler PROPERTIES SUFFIX "-${POPPLER_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -37,5 +37,5 @@ index eecd41fb..c300e69f 100644
install(FILES
poppler/Annot.h
--
-2.16.3
+2.17.0
diff --git a/PKGBUILD b/PKGBUILD
index ba284f29210d..73f83047f41d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.63.0
+pkgver=0.64.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt5-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('66a54da4896b1408611699feda5c1821'
- '45b1cb3f22736d743753b8f343d06087'
- '4b41a9385811d24747820dec0b240045'
- 'fe0f21ce215ae3c92917c79b1c9c2cb4'
- 'd6913e1dd7449b271fa2fd296cfda457')
+md5sums=('f7f687ebb60004f8ad61994575018044'
+ '912040a5f767a7b28f138238914d81a5'
+ '4f3a6fb3dc2ca63320720a64a4ce4b3b'
+ '1a16d27e7b83e7cdfc8e4d1e59035ac5'
+ 'ae1a96566ea48135cc83d2f4bbd6d7e0')
build() {
cd "${srcdir}/poppler-${pkgver}"