summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2017-10-17 16:11:37 +0100
committerPaul Gideon Dann2017-10-17 16:11:37 +0100
commit765137d0e55aaa6ec700ea5361950a82b8abee40 (patch)
treeb3379508c8c9c93eb158cd9b75d9a6f17c1fa22e
parentf501336a358adc3615e97d7313b9f8cfb4832e06 (diff)
downloadaur-765137d0e55aaa6ec700ea5361950a82b8abee40.tar.gz
Update for Poppler 0.60.1
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Cairo-backend-added-to-Qt4-wrapper.patch16
-rw-r--r--0002-Setting-default-Qt4-backend-to-Cairo.patch6
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch38
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch16
-rw-r--r--PKGBUILD12
6 files changed, 55 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2487df873c7..698b2490dc21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Aug 7 11:53:47 UTC 2017
+# Tue Oct 17 15:11:20 UTC 2017
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.57.0
+ pkgver = 0.60.1
pkgrel = 1
url = https://github.com/giddie/poppler-qt4-cairo-backend
arch = i686
@@ -12,21 +12,21 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt4
depends = cairo
- depends = poppler>=0.57.0
- provides = poppler-qt=0.57.0
- provides = poppler-qt4=0.57.0
+ depends = poppler>=0.60.1
+ provides = poppler-qt=0.60.1
+ provides = poppler-qt4=0.60.1
conflicts = poppler-qt
conflicts = poppler-qt4
- source = http://poppler.freedesktop.org/poppler-0.57.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.60.1.tar.xz
source = 0001-Cairo-backend-added-to-Qt4-wrapper.patch
source = 0002-Setting-default-Qt4-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = bc5a191741604552c90d484103229374
- md5sums = 4c5107ad50490c36d592a61de4f1e638
- md5sums = 0415d51b3e5b338f48f7bb77f1ae7b83
- md5sums = daccf4875ca2de644590c990dc127ad1
- md5sums = bb93fb6564e2a3d6bfc6c94a7da78fbf
+ md5sums = 7648416d51a6e9fbc4a75b6f8b53dd7c
+ md5sums = cd3400daeea52082e4a5d4395de5d917
+ md5sums = b50d1feba1e8f23740b55a7fe5f432c8
+ md5sums = 17c816aea87f765ed26a29923de9b4a6
+ md5sums = 8dcdd57d7e92ef7d96c8aaf06cd4c862
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt4-wrapper.patch b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
index e2cad3e21405..7fe7fca06c16 100644
--- a/0001-Cairo-backend-added-to-Qt4-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
@@ -1,4 +1,4 @@
-From 8ca0639d3184f13987a8865d21d65b6f6c567c6b Mon Sep 17 00:00:00 2001
+From f85cda566865fb4f6be2dcb8b84c6dcad4d6f7de Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 11:42:28 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt4/src/CMakeLists.txt b/qt4/src/CMakeLists.txt
-index 18c35f8c..d0c87764 100644
+index b803f755..1b56b21e 100644
--- a/qt4/src/CMakeLists.txt
+++ b/qt4/src/CMakeLists.txt
@@ -6,6 +6,11 @@ include_directories(
@@ -47,12 +47,12 @@ index 18c35f8c..d0c87764 100644
+endif (HAVE_CAIRO)
if(MSVC)
target_link_libraries(poppler-qt4 poppler ${poppler_LIBS})
- endif(MSVC)
+ endif()
diff --git a/qt4/src/poppler-document.cc b/qt4/src/poppler-document.cc
-index 7f8abfa7..a6b4c8e0 100644
+index f5ac11eb..a5cf5930 100644
--- a/qt4/src/poppler-document.cc
+++ b/qt4/src/poppler-document.cc
-@@ -698,6 +698,9 @@ namespace Poppler {
+@@ -693,6 +693,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -63,7 +63,7 @@ index 7f8abfa7..a6b4c8e0 100644
}
diff --git a/qt4/src/poppler-page.cc b/qt4/src/poppler-page.cc
-index fb6a036d..58c3412d 100644
+index 1a55bb57..bc88ce0d 100644
--- a/qt4/src/poppler-page.cc
+++ b/qt4/src/poppler-page.cc
@@ -41,6 +41,7 @@
@@ -179,7 +179,7 @@ index 1b5afb2e..8e3cb26b 100644
/**
diff --git a/qt4/tests/CMakeLists.txt b/qt4/tests/CMakeLists.txt
-index bba868f1..8c404716 100644
+index a01a638a..69ce63bc 100644
--- a/qt4/tests/CMakeLists.txt
+++ b/qt4/tests/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -195,5 +195,5 @@ index bba868f1..8c404716 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.13.2
+2.14.2
diff --git a/0002-Setting-default-Qt4-backend-to-Cairo.patch b/0002-Setting-default-Qt4-backend-to-Cairo.patch
index f81110c49144..5c0490e0c36b 100644
--- a/0002-Setting-default-Qt4-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt4-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From 9c69f88e917944808daf233e05c30121842d96a0 Mon Sep 17 00:00:00 2001
+From 53aee235bf1f8ba63c371580bb742c710ffd8438 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 13:17:29 +0100
Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
@@ -8,7 +8,7 @@ Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qt4/src/poppler-private.cc b/qt4/src/poppler-private.cc
-index 6c4d782e..8cfba6f6 100644
+index 1338a185..b6ca064a 100644
--- a/qt4/src/poppler-private.cc
+++ b/qt4/src/poppler-private.cc
@@ -245,7 +245,7 @@ namespace Debug {
@@ -21,5 +21,5 @@ index 6c4d782e..8cfba6f6 100644
m_hints = 0;
m_optContentModel = 0;
--
-2.13.2
+2.14.2
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index 64dd76604753..0ce089d2c47d 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From 4d4034067f6446b42ab7db34d72ea13223582467 Mon Sep 17 00:00:00 2001
+From 8f7f0789e20308d9089d9fd6adb0b9c38f9fda95 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -74,10 +74,10 @@ index 78d24bb5..d482ceb5 100644
g_timer_stop (timer);
diff --git a/glib/poppler-page.cc b/glib/poppler-page.cc
-index 3d63bfdd..3dc55858 100644
+index a44edac6..9cb85271 100644
--- a/glib/poppler-page.cc
+++ b/glib/poppler-page.cc
-@@ -2424,3 +2424,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
+@@ -2419,3 +2419,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
return g_list_reverse(attributes);
}
@@ -104,7 +104,7 @@ index fdbfd38e..0f02a3af 100644
/* A rectangle on a page, with coordinates in PDF points. */
#define POPPLER_TYPE_RECTANGLE (poppler_rectangle_get_type ())
diff --git a/poppler/CairoFontEngine.cc b/poppler/CairoFontEngine.cc
-index 6676f898..3c8fe815 100644
+index b56d100c..44ab2bef 100644
--- a/poppler/CairoFontEngine.cc
+++ b/poppler/CairoFontEngine.cc
@@ -132,7 +132,7 @@ CairoFont::getSubstitutionCorrection(GfxFont *gfxFont)
@@ -135,10 +135,10 @@ index 6676f898..3c8fe815 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index 2946c924..78f85c0b 100644
+index ffd39ef7..12f198e2 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
-@@ -204,6 +204,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
+@@ -208,6 +208,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
}
if (cairo != NULL) {
this->cairo = cairo_reference (cairo);
@@ -152,7 +152,7 @@ index 2946c924..78f85c0b 100644
/* save the initial matrix so that we can use it for type3 fonts. */
//XXX: is this sufficient? could we miss changes to the matrix somehow?
cairo_get_matrix(cairo, &orig_matrix);
-@@ -1431,6 +1438,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+@@ -1435,6 +1442,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
void CairoOutputDev::endString(GfxState *state)
{
int render;
@@ -160,7 +160,7 @@ index 2946c924..78f85c0b 100644
if (!currentFont)
return;
-@@ -1448,6 +1456,18 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1452,6 +1460,18 @@ void CairoOutputDev::endString(GfxState *state)
goto finish;
}
@@ -179,7 +179,7 @@ index 2946c924..78f85c0b 100644
if (!(render & 1)) {
LOG (printf ("fill string\n"));
cairo_set_source (cairo, fill_pattern);
-@@ -1498,6 +1518,10 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1502,6 +1522,10 @@ void CairoOutputDev::endString(GfxState *state)
}
finish:
@@ -191,10 +191,10 @@ index 2946c924..78f85c0b 100644
glyphs = NULL;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index 37220280..1ae46f40 100644
+index eaef798f..cced8572 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
-@@ -4730,6 +4730,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
+@@ -4616,6 +4616,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
error(errSyntaxError, getPos(), "Bad image parameters");
}
@@ -258,7 +258,7 @@ index 37220280..1ae46f40 100644
// check the effect of compositing objects as a group:
// look for ExtGState entries with ca != 1 or CA != 1 or BM != normal
diff --git a/poppler/Gfx.h b/poppler/Gfx.h
-index a82f9f4a..6a7e2c78 100644
+index 293f4551..5dff6fd3 100644
--- a/poppler/Gfx.h
+++ b/poppler/Gfx.h
@@ -186,6 +186,9 @@ public:
@@ -272,10 +272,10 @@ index a82f9f4a..6a7e2c78 100644
void drawForm(Object *str, Dict *resDict, double *matrix, double *bbox,
diff --git a/poppler/Page.cc b/poppler/Page.cc
-index dca52e4f..3f633423 100644
+index 197e2bef..a76ec219 100644
--- a/poppler/Page.cc
+++ b/poppler/Page.cc
-@@ -372,6 +372,20 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
+@@ -348,6 +348,20 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
return dict ? dict->copy(xrefA) : NULL;
}
@@ -297,19 +297,19 @@ index dca52e4f..3f633423 100644
Object obj1;
Dict *pageDict = pageObj.getDict()->copy(xrefA);
diff --git a/poppler/Page.h b/poppler/Page.h
-index 2aaabae9..a49d34f1 100644
+index 2a597131..3d44a7ae 100644
--- a/poppler/Page.h
+++ b/poppler/Page.h
-@@ -179,6 +179,9 @@ public:
- Dict *getResourceDict();
+@@ -182,6 +182,9 @@ public:
+ Object *getResourceDictObject();
Dict *getResourceDictCopy(XRef *xrefA);
+ // Whether the content in this page supports subpixel rendering (lcdfilter)
+ GBool supportSubpixelRendering(OutputDev *out);
+
// Get annotations array.
- Object *getAnnots(Object *obj, XRef *xrefA = NULL) { return annotsObj.fetch((xrefA == NULL) ? xref : xrefA, obj); }
+ Object getAnnotsObject(XRef *xrefA = nullptr) { return annotsObj.fetch(xrefA ? xrefA : xref); }
// Add a new annotation to the page
--
-2.13.2
+2.14.2
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index 95b2423b7751..069a242f98ea 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From d539ffdea09d1634d1780d2e7b065df001290575 Mon Sep 17 00:00:00 2001
+From 6b85dd588ac2507f503898e949c9e374ba8382ae Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,10 +8,10 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 11 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 390a6b5f..ddab7e8e 100644
+index 7485b2ad..4dc77251 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -532,17 +532,6 @@ if(HAVE_PTHREAD)
+@@ -543,17 +543,6 @@ if(HAVE_PTHREAD)
set(poppler_LIBS ${poppler_LIBS} ${CMAKE_THREAD_LIBS_INIT})
endif()
@@ -19,10 +19,10 @@ index 390a6b5f..ddab7e8e 100644
-add_definitions(-D_CRT_SECURE_NO_WARNINGS)
-set(CMAKE_CXX_FLAGS "/Zc:wchar_t- ${CMAKE_CXX_FLAGS}")
-add_library(poppler STATIC ${poppler_SRCS})
--else(MSVC)
--add_library(poppler SHARED ${poppler_SRCS})
--endif(MSVC)
--set_target_properties(poppler PROPERTIES VERSION 68.0.0 SOVERSION 68)
+-else()
+-add_library(poppler ${poppler_SRCS})
+-endif()
+-set_target_properties(poppler PROPERTIES VERSION 71.0.0 SOVERSION 71)
-target_link_libraries(poppler LINK_PRIVATE ${poppler_LIBS})
-install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX})
-
@@ -30,5 +30,5 @@ index 390a6b5f..ddab7e8e 100644
install(FILES
poppler/Annot.h
--
-2.13.2
+2.14.2
diff --git a/PKGBUILD b/PKGBUILD
index 54ef3acd40d8..9cc1cf45e8af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.57.0
+pkgver=0.60.1
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt4-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('bc5a191741604552c90d484103229374'
- '4c5107ad50490c36d592a61de4f1e638'
- '0415d51b3e5b338f48f7bb77f1ae7b83'
- 'daccf4875ca2de644590c990dc127ad1'
- 'bb93fb6564e2a3d6bfc6c94a7da78fbf')
+md5sums=('7648416d51a6e9fbc4a75b6f8b53dd7c'
+ 'cd3400daeea52082e4a5d4395de5d917'
+ 'b50d1feba1e8f23740b55a7fe5f432c8'
+ '17c816aea87f765ed26a29923de9b4a6'
+ '8dcdd57d7e92ef7d96c8aaf06cd4c862')
build() {
cd "${srcdir}/poppler-${pkgver}"