summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2017-11-13 12:23:55 +0000
committerPaul Gideon Dann2017-11-13 12:23:55 +0000
commit87312142f9cc960fff5ea8eee13398b7160b2a5d (patch)
tree76d6cd65bb43d27c40223a5ce52842a1393a91de
parent765137d0e55aaa6ec700ea5361950a82b8abee40 (diff)
downloadaur-87312142f9cc960fff5ea8eee13398b7160b2a5d.tar.gz
Update for Poppler 0.61.0
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Cairo-backend-added-to-Qt4-wrapper.patch25
-rw-r--r--0002-Setting-default-Qt4-backend-to-Cairo.patch4
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch16
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch25
-rw-r--r--PKGBUILD13
6 files changed, 58 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 698b2490dc21..87c2c8c07bb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Oct 17 15:11:20 UTC 2017
+# Mon Nov 13 12:23:49 UTC 2017
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.60.1
+ pkgver = 0.61.0
pkgrel = 1
url = https://github.com/giddie/poppler-qt4-cairo-backend
arch = i686
@@ -12,21 +12,21 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt4
depends = cairo
- depends = poppler>=0.60.1
- provides = poppler-qt=0.60.1
- provides = poppler-qt4=0.60.1
+ depends = poppler>=0.61.0
+ provides = poppler-qt=0.61.0
+ provides = poppler-qt4=0.61.0
conflicts = poppler-qt
conflicts = poppler-qt4
- source = http://poppler.freedesktop.org/poppler-0.60.1.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.61.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt4-wrapper.patch
source = 0002-Setting-default-Qt4-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = 7648416d51a6e9fbc4a75b6f8b53dd7c
- md5sums = cd3400daeea52082e4a5d4395de5d917
- md5sums = b50d1feba1e8f23740b55a7fe5f432c8
- md5sums = 17c816aea87f765ed26a29923de9b4a6
- md5sums = 8dcdd57d7e92ef7d96c8aaf06cd4c862
+ md5sums = 9feff3fb5e2302bb915e9a55da182c57
+ md5sums = 9d378dd11417fa8a9d8d4844d025e7a0
+ md5sums = d21b085d965ed72402d9ec55d92ca8d9
+ md5sums = 71475a89f057bb02c377657eefd92f19
+ md5sums = 810cb32394fa4ddbc98043a15634015f
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt4-wrapper.patch b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
index 7fe7fca06c16..689cb9623594 100644
--- a/0001-Cairo-backend-added-to-Qt4-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
@@ -1,4 +1,4 @@
-From f85cda566865fb4f6be2dcb8b84c6dcad4d6f7de Mon Sep 17 00:00:00 2001
+From bc66e168dd4cfe4afee20e90bc5aa2898b1f6008 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 11:42:28 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt4/src/CMakeLists.txt b/qt4/src/CMakeLists.txt
-index b803f755..1b56b21e 100644
+index f6547726..b0baa84b 100644
--- a/qt4/src/CMakeLists.txt
+++ b/qt4/src/CMakeLists.txt
@@ -6,6 +6,11 @@ include_directories(
@@ -27,7 +27,7 @@ index b803f755..1b56b21e 100644
set(poppler_qt4_SRCS
poppler-annotation.cc
poppler-document.cc
-@@ -28,10 +33,20 @@ set(poppler_qt4_SRCS
+@@ -28,6 +33,13 @@ set(poppler_qt4_SRCS
poppler-media.cc
ArthurOutputDev.cc
)
@@ -41,6 +41,9 @@ index b803f755..1b56b21e 100644
qt4_automoc(${poppler_qt4_SRCS})
add_library(poppler-qt4 SHARED ${poppler_qt4_SRCS})
set_target_properties(poppler-qt4 PROPERTIES VERSION 4.11.0 SOVERSION 4)
+@@ -36,6 +48,9 @@ if(MINGW)
+ set_target_properties(poppler-qt4 PROPERTIES SUFFIX "-${POPPLER_QT4_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+ endif()
target_link_libraries(poppler-qt4 poppler ${QT4_QTCORE_LIBRARY} ${QT4_QTGUI_LIBRARY} ${QT4_QTXML_LIBRARY})
+if (HAVE_CAIRO)
+ target_link_libraries(poppler-qt4 ${CAIRO_LIBRARIES})
@@ -49,10 +52,10 @@ index b803f755..1b56b21e 100644
target_link_libraries(poppler-qt4 poppler ${poppler_LIBS})
endif()
diff --git a/qt4/src/poppler-document.cc b/qt4/src/poppler-document.cc
-index f5ac11eb..a5cf5930 100644
+index d6e2fbf7..c1f293ad 100644
--- a/qt4/src/poppler-document.cc
+++ b/qt4/src/poppler-document.cc
-@@ -693,6 +693,9 @@ namespace Poppler {
+@@ -694,6 +694,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -63,10 +66,10 @@ index f5ac11eb..a5cf5930 100644
}
diff --git a/qt4/src/poppler-page.cc b/qt4/src/poppler-page.cc
-index 1a55bb57..bc88ce0d 100644
+index ffe6e99c..084c4a6b 100644
--- a/qt4/src/poppler-page.cc
+++ b/qt4/src/poppler-page.cc
-@@ -41,6 +41,7 @@
+@@ -42,6 +42,7 @@
#include <QtGui/QPainter>
#include <config.h>
@@ -74,7 +77,7 @@ index 1a55bb57..bc88ce0d 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -54,6 +55,9 @@
+@@ -55,6 +56,9 @@
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
#endif
@@ -84,7 +87,7 @@ index 1a55bb57..bc88ce0d 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -415,6 +419,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
+@@ -416,6 +420,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
img = tmpimg;
break;
}
@@ -155,7 +158,7 @@ index 1a55bb57..bc88ce0d 100644
}
return img;
-@@ -457,6 +525,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -458,6 +526,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
painter->restore();
return true;
}
@@ -195,5 +198,5 @@ index a01a638a..69ce63bc 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.14.2
+2.15.0
diff --git a/0002-Setting-default-Qt4-backend-to-Cairo.patch b/0002-Setting-default-Qt4-backend-to-Cairo.patch
index 5c0490e0c36b..47e6a0019942 100644
--- a/0002-Setting-default-Qt4-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt4-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From 53aee235bf1f8ba63c371580bb742c710ffd8438 Mon Sep 17 00:00:00 2001
+From dac62d3467a9060c93f8c03bf3fbfa94357c22d2 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 13:17:29 +0100
Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
@@ -21,5 +21,5 @@ index 1338a185..b6ca064a 100644
m_hints = 0;
m_optContentModel = 0;
--
-2.14.2
+2.15.0
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index 0ce089d2c47d..e25c78316a44 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From 8f7f0789e20308d9089d9fd6adb0b9c38f9fda95 Mon Sep 17 00:00:00 2001
+From 01951266ac6d701f705432aa015ccca1e9122db9 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -104,7 +104,7 @@ index fdbfd38e..0f02a3af 100644
/* A rectangle on a page, with coordinates in PDF points. */
#define POPPLER_TYPE_RECTANGLE (poppler_rectangle_get_type ())
diff --git a/poppler/CairoFontEngine.cc b/poppler/CairoFontEngine.cc
-index b56d100c..44ab2bef 100644
+index a375e0af..5f23bba9 100644
--- a/poppler/CairoFontEngine.cc
+++ b/poppler/CairoFontEngine.cc
@@ -132,7 +132,7 @@ CairoFont::getSubstitutionCorrection(GfxFont *gfxFont)
@@ -135,7 +135,7 @@ index b56d100c..44ab2bef 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index ffd39ef7..12f198e2 100644
+index 43c604f0..9ed3c151 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
@@ -208,6 +208,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
@@ -191,10 +191,10 @@ index ffd39ef7..12f198e2 100644
glyphs = NULL;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index eaef798f..cced8572 100644
+index 63346a4c..d051f383 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
-@@ -4616,6 +4616,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
+@@ -4608,6 +4608,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
error(errSyntaxError, getPos(), "Bad image parameters");
}
@@ -272,7 +272,7 @@ index 293f4551..5dff6fd3 100644
void drawForm(Object *str, Dict *resDict, double *matrix, double *bbox,
diff --git a/poppler/Page.cc b/poppler/Page.cc
-index 197e2bef..a76ec219 100644
+index ca4a5a6d..b7acbf04 100644
--- a/poppler/Page.cc
+++ b/poppler/Page.cc
@@ -348,6 +348,20 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
@@ -297,7 +297,7 @@ index 197e2bef..a76ec219 100644
Object obj1;
Dict *pageDict = pageObj.getDict()->copy(xrefA);
diff --git a/poppler/Page.h b/poppler/Page.h
-index 2a597131..3d44a7ae 100644
+index 97b70a0c..6786b40b 100644
--- a/poppler/Page.h
+++ b/poppler/Page.h
@@ -182,6 +182,9 @@ public:
@@ -311,5 +311,5 @@ index 2a597131..3d44a7ae 100644
Object getAnnotsObject(XRef *xrefA = nullptr) { return annotsObj.fetch(xrefA ? xrefA : xref); }
// Add a new annotation to the page
--
-2.14.2
+2.15.0
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index 069a242f98ea..fd51c07da388 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,18 +1,18 @@
-From 6b85dd588ac2507f503898e949c9e374ba8382ae Mon Sep 17 00:00:00 2001
+From c97c870f7d8870f456ad9c726fb323c6b4ad41e6 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
---
- CMakeLists.txt | 11 -----------
- 1 file changed, 11 deletions(-)
+ CMakeLists.txt | 18 ------------------
+ 1 file changed, 18 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7485b2ad..4dc77251 100644
+index bb74c6a2..8f4f4963 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -543,17 +543,6 @@ if(HAVE_PTHREAD)
- set(poppler_LIBS ${poppler_LIBS} ${CMAKE_THREAD_LIBS_INIT})
+@@ -537,24 +537,6 @@ if(TIFF_FOUND)
+ set(poppler_LIBS ${poppler_LIBS} ${TIFF_LIBRARIES})
endif()
-if(MSVC)
@@ -22,13 +22,20 @@ index 7485b2ad..4dc77251 100644
-else()
-add_library(poppler ${poppler_SRCS})
-endif()
--set_target_properties(poppler PROPERTIES VERSION 71.0.0 SOVERSION 71)
+-set_target_properties(poppler PROPERTIES VERSION 72.0.0 SOVERSION 72)
+-if(MINGW)
+- get_target_property(POPPLER_SOVERSION poppler SOVERSION)
+- set_target_properties(poppler PROPERTIES SUFFIX "-${POPPLER_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+-endif()
-target_link_libraries(poppler LINK_PRIVATE ${poppler_LIBS})
--install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX})
+-if(CMAKE_USE_PTHREADS_INIT)
+- target_link_libraries(poppler LINK_PRIVATE Threads::Threads)
+-endif()
+-install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-
if(ENABLE_XPDF_HEADERS)
install(FILES
poppler/Annot.h
--
-2.14.2
+2.15.0
diff --git a/PKGBUILD b/PKGBUILD
index 9cc1cf45e8af..53f66587462e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.60.1
+pkgver=0.61.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt4-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('7648416d51a6e9fbc4a75b6f8b53dd7c'
- 'cd3400daeea52082e4a5d4395de5d917'
- 'b50d1feba1e8f23740b55a7fe5f432c8'
- '17c816aea87f765ed26a29923de9b4a6'
- '8dcdd57d7e92ef7d96c8aaf06cd4c862')
+md5sums=('9feff3fb5e2302bb915e9a55da182c57'
+ '9d378dd11417fa8a9d8d4844d025e7a0'
+ 'd21b085d965ed72402d9ec55d92ca8d9'
+ '71475a89f057bb02c377657eefd92f19'
+ '810cb32394fa4ddbc98043a15634015f')
build() {
cd "${srcdir}/poppler-${pkgver}"
@@ -45,5 +45,6 @@ package() {
make DESTDIR="${pkgdir}" -C qt4/src install
msg "Removing unwanted pkg-config files"
+ mv "${pkgdir}"/usr/lib{64,}
rm -f "${pkgdir}"/usr/lib/pkgconfig/poppler{,-splash,-cairo}.pc
}