summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2016-12-28 11:23:49 +0000
committerPaul Gideon Dann2016-12-28 11:23:49 +0000
commit9f0fd95b2da3252c0f1c6dccfc6990e118b744da (patch)
tree52e1a9f683ac248e33092b002648bb9f4b3153fd
parentc4e5e4f1918ef5177663088e76ac36a68fbdd01f (diff)
downloadaur-9f0fd95b2da3252c0f1c6dccfc6990e118b744da.tar.gz
Update for Poppler 0.50
-rw-r--r--.SRCINFO22
-rw-r--r--0001-Cairo-backend-added-to-Qt4-wrapper.patch20
-rw-r--r--0002-Setting-default-Qt4-backend-to-Cairo.patch6
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch30
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch8
-rw-r--r--PKGBUILD12
6 files changed, 49 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b28a0e2413c..7f7a2a3ed532 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 13 12:04:42 UTC 2016
+# Wed Dec 28 11:23:37 UTC 2016
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.49.0
+ pkgver = 0.50.0
pkgrel = 1
url = https://github.com/giddie/poppler-qt4-cairo-backend
arch = i686
@@ -12,21 +12,21 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt4
depends = cairo
- depends = poppler>=0.49.0
- provides = poppler-qt=0.49.0
- provides = poppler-qt4=0.49.0
+ depends = poppler>=0.50.0
+ provides = poppler-qt=0.50.0
+ provides = poppler-qt4=0.50.0
conflicts = poppler-qt
conflicts = poppler-qt4
- source = http://poppler.freedesktop.org/poppler-0.49.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.50.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt4-wrapper.patch
source = 0002-Setting-default-Qt4-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = 9e057ed8eee1f9979fa75d8f044783b8
- md5sums = 2dced22cd5ca3b0432aeb643a20c5d98
- md5sums = c89bbfba7d89b88c3120ff9f6b089ea9
- md5sums = 86be3ae0b8073ad315ccb5f65cb5d519
- md5sums = 3a767dda20553fad7fec9d3b907784aa
+ md5sums = 1a4c0cd873bddd8f266b85ab8d799962
+ md5sums = 2d6a6ab3aa838ecb0f8a3816468908b6
+ md5sums = 981845704a7e12e5fecdb532db9cdf60
+ md5sums = 9f04452d2c6cb204965234794f8355b0
+ md5sums = b451021512ee08f8defa973ee59498f0
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt4-wrapper.patch b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
index 914a19d36bc1..987053903507 100644
--- a/0001-Cairo-backend-added-to-Qt4-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
@@ -1,4 +1,4 @@
-From fa46f5de2770b40ee79bc4be95030a91657e0f60 Mon Sep 17 00:00:00 2001
+From fbceb64e0eb10b7a3948935e35f4c3c12fc24c27 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 11:42:28 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt4/src/CMakeLists.txt b/qt4/src/CMakeLists.txt
-index 2b55e6b..8587f24 100644
+index 18c35f8c..d0c87764 100644
--- a/qt4/src/CMakeLists.txt
+++ b/qt4/src/CMakeLists.txt
@@ -6,6 +6,11 @@ include_directories(
@@ -40,7 +40,7 @@ index 2b55e6b..8587f24 100644
+endif(HAVE_CAIRO)
qt4_automoc(${poppler_qt4_SRCS})
add_library(poppler-qt4 SHARED ${poppler_qt4_SRCS})
- set_target_properties(poppler-qt4 PROPERTIES VERSION 4.10.0 SOVERSION 4)
+ set_target_properties(poppler-qt4 PROPERTIES VERSION 4.11.0 SOVERSION 4)
target_link_libraries(poppler-qt4 poppler ${QT4_QTCORE_LIBRARY} ${QT4_QTGUI_LIBRARY} ${QT4_QTXML_LIBRARY})
+if (HAVE_CAIRO)
+ target_link_libraries(poppler-qt4 ${CAIRO_LIBRARIES})
@@ -49,7 +49,7 @@ index 2b55e6b..8587f24 100644
target_link_libraries(poppler-qt4 poppler ${poppler_LIBS})
endif(MSVC)
diff --git a/qt4/src/poppler-document.cc b/qt4/src/poppler-document.cc
-index 7f8abfa..a6b4c8e 100644
+index 7f8abfa7..a6b4c8e0 100644
--- a/qt4/src/poppler-document.cc
+++ b/qt4/src/poppler-document.cc
@@ -698,6 +698,9 @@ namespace Poppler {
@@ -63,7 +63,7 @@ index 7f8abfa..a6b4c8e 100644
}
diff --git a/qt4/src/poppler-page.cc b/qt4/src/poppler-page.cc
-index 9e466da..650ad5f 100644
+index fb6a036d..58c3412d 100644
--- a/qt4/src/poppler-page.cc
+++ b/qt4/src/poppler-page.cc
@@ -41,6 +41,7 @@
@@ -84,7 +84,7 @@ index 9e466da..650ad5f 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -406,6 +410,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
+@@ -415,6 +419,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
img = tmpimg;
break;
}
@@ -155,7 +155,7 @@ index 9e466da..650ad5f 100644
}
return img;
-@@ -448,6 +516,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -457,6 +525,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
painter->restore();
return true;
}
@@ -165,7 +165,7 @@ index 9e466da..650ad5f 100644
return false;
}
diff --git a/qt4/src/poppler-qt4.h b/qt4/src/poppler-qt4.h
-index 1b5afb2..8e3cb26 100644
+index 1b5afb2e..8e3cb26b 100644
--- a/qt4/src/poppler-qt4.h
+++ b/qt4/src/poppler-qt4.h
@@ -887,7 +887,8 @@ delete it;
@@ -179,7 +179,7 @@ index 1b5afb2..8e3cb26 100644
/**
diff --git a/qt4/tests/CMakeLists.txt b/qt4/tests/CMakeLists.txt
-index bba868f..8c40471 100644
+index bba868f1..8c404716 100644
--- a/qt4/tests/CMakeLists.txt
+++ b/qt4/tests/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -195,5 +195,5 @@ index bba868f..8c40471 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.10.2
+2.11.0
diff --git a/0002-Setting-default-Qt4-backend-to-Cairo.patch b/0002-Setting-default-Qt4-backend-to-Cairo.patch
index 4f4f0fb2f796..5bcc5e93595d 100644
--- a/0002-Setting-default-Qt4-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt4-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From 23f407f6d4fb622fb2d3182706111cbe1f28c8e4 Mon Sep 17 00:00:00 2001
+From 603d1602bb9d1a0f183aed072b3cea7c131eb7da Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 13:17:29 +0100
Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
@@ -8,7 +8,7 @@ Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qt4/src/poppler-private.cc b/qt4/src/poppler-private.cc
-index 6c4d782..8cfba6f 100644
+index 6c4d782e..8cfba6f6 100644
--- a/qt4/src/poppler-private.cc
+++ b/qt4/src/poppler-private.cc
@@ -245,7 +245,7 @@ namespace Debug {
@@ -21,5 +21,5 @@ index 6c4d782..8cfba6f 100644
m_hints = 0;
m_optContentModel = 0;
--
-2.10.2
+2.11.0
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index aa6327c682fa..42b25541a029 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From 30f21dbfbd957d7b2b133504bd76b022179ae783 Mon Sep 17 00:00:00 2001
+From 86b08b79c33128cebbcea15509630da98bf33d74 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -18,7 +18,7 @@ https://github.com/zhou13/poppler-subpixel/blob/master/poppler/poppler-subpixel.
9 files changed, 136 insertions(+), 6 deletions(-)
diff --git a/glib/demo/render.c b/glib/demo/render.c
-index 78d24bb..d482ceb 100644
+index 78d24bb5..d482ceb5 100644
--- a/glib/demo/render.c
+++ b/glib/demo/render.c
@@ -82,12 +82,14 @@ pgd_render_start (GtkButton *button,
@@ -74,7 +74,7 @@ index 78d24bb..d482ceb 100644
g_timer_stop (timer);
diff --git a/glib/poppler-page.cc b/glib/poppler-page.cc
-index 3d63bfd..3dc5585 100644
+index 3d63bfdd..3dc55858 100644
--- a/glib/poppler-page.cc
+++ b/glib/poppler-page.cc
@@ -2424,3 +2424,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
@@ -92,7 +92,7 @@ index 3d63bfd..3dc5585 100644
+ return page->page->supportSubpixelRendering(output_dev);
+}
diff --git a/glib/poppler-page.h b/glib/poppler-page.h
-index fdbfd38..0f02a3a 100644
+index fdbfd38e..0f02a3af 100644
--- a/glib/poppler-page.h
+++ b/glib/poppler-page.h
@@ -109,6 +109,7 @@ GList *poppler_page_get_text_attributes (PopplerPage *pa
@@ -104,7 +104,7 @@ index fdbfd38..0f02a3a 100644
/* A rectangle on a page, with coordinates in PDF points. */
#define POPPLER_TYPE_RECTANGLE (poppler_rectangle_get_type ())
diff --git a/poppler/CairoFontEngine.cc b/poppler/CairoFontEngine.cc
-index 6676f89..3c8fe81 100644
+index 6676f898..3c8fe815 100644
--- a/poppler/CairoFontEngine.cc
+++ b/poppler/CairoFontEngine.cc
@@ -132,7 +132,7 @@ CairoFont::getSubstitutionCorrection(GfxFont *gfxFont)
@@ -135,10 +135,10 @@ index 6676f89..3c8fe81 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index bd18cde..a24ca38 100644
+index 89d0c996..b06f0da5 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
-@@ -203,6 +203,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
+@@ -204,6 +204,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
}
if (cairo != NULL) {
this->cairo = cairo_reference (cairo);
@@ -152,7 +152,7 @@ index bd18cde..a24ca38 100644
/* save the initial matrix so that we can use it for type3 fonts. */
//XXX: is this sufficient? could we miss changes to the matrix somehow?
cairo_get_matrix(cairo, &orig_matrix);
-@@ -1430,6 +1437,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+@@ -1431,6 +1438,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
void CairoOutputDev::endString(GfxState *state)
{
int render;
@@ -160,7 +160,7 @@ index bd18cde..a24ca38 100644
if (!currentFont)
return;
-@@ -1447,6 +1455,18 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1448,6 +1456,18 @@ void CairoOutputDev::endString(GfxState *state)
goto finish;
}
@@ -179,7 +179,7 @@ index bd18cde..a24ca38 100644
if (!(render & 1)) {
LOG (printf ("fill string\n"));
cairo_set_source (cairo, fill_pattern);
-@@ -1497,6 +1517,10 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1498,6 +1518,10 @@ void CairoOutputDev::endString(GfxState *state)
}
finish:
@@ -191,7 +191,7 @@ index bd18cde..a24ca38 100644
glyphs = NULL;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index a8f5be9..0ca1940 100644
+index a8f5be95..0ca1940a 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
@@ -4728,6 +4728,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
@@ -258,7 +258,7 @@ index a8f5be9..0ca1940 100644
// check the effect of compositing objects as a group:
// look for ExtGState entries with ca != 1 or CA != 1 or BM != normal
diff --git a/poppler/Gfx.h b/poppler/Gfx.h
-index a82f9f4..6a7e2c7 100644
+index a82f9f4a..6a7e2c78 100644
--- a/poppler/Gfx.h
+++ b/poppler/Gfx.h
@@ -186,6 +186,9 @@ public:
@@ -272,7 +272,7 @@ index a82f9f4..6a7e2c7 100644
void drawForm(Object *str, Dict *resDict, double *matrix, double *bbox,
diff --git a/poppler/Page.cc b/poppler/Page.cc
-index dca52e4..3f63342 100644
+index dca52e4f..3f633423 100644
--- a/poppler/Page.cc
+++ b/poppler/Page.cc
@@ -372,6 +372,20 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
@@ -297,7 +297,7 @@ index dca52e4..3f63342 100644
Object obj1;
Dict *pageDict = pageObj.getDict()->copy(xrefA);
diff --git a/poppler/Page.h b/poppler/Page.h
-index 2aaabae..a49d34f 100644
+index 2aaabae9..a49d34f1 100644
--- a/poppler/Page.h
+++ b/poppler/Page.h
@@ -179,6 +179,9 @@ public:
@@ -311,5 +311,5 @@ index 2aaabae..a49d34f 100644
Object *getAnnots(Object *obj, XRef *xrefA = NULL) { return annotsObj.fetch((xrefA == NULL) ? xref : xrefA, obj); }
// Add a new annotation to the page
--
-2.10.2
+2.11.0
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index 316da4487c48..b5c42a66e2b7 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From 4c8400476ac033cdb40c2e198bfaf736c3017367 Mon Sep 17 00:00:00 2001
+From 4055d89f7620e4deee56e8affcc8a2c57cf380f1 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,7 +8,7 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 11 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c25e961..00d231c 100644
+index 54294e12..8e12ea9a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -495,17 +495,6 @@ if(HAVE_PTHREAD)
@@ -22,7 +22,7 @@ index c25e961..00d231c 100644
-else(MSVC)
-add_library(poppler SHARED ${poppler_SRCS})
-endif(MSVC)
--set_target_properties(poppler PROPERTIES VERSION 65.0.0 SOVERSION 65)
+-set_target_properties(poppler PROPERTIES VERSION 66.0.0 SOVERSION 66)
-target_link_libraries(poppler LINK_PRIVATE ${poppler_LIBS})
-install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX})
-
@@ -30,5 +30,5 @@ index c25e961..00d231c 100644
install(FILES
poppler/Annot.h
--
-2.10.2
+2.11.0
diff --git a/PKGBUILD b/PKGBUILD
index f2e6b3ff602a..6c3edc2d9d66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.49.0
+pkgver=0.50.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt4-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('9e057ed8eee1f9979fa75d8f044783b8'
- '2dced22cd5ca3b0432aeb643a20c5d98'
- 'c89bbfba7d89b88c3120ff9f6b089ea9'
- '86be3ae0b8073ad315ccb5f65cb5d519'
- '3a767dda20553fad7fec9d3b907784aa')
+md5sums=('1a4c0cd873bddd8f266b85ab8d799962'
+ '2d6a6ab3aa838ecb0f8a3816468908b6'
+ '981845704a7e12e5fecdb532db9cdf60'
+ '9f04452d2c6cb204965234794f8355b0'
+ 'b451021512ee08f8defa973ee59498f0')
build() {
cd "${srcdir}/poppler-${pkgver}"