summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2020-02-17 11:48:17 +0000
committerPaul Gideon Dann2020-02-17 11:48:17 +0000
commitbb9fe259ba0c5df3b1ac4d023dd7f6b20b82da5d (patch)
tree606dbb4e51b380fbb1f5fccb90f306d7b622e8d0
parent39246c68ecc7e60d217c132a2108fdca623a9470 (diff)
downloadaur-bb9fe259ba0c5df3b1ac4d023dd7f6b20b82da5d.tar.gz
Update for Poppler 0.85.0
-rw-r--r--.SRCINFO20
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch26
-rw-r--r--0002-Setting-default-Qt5-backend-to-Cairo.patch8
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch18
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch14
-rw-r--r--PKGBUILD12
6 files changed, 49 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bab8e1cd9940..57ab9fe4c8ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.84.0
+ pkgver = 0.85.0
pkgrel = 1
url = https://github.com/giddie/poppler-cairo-backend
arch = i686
@@ -10,22 +10,22 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt5-base
depends = cairo
- depends = poppler>=0.84.0
- provides = poppler-qt=0.84.0
- provides = poppler-qt5=0.84.0
+ depends = poppler>=0.85.0
+ provides = poppler-qt=0.85.0
+ provides = poppler-qt5=0.85.0
conflicts = poppler-qt
conflicts = poppler-qt4
conflicts = poppler-qt5
- source = http://poppler.freedesktop.org/poppler-0.84.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.85.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt5-wrapper.patch
source = 0002-Setting-default-Qt5-backend-to-Cairo.patch
source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = e14a8aca8809908ad4364c32c17bcb92
- md5sums = 2aefa37d415d1f036eb4a836582aea8e
- md5sums = 799cd74020f6afd680ecdbddf6b8281d
- md5sums = 9abe68a954e5018a429aeb1d56aa58d5
- md5sums = 8ff59d6d9b90bdbef531cb2fc8712a15
+ md5sums = 5315084523a4d73e9514f51eef78a332
+ md5sums = 2ab69361db35e81c2f9a425234926dbb
+ md5sums = 3522932d7a0d849e412dcbe972fdf2f8
+ md5sums = 47db63064e2e3819f5e9dd997350a011
+ md5sums = 7c58bbdcb318d03905d0170f2d9518f0
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index a916d07c68e6..89b8a895da02 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From c9ef97b68af1327131793d68d273e751a7d90329 Mon Sep 17 00:00:00 2001
+From 0324a49e026627849372bde9c578decc6c594e7f Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 643f56a1..eaadd0c0 100644
+index f7c99248..301adcb3 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -27,7 +27,7 @@ index 643f56a1..eaadd0c0 100644
set(CMAKE_C_VISIBILITY_PRESET hidden)
set(CMAKE_CXX_VISIBILITY_PRESET hidden)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
-@@ -38,6 +43,13 @@ set(poppler_qt5_SRCS
+@@ -39,6 +44,13 @@ set(poppler_qt5_SRCS
ArthurOutputDev.cc
poppler-version.cpp
)
@@ -39,9 +39,9 @@ index 643f56a1..eaadd0c0 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.21.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.22.0 SOVERSION 1)
if(MINGW AND BUILD_SHARED_LIBS)
-@@ -45,6 +57,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
+@@ -46,6 +58,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
target_link_libraries(poppler-qt5 poppler ${Qt5Core_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Xml_LIBRARIES} ${FREETYPE_LIBRARIES})
@@ -52,10 +52,10 @@ index 643f56a1..eaadd0c0 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index ba9b86cd..d4336d3f 100644
+index bff01205..6c25e42e 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -695,6 +695,9 @@ namespace Poppler {
+@@ -707,6 +707,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -66,7 +66,7 @@ index ba9b86cd..d4336d3f 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index c9987761..034b9c2b 100644
+index 9e08134a..7459f30c 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
@@ -48,6 +48,7 @@
@@ -87,7 +87,7 @@ index c9987761..034b9c2b 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -616,6 +620,70 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -609,6 +613,70 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -158,7 +158,7 @@ index c9987761..034b9c2b 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -638,6 +706,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -631,6 +699,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
QImageDumpingArthurOutputDev arthur_output(painter, nullptr);
return renderToArthur(&arthur_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,10 +168,10 @@ index c9987761..034b9c2b 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index c501f67f..e9ec5f10 100644
+index d32ffa3b..aa71aca9 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1151,7 +1151,8 @@ delete it;
+@@ -1152,7 +1152,8 @@ delete it;
*/
enum RenderBackend {
SplashBackend, ///< Splash backend
@@ -198,5 +198,5 @@ index 5abcbc45..99c12b9f 100644
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
--
-2.24.1
+2.25.0
diff --git a/0002-Setting-default-Qt5-backend-to-Cairo.patch b/0002-Setting-default-Qt5-backend-to-Cairo.patch
index 53d36a9706db..9d9528489c42 100644
--- a/0002-Setting-default-Qt5-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt5-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From 6cc2fe9d62aeef19ae68ffca81de9465753fc8fa Mon Sep 17 00:00:00 2001
+From 3dc1acd1f1c9af81a0add270517e1948b0db0425 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:37:38 +0100
Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
@@ -8,10 +8,10 @@ Subject: [PATCH 2/4] Setting default Qt5 backend to Cairo
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qt5/src/poppler-private.cc b/qt5/src/poppler-private.cc
-index 3c9bf512..33906aa0 100644
+index 81af2bed..4ef06515 100644
--- a/qt5/src/poppler-private.cc
+++ b/qt5/src/poppler-private.cc
-@@ -255,7 +255,7 @@ namespace Debug {
+@@ -239,7 +239,7 @@ namespace Debug {
void DocumentData::init()
{
@@ -21,5 +21,5 @@ index 3c9bf512..33906aa0 100644
m_hints = 0;
m_optContentModel = nullptr;
--
-2.24.1
+2.25.0
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
index 0f7f2d341b9f..956749b914c4 100644
--- a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -1,4 +1,4 @@
-From 93573105c0c73cee4acb451bcb9e99a34ce2daea Mon Sep 17 00:00:00 2001
+From 16c34ccad8d99ded933daa3d0875369e5b9459bf Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 9 Aug 2016 15:02:53 +0100
Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
@@ -135,10 +135,10 @@ index 1f637cf5..3de0a45e 100644
if (cairo_font_face_set_user_data (l->font_face,
&_ft_cairo_key,
diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index eac8ed09..b842818f 100644
+index 34c02667..520fdb4e 100644
--- a/poppler/CairoOutputDev.cc
+++ b/poppler/CairoOutputDev.cc
-@@ -206,6 +206,13 @@ void CairoOutputDev::setCairo(cairo_t *c)
+@@ -204,6 +204,13 @@ void CairoOutputDev::setCairo(cairo_t *c)
}
if (c != nullptr) {
cairo = cairo_reference (c);
@@ -152,7 +152,7 @@ index eac8ed09..b842818f 100644
/* save the initial matrix so that we can use it for type3 fonts. */
//XXX: is this sufficient? could we miss changes to the matrix somehow?
cairo_get_matrix(cairo, &orig_matrix);
-@@ -1431,6 +1438,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+@@ -1428,6 +1435,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
void CairoOutputDev::endString(GfxState *state)
{
int render;
@@ -160,7 +160,7 @@ index eac8ed09..b842818f 100644
if (!currentFont)
return;
-@@ -1448,6 +1456,18 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1445,6 +1453,18 @@ void CairoOutputDev::endString(GfxState *state)
goto finish;
}
@@ -179,7 +179,7 @@ index eac8ed09..b842818f 100644
if (!(render & 1)) {
LOG (printf ("fill string\n"));
cairo_set_source (cairo, fill_pattern);
-@@ -1498,6 +1518,10 @@ void CairoOutputDev::endString(GfxState *state)
+@@ -1495,6 +1515,10 @@ void CairoOutputDev::endString(GfxState *state)
}
finish:
@@ -191,10 +191,10 @@ index eac8ed09..b842818f 100644
glyphs = nullptr;
if (use_show_text_glyphs) {
diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
-index 58c36fcb..1aea6090 100644
+index 9773b60c..945210d2 100644
--- a/poppler/Gfx.cc
+++ b/poppler/Gfx.cc
-@@ -4602,6 +4602,47 @@ void Gfx::doImage(Object *ref, Stream *str, bool inlineImg) {
+@@ -4595,6 +4595,47 @@ void Gfx::doImage(Object *ref, Stream *str, bool inlineImg) {
error(errSyntaxError, getPos(), "Bad image parameters");
}
@@ -295,5 +295,5 @@ index 01f056f9..d6547a79 100644
Object getAnnotsObject(XRef *xrefA = nullptr) { return annotsObj.fetch(xrefA ? xrefA : xref); }
// Add a new annotation to the page
--
-2.24.1
+2.25.0
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index 3e3ecbe27a43..d5a7f65b5783 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From ce960d5e890abd58fae3ff669bb841b5c96d43e1 Mon Sep 17 00:00:00 2001
+From 94e722b2e2253c987b220d41dcf677f871cf8cb6 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,12 +8,12 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 17 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ef987a86..9c9fffe4 100644
+index afad5c78..16ee215a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -491,23 +491,6 @@ if(TIFF_FOUND)
- set(poppler_LIBS ${poppler_LIBS} ${TIFF_LIBRARIES})
- endif()
+@@ -527,23 +527,6 @@ ADD_GPERF_FILE(TimesItalicWidths)
+ ADD_GPERF_FILE(TimesRomanWidths)
+ ADD_GPERF_FILE(ZapfDingbatsWidths)
-if(MSVC)
-add_definitions(-D_CRT_SECURE_NO_WARNINGS)
@@ -21,7 +21,7 @@ index ef987a86..9c9fffe4 100644
-else()
-add_library(poppler ${poppler_SRCS})
-endif()
--set_target_properties(poppler PROPERTIES VERSION 94.0.0 SOVERSION 94)
+-set_target_properties(poppler PROPERTIES VERSION 95.0.0 SOVERSION 95)
-if(MINGW AND BUILD_SHARED_LIBS)
- get_target_property(POPPLER_SOVERSION poppler SOVERSION)
- set_target_properties(poppler PROPERTIES SUFFIX "-${POPPLER_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -36,5 +36,5 @@ index ef987a86..9c9fffe4 100644
install(FILES
poppler/Annot.h
--
-2.24.1
+2.25.0
diff --git a/PKGBUILD b/PKGBUILD
index eba81cfb1887..da3bee538c12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.84.0
+pkgver=0.85.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -17,11 +17,11 @@ source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0002-Setting-default-Qt5-backend-to-Cairo.patch
0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('e14a8aca8809908ad4364c32c17bcb92'
- '2aefa37d415d1f036eb4a836582aea8e'
- '799cd74020f6afd680ecdbddf6b8281d'
- '9abe68a954e5018a429aeb1d56aa58d5'
- '8ff59d6d9b90bdbef531cb2fc8712a15')
+md5sums=('5315084523a4d73e9514f51eef78a332'
+ '2ab69361db35e81c2f9a425234926dbb'
+ '3522932d7a0d849e412dcbe972fdf2f8'
+ '47db63064e2e3819f5e9dd997350a011'
+ '7c58bbdcb318d03905d0170f2d9518f0')
build() {
cd "${srcdir}/poppler-${pkgver}"