summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Gideon Dann2016-12-13 12:04:59 +0000
committerPaul Gideon Dann2016-12-13 12:04:59 +0000
commitc4e5e4f1918ef5177663088e76ac36a68fbdd01f (patch)
treeceb88a410018263775a97f8c47e4f319f412441e
parent3186fca13a3f64f7c0e8e89ba9be51cc8c52cbc2 (diff)
downloadaur-c4e5e4f1918ef5177663088e76ac36a68fbdd01f.tar.gz
Update for poppler-0.49
-rw-r--r--.SRCINFO24
-rw-r--r--0001-Cairo-backend-added-to-Qt4-wrapper.patch8
-rw-r--r--0002-Setting-default-Qt4-backend-to-Cairo.patch6
-rw-r--r--0003-Apply-subpixel-rendering-in-Cairo-Backend.patch315
-rw-r--r--0003-Forcing-subpixel-rendering-in-Cairo-backend.patch30
-rw-r--r--0004-Don-t-build-the-main-poppler-library.patch8
-rw-r--r--PKGBUILD14
7 files changed, 345 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a12e6d13ea8..7b28a0e2413c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 9 13:54:38 UTC 2016
+# Tue Dec 13 12:04:42 UTC 2016
pkgbase = poppler-qt-lcd
pkgdesc = Poppler Qt bindings, with patches to allow subpixel rendering via Cairo
- pkgver = 0.46.0
+ pkgver = 0.49.0
pkgrel = 1
url = https://github.com/giddie/poppler-qt4-cairo-backend
arch = i686
@@ -12,21 +12,21 @@ pkgbase = poppler-qt-lcd
makedepends = pkgconfig
depends = qt4
depends = cairo
- depends = poppler>=0.46.0
- provides = poppler-qt=0.46.0
- provides = poppler-qt4=0.46.0
+ depends = poppler>=0.49.0
+ provides = poppler-qt=0.49.0
+ provides = poppler-qt4=0.49.0
conflicts = poppler-qt
conflicts = poppler-qt4
- source = http://poppler.freedesktop.org/poppler-0.46.0.tar.xz
+ source = http://poppler.freedesktop.org/poppler-0.49.0.tar.xz
source = 0001-Cairo-backend-added-to-Qt4-wrapper.patch
source = 0002-Setting-default-Qt4-backend-to-Cairo.patch
- source = 0003-Forcing-subpixel-rendering-in-Cairo-backend.patch
+ source = 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
source = 0004-Don-t-build-the-main-poppler-library.patch
- md5sums = a6513d6fe72751c58b501403c3da6ef1
- md5sums = 1964c4388455d9da02fda267b3bbc0b6
- md5sums = 6579a7896f9a2e4bb10bb19b552dda6c
- md5sums = bd9df787addbc9a98f49192732465dc4
- md5sums = 892694d6cfce9e6c321253cf62fc9001
+ md5sums = 9e057ed8eee1f9979fa75d8f044783b8
+ md5sums = 2dced22cd5ca3b0432aeb643a20c5d98
+ md5sums = c89bbfba7d89b88c3120ff9f6b089ea9
+ md5sums = 86be3ae0b8073ad315ccb5f65cb5d519
+ md5sums = 3a767dda20553fad7fec9d3b907784aa
pkgname = poppler-qt-lcd
diff --git a/0001-Cairo-backend-added-to-Qt4-wrapper.patch b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
index fde93712eca0..914a19d36bc1 100644
--- a/0001-Cairo-backend-added-to-Qt4-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt4-wrapper.patch
@@ -1,4 +1,4 @@
-From bb2a79e89f60366ae3830ed7e7c6bbfb567ec3db Mon Sep 17 00:00:00 2001
+From fa46f5de2770b40ee79bc4be95030a91657e0f60 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 11:42:28 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt4 wrapper
@@ -49,7 +49,7 @@ index 2b55e6b..8587f24 100644
target_link_libraries(poppler-qt4 poppler ${poppler_LIBS})
endif(MSVC)
diff --git a/qt4/src/poppler-document.cc b/qt4/src/poppler-document.cc
-index 93f9a0a..260c7a0 100644
+index 7f8abfa..a6b4c8e 100644
--- a/qt4/src/poppler-document.cc
+++ b/qt4/src/poppler-document.cc
@@ -698,6 +698,9 @@ namespace Poppler {
@@ -165,7 +165,7 @@ index 9e466da..650ad5f 100644
return false;
}
diff --git a/qt4/src/poppler-qt4.h b/qt4/src/poppler-qt4.h
-index 2b518c1..2eaeafc 100644
+index 1b5afb2..8e3cb26 100644
--- a/qt4/src/poppler-qt4.h
+++ b/qt4/src/poppler-qt4.h
@@ -887,7 +887,8 @@ delete it;
@@ -195,5 +195,5 @@ index bba868f..8c40471 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.9.2
+2.10.2
diff --git a/0002-Setting-default-Qt4-backend-to-Cairo.patch b/0002-Setting-default-Qt4-backend-to-Cairo.patch
index 04252a6fde55..4f4f0fb2f796 100644
--- a/0002-Setting-default-Qt4-backend-to-Cairo.patch
+++ b/0002-Setting-default-Qt4-backend-to-Cairo.patch
@@ -1,4 +1,4 @@
-From ace47a614fce2654b51f7f02c3f3ed71526e90c0 Mon Sep 17 00:00:00 2001
+From 23f407f6d4fb622fb2d3182706111cbe1f28c8e4 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 20 May 2009 13:17:29 +0100
Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
@@ -8,7 +8,7 @@ Subject: [PATCH 2/4] Setting default Qt4 backend to Cairo
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/qt4/src/poppler-private.cc b/qt4/src/poppler-private.cc
-index d64dca6..2697517 100644
+index 6c4d782..8cfba6f 100644
--- a/qt4/src/poppler-private.cc
+++ b/qt4/src/poppler-private.cc
@@ -245,7 +245,7 @@ namespace Debug {
@@ -21,5 +21,5 @@ index d64dca6..2697517 100644
m_hints = 0;
m_optContentModel = 0;
--
-2.9.2
+2.10.2
diff --git a/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
new file mode 100644
index 000000000000..aa6327c682fa
--- /dev/null
+++ b/0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
@@ -0,0 +1,315 @@
+From 30f21dbfbd957d7b2b133504bd76b022179ae783 Mon Sep 17 00:00:00 2001
+From: Paul Gideon Dann <pdgiddie@gmail.com>
+Date: Tue, 9 Aug 2016 15:02:53 +0100
+Subject: [PATCH 3/4] Apply subpixel rendering in Cairo Backend
+
+Source:
+https://github.com/zhou13/poppler-subpixel/blob/master/poppler/poppler-subpixel.patch
+---
+ glib/demo/render.c | 25 ++++++++++++++++++---
+ glib/poppler-page.cc | 10 +++++++++
+ glib/poppler-page.h | 1 +
+ poppler/CairoFontEngine.cc | 6 ++---
+ poppler/CairoOutputDev.cc | 24 ++++++++++++++++++++
+ poppler/Gfx.cc | 56 ++++++++++++++++++++++++++++++++++++++++++++++
+ poppler/Gfx.h | 3 +++
+ poppler/Page.cc | 14 ++++++++++++
+ poppler/Page.h | 3 +++
+ 9 files changed, 136 insertions(+), 6 deletions(-)
+
+diff --git a/glib/demo/render.c b/glib/demo/render.c
+index 78d24bb..d482ceb 100644
+--- a/glib/demo/render.c
++++ b/glib/demo/render.c
+@@ -82,12 +82,14 @@ pgd_render_start (GtkButton *button,
+ PgdRenderDemo *demo)
+ {
+ PopplerPage *page;
++ gboolean subpixel_rendering;
+ gdouble page_width, page_height;
+ gdouble width, height;
+ gint x, y;
+ gchar *str;
+ GTimer *timer;
+ cairo_t *cr;
++ cairo_font_options_t *fo;
+
+ page = poppler_document_get_page (demo->doc, demo->page);
+ if (!page)
+@@ -116,6 +118,21 @@ pgd_render_start (GtkButton *button,
+ width, height);
+ cr = cairo_create (demo->surface);
+
++ fo = cairo_font_options_create ();
++ cairo_get_font_options (cr, fo);
++
++ subpixel_rendering = poppler_page_support_subpixel_rendering (page);
++ printf("subpixel_rendering %d\n", subpixel_rendering);
++ if (subpixel_rendering) {
++ cairo_set_source_rgb (cr, 1., 1., 1.);
++ cairo_paint (cr);
++ cairo_font_options_set_antialias (fo, CAIRO_ANTIALIAS_SUBPIXEL);
++ cairo_font_options_set_subpixel_order (fo, CAIRO_SUBPIXEL_ORDER_RGB);
++ }
++
++ cairo_set_font_options (cr, fo);
++ cairo_font_options_destroy (fo);
++
+ cairo_save (cr);
+ switch (demo->rotate) {
+ case 90:
+@@ -143,9 +160,11 @@ pgd_render_start (GtkButton *button,
+ poppler_page_render (page, cr);
+ cairo_restore (cr);
+
+- cairo_set_operator (cr, CAIRO_OPERATOR_DEST_OVER);
+- cairo_set_source_rgb (cr, 1., 1., 1.);
+- cairo_paint (cr);
++ if (!subpixel_rendering) {
++ cairo_set_operator (cr, CAIRO_OPERATOR_DEST_OVER);
++ cairo_set_source_rgb (cr, 1., 1., 1.);
++ cairo_paint (cr);
++ }
+
+ g_timer_stop (timer);
+
+diff --git a/glib/poppler-page.cc b/glib/poppler-page.cc
+index 3d63bfd..3dc5585 100644
+--- a/glib/poppler-page.cc
++++ b/glib/poppler-page.cc
+@@ -2424,3 +2424,13 @@ poppler_page_get_text_attributes_for_area (PopplerPage *page,
+
+ return g_list_reverse(attributes);
+ }
++
++gboolean
++poppler_page_support_subpixel_rendering (PopplerPage *page)
++{
++ CairoOutputDev *output_dev;
++ g_return_val_if_fail (POPPLER_IS_PAGE (page), FALSE);
++
++ output_dev = page->document->output_dev;
++ return page->page->supportSubpixelRendering(output_dev);
++}
+diff --git a/glib/poppler-page.h b/glib/poppler-page.h
+index fdbfd38..0f02a3a 100644
+--- a/glib/poppler-page.h
++++ b/glib/poppler-page.h
+@@ -109,6 +109,7 @@ GList *poppler_page_get_text_attributes (PopplerPage *pa
+ void poppler_page_free_text_attributes (GList *list);
+ GList * poppler_page_get_text_attributes_for_area (PopplerPage *page,
+ PopplerRectangle *area);
++gboolean poppler_page_support_subpixel_rendering (PopplerPage *page);
+
+ /* A rectangle on a page, with coordinates in PDF points. */
+ #define POPPLER_TYPE_RECTANGLE (poppler_rectangle_get_type ())
+diff --git a/poppler/CairoFontEngine.cc b/poppler/CairoFontEngine.cc
+index 6676f89..3c8fe81 100644
+--- a/poppler/CairoFontEngine.cc
++++ b/poppler/CairoFontEngine.cc
+@@ -132,7 +132,7 @@ CairoFont::getSubstitutionCorrection(GfxFont *gfxFont)
+ cairo_matrix_t m;
+ cairo_matrix_init_identity(&m);
+ cairo_font_options_t *options = cairo_font_options_create();
+- cairo_font_options_set_hint_style(options, CAIRO_HINT_STYLE_NONE);
++ cairo_font_options_set_hint_style(options, CAIRO_HINT_STYLE_SLIGHT);
+ cairo_font_options_set_hint_metrics(options, CAIRO_HINT_METRICS_OFF);
+ cairo_scaled_font_t *scaled_font = cairo_scaled_font_create(cairo_font_face, &m, &m, options);
+
+@@ -190,7 +190,7 @@ _ft_new_face_uncached (FT_Library lib,
+ }
+
+ font_face = cairo_ft_font_face_create_for_ft_face (face,
+- FT_LOAD_NO_HINTING |
++ FT_LOAD_TARGET_LIGHT |
+ FT_LOAD_NO_BITMAP);
+ if (cairo_font_face_set_user_data (font_face,
+ &_ft_cairo_key,
+@@ -359,7 +359,7 @@ _ft_new_face (FT_Library lib,
+ _ft_open_faces = l;
+
+ l->font_face = cairo_ft_font_face_create_for_ft_face (tmpl.face,
+- FT_LOAD_NO_HINTING |
++ FT_LOAD_TARGET_LIGHT |
+ FT_LOAD_NO_BITMAP);
+ if (cairo_font_face_set_user_data (l->font_face,
+ &_ft_cairo_key,
+diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
+index bd18cde..a24ca38 100644
+--- a/poppler/CairoOutputDev.cc
++++ b/poppler/CairoOutputDev.cc
+@@ -203,6 +203,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
+ }
+ if (cairo != NULL) {
+ this->cairo = cairo_reference (cairo);
++ {
++ cairo_font_options_t *options = cairo_font_options_create ();
++ cairo_get_font_options (cairo, options);
++ cairo_font_options_set_antialias (options, CAIRO_ANTIALIAS_SUBPIXEL);
++ cairo_set_font_options (cairo, options);
++ cairo_font_options_destroy (options);
++ }
+ /* save the initial matrix so that we can use it for type3 fonts. */
+ //XXX: is this sufficient? could we miss changes to the matrix somehow?
+ cairo_get_matrix(cairo, &orig_matrix);
+@@ -1430,6 +1437,7 @@ void CairoOutputDev::drawChar(GfxState *state, double x, double y,
+ void CairoOutputDev::endString(GfxState *state)
+ {
+ int render;
++ GfxFontType fontType;
+
+ if (!currentFont)
+ return;
+@@ -1447,6 +1455,18 @@ void CairoOutputDev::endString(GfxState *state)
+ goto finish;
+ }
+
++ fontType = state->getFont()->getType();
++ // Do not enable subpixel rendering for type3 font
++ // For some reason it does not work
++ if (fontType == fontType3) {
++ cairo_save(cairo);
++ cairo_font_options_t *fo;
++ fo = cairo_font_options_create ();
++ cairo_get_font_options (cairo, fo);
++ cairo_font_options_set_antialias (fo, CAIRO_ANTIALIAS_DEFAULT);
++ cairo_set_font_options (cairo, fo);
++ }
++
+ if (!(render & 1)) {
+ LOG (printf ("fill string\n"));
+ cairo_set_source (cairo, fill_pattern);
+@@ -1497,6 +1517,10 @@ void CairoOutputDev::endString(GfxState *state)
+ }
+
+ finish:
++ // pair with the previous cairo_save to disable subpixel rendering for type3 fonts
++ if (fontType == fontType3) {
++ cairo_restore(cairo);
++ }
+ gfree (glyphs);
+ glyphs = NULL;
+ if (use_show_text_glyphs) {
+diff --git a/poppler/Gfx.cc b/poppler/Gfx.cc
+index a8f5be9..0ca1940 100644
+--- a/poppler/Gfx.cc
++++ b/poppler/Gfx.cc
+@@ -4728,6 +4728,62 @@ void Gfx::doImage(Object *ref, Stream *str, GBool inlineImg) {
+ error(errSyntaxError, getPos(), "Bad image parameters");
+ }
+
++GBool Gfx::checkNormalBlendModeOnly(Object *str) {
++ printf("check blender mode start\n");
++ char *cmd;
++ Object obj;
++ Object args[maxArgs];
++ int numArgs, i;
++ GBool onlyNormalBlendMode;
++ Parser myParser(xref, new Lexer(xref, str), gFalse);
++
++ numArgs = 0;
++ onlyNormalBlendMode = gTrue;
++
++ myParser.getObj(&obj);
++ while (!obj.isEOF()) {
++ if (obj.isCmd()) {
++ cmd = obj.getCmd();
++
++ if (strcmp(cmd, "gs") == 0) {
++ Object obj1, obj2;
++ GfxBlendMode mode;
++ if (res->lookupGState(args[0].getName(), &obj1)) {
++ if (!obj1.dictLookup("BM", &obj2)->isNull()) {
++ if (state->parseBlendMode(&obj2, &mode)) {
++ printf("check blend mode: %d\n", mode);
++ onlyNormalBlendMode &= (mode == gfxBlendNormal);
++ }
++ }
++ obj2.free();
++ }
++ obj1.free();
++ }
++ obj.free();
++
++ for (i = 0; i < numArgs; ++i)
++ args[i].free();
++ numArgs = 0;
++
++ } else if (numArgs < maxArgs) {
++ args[numArgs++] = obj;
++ } else {
++ obj.free();
++ }
++
++ myParser.getObj(&obj);
++ }
++ obj.free();
++
++ if (numArgs > 0) {
++ for (i = 0; i < numArgs; ++i)
++ args[i].free();
++ }
++
++ return onlyNormalBlendMode;
++}
++
++
+ GBool Gfx::checkTransparencyGroup(Dict *resDict) {
+ // check the effect of compositing objects as a group:
+ // look for ExtGState entries with ca != 1 or CA != 1 or BM != normal
+diff --git a/poppler/Gfx.h b/poppler/Gfx.h
+index a82f9f4..6a7e2c7 100644
+--- a/poppler/Gfx.h
++++ b/poppler/Gfx.h
+@@ -186,6 +186,9 @@ public:
+ // Get the current graphics state object.
+ GfxState *getState() { return state; }
+
++ // Check whether a stream only contains normal blend mode (to enable subpixel rendering)
++ GBool checkNormalBlendModeOnly(Object *str);
++
+ GBool checkTransparencyGroup(Dict *resDict);
+
+ void drawForm(Object *str, Dict *resDict, double *matrix, double *bbox,
+diff --git a/poppler/Page.cc b/poppler/Page.cc
+index dca52e4..3f63342 100644
+--- a/poppler/Page.cc
++++ b/poppler/Page.cc
+@@ -372,6 +372,20 @@ Dict *Page::getResourceDictCopy(XRef *xrefA) {
+ return dict ? dict->copy(xrefA) : NULL;
+ }
+
++GBool Page::supportSubpixelRendering(OutputDev *out) {
++ GBool supported = gFalse;
++ Object obj;
++ PDFRectangle box;
++
++ contents.fetch(xref, &obj);
++ if (!obj.isNull()) {
++ Gfx gfx(doc, out, attrs->getResourceDict(), &box, NULL);
++ supported = gfx.checkNormalBlendModeOnly(&obj);
++ }
++ obj.free();
++ return supported;
++}
++
+ void Page::replaceXRef(XRef *xrefA) {
+ Object obj1;
+ Dict *pageDict = pageObj.getDict()->copy(xrefA);
+diff --git a/poppler/Page.h b/poppler/Page.h
+index 2aaabae..a49d34f 100644
+--- a/poppler/Page.h
++++ b/poppler/Page.h
+@@ -179,6 +179,9 @@ public:
+ Dict *getResourceDict();
+ Dict *getResourceDictCopy(XRef *xrefA);
+
++ // Whether the content in this page supports subpixel rendering (lcdfilter)
++ GBool supportSubpixelRendering(OutputDev *out);
++
+ // Get annotations array.
+ Object *getAnnots(Object *obj, XRef *xrefA = NULL) { return annotsObj.fetch((xrefA == NULL) ? xref : xrefA, obj); }
+ // Add a new annotation to the page
+--
+2.10.2
+
diff --git a/0003-Forcing-subpixel-rendering-in-Cairo-backend.patch b/0003-Forcing-subpixel-rendering-in-Cairo-backend.patch
deleted file mode 100644
index b4285003ab9e..000000000000
--- a/0003-Forcing-subpixel-rendering-in-Cairo-backend.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From c935463856b48d307ca766a676be573e242525a9 Mon Sep 17 00:00:00 2001
-From: Paul Gideon Dann <pdgiddie@gmail.com>
-Date: Wed, 20 May 2009 13:06:48 +0100
-Subject: [PATCH 3/4] Forcing subpixel rendering in Cairo backend
-
----
- poppler/CairoOutputDev.cc | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/poppler/CairoOutputDev.cc b/poppler/CairoOutputDev.cc
-index bd18cde..3a563eb 100644
---- a/poppler/CairoOutputDev.cc
-+++ b/poppler/CairoOutputDev.cc
-@@ -203,6 +203,13 @@ void CairoOutputDev::setCairo(cairo_t *cairo)
- }
- if (cairo != NULL) {
- this->cairo = cairo_reference (cairo);
-+ {
-+ cairo_font_options_t *options = cairo_font_options_create ();
-+ cairo_get_font_options (cairo, options);
-+ cairo_font_options_set_antialias (options, CAIRO_ANTIALIAS_SUBPIXEL);
-+ cairo_set_font_options (cairo, options);
-+ cairo_font_options_destroy (options);
-+ }
- /* save the initial matrix so that we can use it for type3 fonts. */
- //XXX: is this sufficient? could we miss changes to the matrix somehow?
- cairo_get_matrix(cairo, &orig_matrix);
---
-2.9.2
-
diff --git a/0004-Don-t-build-the-main-poppler-library.patch b/0004-Don-t-build-the-main-poppler-library.patch
index ee6f611d0874..316da4487c48 100644
--- a/0004-Don-t-build-the-main-poppler-library.patch
+++ b/0004-Don-t-build-the-main-poppler-library.patch
@@ -1,4 +1,4 @@
-From 8a3d08351ebedd4efdfc90944911c52845097514 Mon Sep 17 00:00:00 2001
+From 4c8400476ac033cdb40c2e198bfaf736c3017367 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Tue, 20 Oct 2009 18:32:35 +0100
Subject: [PATCH 4/4] Don't build the main poppler library.
@@ -8,7 +8,7 @@ Subject: [PATCH 4/4] Don't build the main poppler library.
1 file changed, 11 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c90d0e8..4ba7bdd 100644
+index c25e961..00d231c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -495,17 +495,6 @@ if(HAVE_PTHREAD)
@@ -22,7 +22,7 @@ index c90d0e8..4ba7bdd 100644
-else(MSVC)
-add_library(poppler SHARED ${poppler_SRCS})
-endif(MSVC)
--set_target_properties(poppler PROPERTIES VERSION 63.0.0 SOVERSION 63)
+-set_target_properties(poppler PROPERTIES VERSION 65.0.0 SOVERSION 65)
-target_link_libraries(poppler LINK_PRIVATE ${poppler_LIBS})
-install(TARGETS poppler RUNTIME DESTINATION bin LIBRARY DESTINATION lib${LIB_SUFFIX} ARCHIVE DESTINATION lib${LIB_SUFFIX})
-
@@ -30,5 +30,5 @@ index c90d0e8..4ba7bdd 100644
install(FILES
poppler/Annot.h
--
-2.9.2
+2.10.2
diff --git a/PKGBUILD b/PKGBUILD
index c2e981e4f43b..f2e6b3ff602a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paul Gideon Dann <pdgiddie_at_gmail.com>
pkgname=poppler-qt-lcd
-pkgver=0.46.0
+pkgver=0.49.0
pkgrel=1
pkgdesc="Poppler Qt bindings, with patches to allow subpixel rendering via Cairo"
license=('GPL')
@@ -15,13 +15,13 @@ url="https://github.com/giddie/poppler-qt4-cairo-backend"
source=(http://poppler.freedesktop.org/poppler-${pkgver}.tar.xz
0001-Cairo-backend-added-to-Qt4-wrapper.patch
0002-Setting-default-Qt4-backend-to-Cairo.patch
- 0003-Forcing-subpixel-rendering-in-Cairo-backend.patch
+ 0003-Apply-subpixel-rendering-in-Cairo-Backend.patch
0004-Don-t-build-the-main-poppler-library.patch)
-md5sums=('a6513d6fe72751c58b501403c3da6ef1'
- '1964c4388455d9da02fda267b3bbc0b6'
- '6579a7896f9a2e4bb10bb19b552dda6c'
- 'bd9df787addbc9a98f49192732465dc4'
- '892694d6cfce9e6c321253cf62fc9001')
+md5sums=('9e057ed8eee1f9979fa75d8f044783b8'
+ '2dced22cd5ca3b0432aeb643a20c5d98'
+ 'c89bbfba7d89b88c3120ff9f6b089ea9'
+ '86be3ae0b8073ad315ccb5f65cb5d519'
+ '3a767dda20553fad7fec9d3b907784aa')
build() {
cd "${srcdir}/poppler-${pkgver}"