summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-11-01 05:00:09 +0100
committerPellegrino Prevete2021-11-01 05:00:09 +0100
commit300c0cc852fba9f8b9d0b36ad93f345204811a17 (patch)
tree566f422256b7dc5c61158e2e9c45a874860b86ff
downloadaur-300c0cc852fba9f8b9d0b36ad93f345204811a17.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8b50db776b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pops-usb-setup
+ pkgdesc = Setup a USB drive for the POPS emulator
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://gitlab.com/tallero/pops-usb-setup
+ arch = any
+ license = AGPL3
+ makedepends = git
+ makedepends = python-setuptools
+ makedepends = wget
+ depends = python
+ source = git+https://gitlab.com/tallero/pops-usb-setup
+ md5sums = SKIP
+
+pkgname = pops-usb-setup
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fe5defb97ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+
+pkgname=pops-usb-setup
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Setup a USB drive for the POPS emulator"
+arch=('any')
+url="https://gitlab.com/tallero/pops-usb-setup"
+license=('AGPL3')
+depends=('python')
+makedepends=('git' 'python-setuptools' 'wget')
+source=("git+$url")
+md5sums=(SKIP)
+
+package() {
+ cd $pkgname/pops_usb_setup/usb
+ rm -rf bitbucket
+ git clone "https://github.com/AnimMouse/POPS-binaries" bitbucket
+
+ cd archive
+ wget "https://archive.org/download/pops-iox/POPSTARTER.ELF"
+ wget "https://archive.org/download/pops-iox/POPS_IOX.PAK"
+
+ cd ../../../
+
+ python3 setup.py install --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: