summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-11-01 16:00:26 +0100
committerPellegrino Prevete2021-11-01 16:00:26 +0100
commit5d208e0da50b1b88ac8521179f985525272f71cf (patch)
treee1347edfe43ce132be639e28498a3ba898cbd11e
parent6069bdb2bdd927773846d1dee296aa02f582d0b1 (diff)
downloadaur-5d208e0da50b1b88ac8521179f985525272f71cf.tar.gz
Integrated resources retrieval
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 43 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b14007033d..cf0814159f9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pops-usb-setup
pkgdesc = Setup a USB drive for the POPS emulator
pkgver = 0.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/tallero/pops-usb-setup
arch = any
license = AGPL3
@@ -10,7 +10,15 @@ pkgbase = pops-usb-setup
makedepends = wget
depends = python
options = !strip
- source = git+https://gitlab.com/tallero/pops-usb-setup
- md5sums = SKIP
+ source = git+https://gitlab.com/tallero/pops-usb-setup#branch=opl
+ source = git+https://github.com/AnimMouse/POPS-binaries#commit=c63de15
+ source = https://github.com/ps2homebrew/Open-PS2-Loader/releases/download/v1.1.0/OPNPS2LD.7z
+ source = https://archive.org/download/pops-iox/POPSTARTER.ELF
+ source = https://archive.org/download/pops-iox/POPS_IOX.PAK
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = e39a5537f8bfd5fcc9964f1d20302a02f5936c3bd5154db61b85aa16d9182a83f70135c4782ef38ca1120137c2c19c508587d3a7e69016008f2c77dca44ac50b
+ sha512sums = 2449bc74620434e8ef6e6bf0f564957b0ba80a9ea53d15a3245e2873367f61d8e0d0670f04003c3dc6d778c6a540be35570052d6f8ccd7201e6dbf6b4600ba9e
+ sha512sums = d171b51f19080f1dcbd25acdd3c8695014352472dd2a164b6053bfe8bb52741ef35e1852a244ba18c018a79eecd26ce185fc9d67bde85f32f48a7fdca01bf751
pkgname = pops-usb-setup
diff --git a/PKGBUILD b/PKGBUILD
index 00c917c93438..297acf6d9c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,50 @@
# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+_opl_url="https://github.com/ps2homebrew/Open-PS2-Loader"
+_opl_ver="1.1.0"
+_opl_name="OPNPS2LD"
+_pops_url="https://github.com/AnimMouse/POPS-binaries"
+_pops_commit="c63de15"
+
pkgname=pops-usb-setup
pkgver=0.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Setup a USB drive for the POPS emulator"
arch=('any')
url="https://gitlab.com/tallero/pops-usb-setup"
license=('AGPL3')
depends=('python')
+makedepends=('p7zip' 'python-setuptools')
options=(!strip)
makedepends=('git' 'python-setuptools' 'wget')
-source=("git+$url")
-md5sums=(SKIP)
+source=("git+$url#branch=opl"
+ "git+$_pops_url#commit=$_pops_commit"
+ "$_opl_url/releases/download/v$_opl_ver/$_opl_name.7z"
+ "https://archive.org/download/pops-iox/POPSTARTER.ELF"
+ "https://archive.org/download/pops-iox/POPS_IOX.PAK")
+sha512sums=(SKIP
+ SKIP
+ e39a5537f8bfd5fcc9964f1d20302a02f5936c3bd5154db61b85aa16d9182a83f70135c4782ef38ca1120137c2c19c508587d3a7e69016008f2c77dca44ac50b
+ 2449bc74620434e8ef6e6bf0f564957b0ba80a9ea53d15a3245e2873367f61d8e0d0670f04003c3dc6d778c6a540be35570052d6f8ccd7201e6dbf6b4600ba9e
+ d171b51f19080f1dcbd25acdd3c8695014352472dd2a164b6053bfe8bb52741ef35e1852a244ba18c018a79eecd26ce185fc9d67bde85f32f48a7fdca01bf751)
package() {
- cd $pkgname/pops_usb_setup/usb
- rm -rf bitbucket
- git clone "https://github.com/AnimMouse/POPS-binaries" bitbucket
- cd archive
- wget "https://archive.org/download/pops-iox/POPSTARTER.ELF"
- wget "https://archive.org/download/pops-iox/POPS_IOX.PAK"
+ module_dir="$srcdir/$pkgname/pops_usb_setup"
+
+ mv $srcdir/$_opl_name/$_opl_name-v$_opl_ver.ELF \
+ $module_dir/opl/$_opl_name.ELF
+
+ mv $srcdir/POPS-binaries/* \
+ $module_dir/usb/bitbucket
+
+ mv $srcdir/POPS_IOX.PAK \
+ $module_dir/usb/archive
+
+ mv $srcdir/POPSTARTER.ELF \
+ $module_dir/usb/archive
- cd ../../../
+ cd $pkgname
python3 setup.py install --root="$pkgdir"
}