summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-12-13 02:39:54 +0000
committerPellegrino Prevete2021-12-13 02:39:54 +0000
commitda3edd0bac31065cb0e5525490d06a1ae4fc60f9 (patch)
treeb14dbd853afb4dbb70c666d7225fe6db19c00f03
parente677c4c732bcb4a8b610056c63e0655c05d5d782 (diff)
downloadaur-da3edd0bac31065cb0e5525490d06a1ae4fc60f9.tar.gz
double makedepends var
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e9fc724751c..2c7c5d4e221c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,6 +5,8 @@ _opl_ver="1.1.0"
_opl_name="OPNPS2LD"
_pops_url="https://github.com/AnimMouse/POPS-binaries"
_pops_commit="c63de15"
+_popstarter_name="POPStarter_SMB_Quickstarter_Pack_20200209"
+_popstarter_smb="https://bitbucket.org/ShaolinAssassin/popstarter-documentation-stuff/downloads/$_popstarter_name.zip"
pkgname=pops-usb-setup
pkgver=0.0.1
@@ -14,19 +16,20 @@ arch=('any')
url="https://gitlab.com/tallero/pops-usb-setup"
license=('AGPL3')
depends=('python')
-makedepends=('p7zip' 'python-setuptools')
+makedepends=('git' 'p7zip' 'python-setuptools')
options=(!strip)
-makedepends=('git' 'python-setuptools' 'wget')
source=("git+$url"
"git+$_pops_url#commit=$_pops_commit"
"$_opl_url/releases/download/v$_opl_ver/$_opl_name.7z"
"https://archive.org/download/pops-iox/POPSTARTER.ELF"
- "https://archive.org/download/pops-iox/POPS_IOX.PAK")
+ "https://archive.org/download/pops-iox/POPS_IOX.PAK"
+ "$_popstarter_smb")
sha512sums=(SKIP
SKIP
e39a5537f8bfd5fcc9964f1d20302a02f5936c3bd5154db61b85aa16d9182a83f70135c4782ef38ca1120137c2c19c508587d3a7e69016008f2c77dca44ac50b
2449bc74620434e8ef6e6bf0f564957b0ba80a9ea53d15a3245e2873367f61d8e0d0670f04003c3dc6d778c6a540be35570052d6f8ccd7201e6dbf6b4600ba9e
- d171b51f19080f1dcbd25acdd3c8695014352472dd2a164b6053bfe8bb52741ef35e1852a244ba18c018a79eecd26ce185fc9d67bde85f32f48a7fdca01bf751)
+ d171b51f19080f1dcbd25acdd3c8695014352472dd2a164b6053bfe8bb52741ef35e1852a244ba18c018a79eecd26ce185fc9d67bde85f32f48a7fdca01bf751
+ SKIP)
package() {
@@ -44,6 +47,9 @@ package() {
mv $srcdir/POPSTARTER.ELF \
$module_dir/usb/archive
+ mv $srcdir/$_popstarter_name/network_modules/* \
+ $module_dir/smb/
+
cd $pkgname
python3 setup.py install --root="$pkgdir"