summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Hamelink2017-10-11 14:50:58 +0100
committerJohn Hamelink2017-10-11 14:54:42 +0100
commit300371f83467d41cd7aa01f07539a97bc7497e91 (patch)
treeb400d33cd51320acf023953f36cfc1a8d22ef042
downloadaur-300371f83467d41cd7aa01f07539a97bc7497e91.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD27
-rw-r--r--popsql.install19
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43d4ccf30b39
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = popsql
+ pkgdesc = Collaborative SQL editor to write, run, and share queries instantly
+ pkgver = 0.4.2
+ pkgrel = 2
+ url = https://popsql.io
+ install = popsql.install
+ arch = x86_64
+ license = unknown
+ depends = gconf
+ depends = nss
+ depends = libxss
+ depends = gtk2
+ optdepends = alsa-lib: Audio notifications
+ optdepends = libnotify: Visual notifications
+ optdepends = libappindicator-gtk2: System Tray support
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = popsql-0.4.2.deb::https://get.popsql.io/download/linux_deb_64
+ sha512sums_x86_64 = 5664c91d12708cac9bacffbdffd4e868e0145b60387afcadc273b60da705325d47d010a74f4a600a6517dbc387612240ac13151e2d57c9a2905c60118b5b2ceb
+
+pkgname = popsql
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f464460a9aaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Generated by debtap
+# Maintainer: John Hamelink <john@johnhamelink.com>
+pkgname=popsql
+pkgver=0.4.2
+pkgrel=2
+pkgdesc="Collaborative SQL editor to write, run, and share queries instantly"
+arch=('x86_64')
+url="https://popsql.io"
+license=('unknown')
+groups=()
+depends=('gconf' 'nss' 'libxss' 'gtk2')
+optdepends=(
+ 'alsa-lib: Audio notifications'
+ 'libnotify: Visual notifications'
+ 'libappindicator-gtk2: System Tray support')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("popsql-0.4.2.deb::https://get.popsql.io/download/linux_deb_64")
+sha512sums_x86_64=('5664c91d12708cac9bacffbdffd4e868e0145b60387afcadc273b60da705325d47d010a74f4a600a6517dbc387612240ac13151e2d57c9a2905c60118b5b2ceb')
+
+package(){
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+ # Create a Licenses directory, add a license file
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ echo "Copyright PopSQL, inc. All rights reserved" > "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/popsql.install b/popsql.install
new file mode 100644
index 000000000000..2b266cb92721
--- /dev/null
+++ b/popsql.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/PopSQL/popsql' '/usr/bin/popsql'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/popsql'
+ update-desktop-database -q
+}