summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:31:09 +0200
committersl1pkn072015-06-08 19:31:09 +0200
commit3a83e62009147d1347ada7d9cf6f549922a1c518 (patch)
tree3f2010432c4bed848b5f89ce785a3d28efcaadbc
downloadaur-3a83e62009147d1347ada7d9cf6f549922a1c518.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..957825d16d9c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = popstation
+ pkgdesc = Play PSX Games in Sony PSP, One Disc Games
+ pkgver = 1.0.0
+ pkgrel = 2
+ url = http://dark-alex.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ options = !buildflags
+ source = http://leandroufcgprojects.googlecode.com/files/popstation-1.0.0.tar.gz
+ sha1sums = 0c16b9d7846fa1b62fdafc756478b34d524baf33
+
+pkgname = popstation
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c223769926e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Leandro de Assis <leandrodiassis@gmail.com>
+
+pkgname=popstation
+pkgver=1.0.0
+pkgrel=2
+pkgdesc="Play PSX Games in Sony PSP, One Disc Games"
+arch=('i686' 'x86_64')
+url="http://dark-alex.org/"
+license=('GPL')
+depends=('zlib')
+source=("http://leandroufcgprojects.googlecode.com/files/${pkgname}-${pkgver}.tar.gz")
+sha1sums=('0c16b9d7846fa1b62fdafc756478b34d524baf33')
+options=('!buildflags')
+
+prepare() {
+ rm -fr build
+ cp -R "${pkgname}" build
+}
+
+build() {
+ cd build
+ make
+}
+
+package() {
+ cd build
+ install popstation -Dm755 "${pkgdir}/usr/bin/popstation"
+}