summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPBlue32019-07-08 19:03:35 +0200
committerPBlue32019-07-08 19:03:35 +0200
commit586e0796111cad67fef59d67961ba673b3603a22 (patch)
treee3117fee6bb5091cb878592cd840a55c01f54799
downloadaur-586e0796111cad67fef59d67961ba673b3603a22.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a93bd0641585
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Nov 26 18:41:10 UTC 2016
+pkgbase = popstation
+ pkgdesc = Play PSX Games in Sony PSP, One Disc Games
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://dark-alex.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/leandroufcgprojects/popstation-1.0.0.tar.gz
+ sha256sums = 47a1c88518377110b006725b29ac6847bb4cfc8d918395235512d4053972e10b
+
+pkgname = popstation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d2e3c88aa6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: PBlue3 <pblue3@protonmail.com>
+
+pkgname="popstationr-git"
+_pkgname="popstationr"
+pkgver=20190708
+pkgrel=1
+pkgdesc="popstationr is ISO to EBOOT.bin converter to convert PSX ISO images to use with modded PSPs or adrenaline for PS Vita"
+arch=('x86_64')
+url='https://github.com/pseiler/popstationr.git'
+license=('GPL')
+depends=('zlib')
+makedepends=('git')
+source=('git+https://github.com/pseiler/popstationr.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format="%at" | xargs -I{} date -d @{} +%Y%m%d
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}/${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+}