summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzat Khuzhin2017-08-31 02:53:32 +0300
committerAzat Khuzhin2017-08-31 03:00:57 +0300
commitd2ae6c85d226d7a16c204c70639b25c6f8b8b0fc (patch)
tree1b64e857b9021366f9dae5abc653292bc7f978ec
downloadaur-d2ae6c85d226d7a16c204c70639b25c6f8b8b0fc.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..170a0155fa8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = popt-deb
+ pkgdesc = popt with debian patches (mostly to avoid double free)
+ pkgver = 1.16.10
+ pkgrel = 1
+ url = https://github.com/azat/popt
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gcc
+ makedepends = git
+ makedepends = libtool
+ makedepends = make
+ provides = popt
+ conflicts = popt
+ source = git+https://github.com/azat/popt#branch=patched
+ md5sums = SKIP
+
+pkgname = popt-deb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4363e552552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+Maintainer='Azat Khuzhin <a3at.mail@gmail.com>'
+pkgname=popt-deb
+pkgdesc='popt with debian patches (mostly to avoid double free)'
+pkgver=1.16.10
+pkgrel=1
+arch=(x86_64)
+url='https://github.com/azat/popt'
+license=('GPL')
+provides=(popt)
+conflicts=(popt)
+makedepends=('autoconf' 'automake' 'gcc' 'git' 'libtool' 'make')
+source=('git+https://github.com/azat/popt#branch=patched')
+md5sums=(SKIP)
+
+build() {
+ cd popt
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd popt
+ make DESTDIR="$pkgdir/" install
+}