summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2015-06-09 09:45:04 +1000
committerXavion2015-06-09 09:45:04 +1000
commit7bb5b86f4cb7aeb55bc6faa745783e9d23f3d8dd (patch)
tree54e3a6b4d782c2f3e93f0a83621b1d04e2a5cbf1
downloadaur-7bb5b86f4cb7aeb55bc6faa745783e9d23f3d8dd.tar.gz
Initial AUR v4 importation
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68092aa2798a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = popular-packages
+ pkgdesc = Lists popular packages not installed
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = http://i.imgur.com/AeWSX.jpg
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = wget
+ depends = package-query
+ optdepends = pacman-cage: Better performance
+ options = !emptydirs
+ source = http://dl.dropbox.com/u/106000/Software/Shell/popular-packages
+ sha1sums = 989ef1aedd753e59e08e3e25fa5408cc2232ef41
+
+pkgname = popular-packages
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3a34a59552a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=popular-packages
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="Lists popular packages not installed"
+arch=("any")
+url="http://i.imgur.com/AeWSX.jpg"
+license=("GPL3")
+depends=("bash" "wget" "package-query")
+optdepends=("pacman-cage: Better performance")
+options=(!emptydirs)
+source=(http://dl.dropbox.com/u/106000/Software/Shell/${pkgname})
+
+package() {
+ cd "${srcdir}"
+
+ install -D -m755 ${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+}
+
+sha1sums=('989ef1aedd753e59e08e3e25fa5408cc2232ef41')