summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-05-20 11:05:57 -0500
committerAnthony Wang2022-05-20 11:05:57 -0500
commitd89f0cf60f33b6ccf98dba6c437bf8383dff4d4a (patch)
treedc176f9e393feca955a8505613893333d824084d
downloadaur-d89f0cf60f33b6ccf98dba6c437bf8383dff4d4a.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07c2843387d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = porkbun-dynamic-dns-python-git
+ pkgdesc = Our minimalist dynamic DNS client written in Python
+ pkgver = r16.aca7407
+ pkgrel = 1
+ url = https://github.com/Ta180m/porkbun-dynamic-dns-python
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-requests
+ backup = etc/porkbun-ddns.json
+ source = porkbun-dynamic-dns-python::git+https://github.com/Ta180m/porkbun-dynamic-dns-python.git
+ sha256sums = SKIP
+
+pkgname = porkbun-dynamic-dns-python-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d222e565c77d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Anthony Wang <ta180m@pm.me>
+_pkgname=porkbun-dynamic-dns-python
+pkgname=${_pkgname}-git
+pkgver=r16.aca7407
+pkgrel=1
+pkgdesc="Our minimalist dynamic DNS client written in Python"
+arch=(any)
+url="https://github.com/Ta180m/porkbun-dynamic-dns-python"
+license=('MIT')
+depends=('python' 'python-requests')
+backup=('etc/porkbun-ddns.json')
+source=("${_pkgname}::git+${url}.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ install -vDm755 porkbun-ddns.py "$pkgdir/usr/bin/porkbun-ddns"
+ install -vDm600 config.json.example "$pkgdir/etc/porkbun-ddns.json"
+ install -vDm644 systemd.service "$pkgdir/usr/lib/systemd/system/porkbun-ddns.service"
+ install -vDm644 systemd.timer "$pkgdir/usr/lib/systemd/system/porkbun-ddns.timer"
+}