summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Barrett2021-05-31 20:21:00 +0200
committerTom Barrett2021-05-31 20:21:00 +0200
commit04bfff32748f88419e68715affbc4fe2cf347c45 (patch)
tree11d29de90d0e945f8c2335f84dae8a351306973b
parent766cdb9283f910a81b8bd1b5c2409904aa1c687b (diff)
downloadaur-04bfff32748f88419e68715affbc4fe2cf347c45.tar.gz
Help from knutsen
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..48c7b872c5ce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+*zip
+*zst
+port
diff --git a/PKGBUILD b/PKGBUILD
index fce00fedb065..65396cb6ec89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,9 @@ sha512sums=("SKIP")
package() {
yarn --cwd "$srcdir"/port
- # the | true is really stupid but until we can just build the exec, i think its required
- yarn --cwd "$srcdir"/port/ run make:linux | true
- mkdir -p "$pkgdir"/usr/bin
- ln -s "$srcdir"/port/out/port-linux-x64/port "$pkgdir"/usr/bin
+ yarn --cwd "$srcdir"/port/ make --targets=@electron-forge/maker-zip
+ install -d -m755 "$pkgdir"/usr/bin
+ install -d -m755 "$pkgdir"/usr/share/port
+ cp -r "$srcdir"/port/out/port-linux-x64* "$pkgdir"/usr/share/port
+ ln -s /usr/share/port/port "$pkgdir"/usr/bin/port
}