summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Barrett2021-05-31 19:04:29 +0200
committerTom Barrett2021-05-31 19:04:29 +0200
commit766cdb9283f910a81b8bd1b5c2409904aa1c687b (patch)
treec59012ce7f22ebf1473948c5db8658f42d44854c
downloadaur-766cdb9283f910a81b8bd1b5c2409904aa1c687b.tar.gz
First version added to the AUR.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD22
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2bd293d628d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = port
+ pkgdesc = A ship runner and manager for Urbit OS
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/arthyn/port
+ arch = x86_64
+ license = MIT
+ license = custom:chromium
+ depends = urbit
+ depends = yarn
+ depends = dpkg
+ depends = fakeroot
+ depends = zip
+ conflicts = port-bin
+ source = git+https://github.com/arthyn/port.git#tag=v1.0.1
+ sha512sums = SKIP
+
+pkgname = port
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fce00fedb065
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: tom barrett <tom at tombarrett dot xyz>
+# https://aur.archlinux.org/packages/port-bin/
+
+pkgname=port
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A ship runner and manager for Urbit OS"
+arch=("x86_64")
+url="https://github.com/arthyn/port"
+license=("MIT" "custom:chromium")
+depends=("urbit" "yarn" "dpkg" "fakeroot" "zip")
+conflicts=("port-bin")
+source=("git+https://github.com/arthyn/port.git#tag=v${pkgver}")
+sha512sums=("SKIP")
+
+package() {
+ yarn --cwd "$srcdir"/port
+ # the | true is really stupid but until we can just build the exec, i think its required
+ yarn --cwd "$srcdir"/port/ run make:linux | true
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s "$srcdir"/port/out/port-linux-x64/port "$pkgdir"/usr/bin
+}