summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSP2015-10-08 20:12:56 +0000
committerSP2015-10-08 20:12:56 +0000
commite71e8da1046e118451e3de0fe25c747b85adfcac (patch)
treefec551e43e39d5347c32372b6a04772dd0dd4671
parent39cd568824cb3b8149edc6971507df7076e4ebab (diff)
downloadaur-e71e8da1046e118451e3de0fe25c747b85adfcac.tar.gz
added portal.install and backup array for postfix files
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD11
-rw-r--r--portal.install11
3 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e8fd8d09209..c86a7d76fddb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Mon Oct 5 21:42:18 UTC 2015
+# Thu Oct 8 20:12:06 UTC 2015
pkgbase = portal
pkgdesc = A personal portal system
pkgver = 0.1.1
pkgrel = 1
url = http://orbitalfox.com
+ install = portal.install
arch = any
license = LGPL3
depends = postfix
@@ -12,6 +13,16 @@ pkgbase = portal
depends = nginx
optdepends = yamado
provides = portal
+ backup = etc/postfix/access
+ backup = etc/postfix/aliases
+ backup = etc/postfix/canonical
+ backup = etc/postfix/generic
+ backup = etc/postfix/header_checks
+ backup = etc/postfix/main.cf
+ backup = etc/postfix/master.cf
+ backup = etc/postfix/relocated
+ backup = etc/postfix/transport
+ backup = etc/postfix/virtual
source = https://github.com/orbifx/portal/releases/download/v0.1-beta/portal-postconf.tar.gz
md5sums = ca4a222928203019be0aab260e342def
diff --git a/PKGBUILD b/PKGBUILD
index 4eb359c45f5e..cb3e4d28f78f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,22 +13,15 @@ optdepends=(yamado)
provides=("portal")
conflicts=()
replaces=()
-backup=()
+backup=('etc/postfix/'{access,aliases,canonical,generic,header_checks,main.cf,master.cf,relocated,transport,virtual})
options=()
-install=
+install="portal.install"
changelog=
source=(#"git+https://github.com/orbifx/portal.git"
https://github.com/orbifx/portal/releases/download/v0.1-beta/portal-postconf.tar.gz)
noextract=()
md5sums=('ca4a222928203019be0aab260e342def')
-build() {
-# cd "$pkgname-$pkgver"
-# ./configure --prefix=/usr
-# make
-true
-}
-
package() {
install -Dm544 portal-postconf "$pkgdir/usr/bin/portal-postconf"
}
diff --git a/portal.install b/portal.install
new file mode 100644
index 000000000000..2a8853332d6c
--- /dev/null
+++ b/portal.install
@@ -0,0 +1,11 @@
+post_install() {
+ portal-postconf -d "$HOST"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}