summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSP2015-10-24 17:45:14 +0000
committerSP2015-10-24 17:45:14 +0000
commitfe336e603fb3c0675936a38df8d3da250aace003 (patch)
treec0c45b2eb6d77f959d1fdee2ac7e04bf79f91292
parenta4af7a257bb60555a6e3cb0e2c1524b683971d0e (diff)
downloadaur-fe336e603fb3c0675936a38df8d3da250aace003.tar.gz
added dovecot auth configuration and new beta package
-rw-r--r--.SRCINFO10
-rw-r--r--10-master.conf121
-rw-r--r--PKGBUILD8
3 files changed, 130 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25648e8173e5..1cdbe834fc4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Oct 24 17:17:12 UTC 2015
+# Sat Oct 24 17:44:29 UTC 2015
pkgbase = portal
pkgdesc = A personal portal system. Alpha version, do not install unless you know what you are doing
- pkgver = 0.1.5
- pkgrel = 2
+ pkgver = 0.1.6
+ pkgrel = 0
url = http://orbitalfox.com
install = portal.install
arch = any
@@ -14,8 +14,8 @@ pkgbase = portal
depends = nginx
optdepends = yamado
provides = portal
- source = https://github.com/orbifx/portal/releases/download/v0.1-beta/portal.tar.gz
- md5sums = 4dda94de96f9840bdc32e6471499a360
+ source = https://github.com/orbifx/portal/releases/download/v0.2-beta/portal.tar.gz
+ md5sums = f4ba827fe5398a9afcb869bbfa450c54
pkgname = portal
diff --git a/10-master.conf b/10-master.conf
new file mode 100644
index 000000000000..0349e870a755
--- /dev/null
+++ b/10-master.conf
@@ -0,0 +1,121 @@
+#default_process_limit = 100
+#default_client_limit = 1000
+
+# Default VSZ (virtual memory size) limit for service processes. This is mainly
+# intended to catch and kill processes that leak memory before they eat up
+# everything.
+#default_vsz_limit = 256M
+
+# Login user is internally used by login processes. This is the most untrusted
+# user in Dovecot system. It shouldn't have access to anything at all.
+#default_login_user = dovenull
+
+# Internal user is used by unprivileged processes. It should be separate from
+# login user, so that login processes can't disturb other processes.
+#default_internal_user = dovecot
+
+service imap-login {
+ inet_listener imap {
+ #port = 143
+ }
+ inet_listener imaps {
+ #port = 993
+ #ssl = yes
+ }
+
+ # Number of connections to handle before starting a new process. Typically
+ # the only useful values are 0 (unlimited) or 1. 1 is more secure, but 0
+ # is faster. <doc/wiki/LoginProcess.txt>
+ #service_count = 1
+
+ # Number of processes to always keep waiting for more connections.
+ #process_min_avail = 0
+
+ # If you set service_count=0, you probably need to grow this.
+ #vsz_limit = $default_vsz_limit
+}
+
+service pop3-login {
+ inet_listener pop3 {
+ #port = 110
+ }
+ inet_listener pop3s {
+ #port = 995
+ #ssl = yes
+ }
+}
+
+service lmtp {
+ unix_listener lmtp {
+ #mode = 0666
+ }
+
+ # Create inet listener only if you can't use the above UNIX socket
+ #inet_listener lmtp {
+ # Avoid making LMTP visible for the entire internet
+ #address =
+ #port =
+ #}
+}
+
+service imap {
+ # Most of the memory goes to mmap()ing files. You may need to increase this
+ # limit if you have huge mailboxes.
+ #vsz_limit = $default_vsz_limit
+
+ # Max. number of IMAP processes (connections)
+ #process_limit = 1024
+}
+
+service pop3 {
+ # Max. number of POP3 processes (connections)
+ #process_limit = 1024
+}
+
+service auth {
+ # auth_socket_path points to this userdb socket by default. It's typically
+ # used by dovecot-lda, doveadm, possibly imap process, etc. Users that have
+ # full permissions to this socket are able to get a list of all usernames and
+ # get the results of everyone's userdb lookups.
+ #
+ # The default 0666 mode allows anyone to connect to the socket, but the
+ # userdb lookups will succeed only if the userdb returns an "uid" field that
+ # matches the caller process's UID. Also if caller's uid or gid matches the
+ # socket's uid or gid the lookup succeeds. Anything else causes a failure.
+ #
+ # To give the caller full permissions to lookup all users, set the mode to
+ # something else than 0666 and Dovecot lets the kernel enforce the
+ # permissions (e.g. 0777 allows everyone full permissions).
+ unix_listener auth-userdb {
+ #mode = 0666
+ #user =
+ #group =
+ }
+
+ # Postfix smtp-auth
+ unix_listener /var/spool/postfix/private/auth {
+ group = postfix
+ user = postfix
+ mode = 0666
+ }
+
+ # Auth process is run as this user.
+ user = root
+}
+
+service auth-worker {
+ # Auth worker process is run as root by default, so that it can access
+ # /etc/shadow. If this isn't necessary, the user should be changed to
+ # $default_internal_user.
+ #user = root
+}
+
+service dict {
+ # If dict proxy is used, mail processes should have access to its socket.
+ # For example: mode=0660, group=vmail and global mail_access_groups=vmail
+ unix_listener dict {
+ #mode = 0600
+ #user =
+ #group =
+ }
+}
diff --git a/PKGBUILD b/PKGBUILD
index f541cc3b4cca..7fe4e0b93d51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stavros Polymenis <sp@orbitalfox.com>
pkgname=portal
-pkgver=0.1.5
-pkgrel=2
+pkgver=0.1.6
+pkgrel=0
pkgdesc="A personal portal system. Alpha version, do not install unless you know what you are doing"
arch=(any)
url="http://orbitalfox.com"
@@ -17,9 +17,9 @@ options=()
install="portal.install"
changelog=
source=(#"git+https://github.com/orbifx/portal.git"
- https://github.com/orbifx/portal/releases/download/v0.1-beta/portal.tar.gz)
+ https://github.com/orbifx/portal/releases/download/v0.2-beta/portal.tar.gz)
noextract=()
-md5sums=('4dda94de96f9840bdc32e6471499a360')
+md5sums=('f4ba827fe5398a9afcb869bbfa450c54')
package() {
install -Dm544 portal "$pkgdir/usr/bin/portal"