summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolai Schmid2019-09-30 14:55:52 +0200
committerNicolai Schmid2019-09-30 14:55:52 +0200
commit8c1687ae97727e5dc3fcb9fb7f6f094b8b121efa (patch)
tree3b7c01104acf439058d592fd81d4cb9ace8f8e0c
downloadaur-8c1687ae97727e5dc3fcb9fb7f6f094b8b121efa.tar.gz
feat: publish initial PKGBUILD with portfolio-performance version 0.41.1
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
-rw-r--r--portfolio-performance.desktop10
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8e6f221218d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = portfolio-performance-bin
+ pkgdesc = A simple tool to calculate the overall performance of an investment portfolio.
+ pkgver = 0.41.1
+ pkgrel = 1
+ url = https://www.portfolio-performance.info
+ arch = x86_64
+ options = !strip
+ source = portfolio_0.41.1.tar.gz::https://github.com/buchen/portfolio/releases/download/0.41.1/PortfolioPerformance-0.41.1-linux.gtk.x86_64.tar.gz
+ source = portfolio-performance.desktop
+ md5sums = 3d2f53e4afdc9dd8b4ac250b63129d81
+ md5sums = a1204cabfcbf5a026cd44923b87be026
+
+pkgname = portfolio-performance-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27c3bb1ccb9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src
+pkg
+portfolio*.tar*
+.idea
+.DS_Store
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31d1779f43a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Nicolai Schmid <nicolai@schmid.uno>
+
+pkgname=portfolio-performance-bin
+pkgver=0.41.1
+pkgrel=1
+pkgdesc="A simple tool to calculate the overall performance of an investment portfolio."
+arch=('x86_64')
+url="https://www.portfolio-performance.info"
+options=('!strip')
+depends=()
+
+source=(
+ portfolio_$pkgver.tar.gz::"https://github.com/buchen/portfolio/releases/download/${pkgver}/PortfolioPerformance-${pkgver}-linux.gtk.x86_64.tar.gz"
+ portfolio-performance.desktop
+)
+
+package() {
+ # Extract the core package
+ tar xzf portfolio_${pkgver}.tar.gz -C "${pkgdir}"
+
+ mkdir -p ${pkgdir}/usr/share/applications
+ install -m644 "${srcdir}/portfolio-performance.desktop" "${pkgdir}/usr/share/applications/portfolio-performance.desktop"
+
+}
+
+md5sums=('3d2f53e4afdc9dd8b4ac250b63129d81'
+ 'a1204cabfcbf5a026cd44923b87be026')
diff --git a/portfolio-performance.desktop b/portfolio-performance.desktop
new file mode 100644
index 000000000000..00f1874a3199
--- /dev/null
+++ b/portfolio-performance.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=/opt/portfolio-performance-bin/portfolio/PortfolioPerformance
+Icon=visual-studio-code
+Terminal=false
+Type=Application
+Name=Portfolio Performance
+Comment=A simple tool to calculate the overall performance of an investment portfolio.
+MimeType=text/plain;inode/directory;
+StartupNotify=true
+