summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolai Schmid2020-05-19 22:07:12 +0200
committerNicolai Schmid2020-05-19 22:34:32 +0200
commitb363ceab1a82b8dcd30d1a01f3eb1ab2fec5c291 (patch)
tree4b8dc5355d697265f14ef32078d1ea22f7661889
parentde88552407fdb4c193564013d68740cf1845e025 (diff)
downloadaur-b363ceab1a82b8dcd30d1a01f3eb1ab2fec5c291.tar.gz
feat: fix pkgbuild, update version, add correct icon and switch checksums to sha512
-rw-r--r--PKGBUILD20
-rw-r--r--portfolio-performance-bin.desktop2
2 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9dd85243918..f33d8c837c47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# PKGBUILD-Credit: https://aur.archlinux.org/account/teprrr
pkgname=portfolio-performance-bin
-pkgver=0.46.0
+pkgver=0.46.3
pkgrel=1
pkgdesc="A simple tool to calculate the overall performance of an investment portfolio."
arch=('x86_64')
@@ -12,20 +12,22 @@ depends=()
source=(
portfolio_$pkgver.tar.gz::"https://github.com/buchen/portfolio/releases/download/${pkgver}/PortfolioPerformance-${pkgver}-linux.gtk.x86_64.tar.gz"
+ portfolio-performance-bin.svg::https://www.portfolio-performance.info/images/logo.svg
+ portfolio-performance-bin.desktop
)
package() {
install -d "$pkgdir"/{opt,usr/bin}
- cp -a "$srcdir"/portfolio "${pkgdir}"/opt/PortfolioPerformance
+ cp -a "$srcdir"/portfolio "${pkgdir}"/opt/portfolio-performance-bin
- #tar xzf portfolio_${pkgver}.tar.gz -C "${pkgdir}"/opt/PortfolioPerformance
- ln -s /opt/PortfolioPerformance/PortfolioPerformance "$pkgdir"/usr/bin/PortfolioPerformance
+ ln -s /opt/portfolio-performance-bin/PortfolioPerformance "$pkgdir"/usr/bin/PortfolioPerformance
- mkdir -p ${pkgdir}/usr/share/applications
- # install -m644 "${srcdir}/portfolio-performance.desktop" "${pkgdir}/usr/share/applications/portfolio-performance.desktop"
-
- install -Dm 644 "$srcdir"/portfolio/icon.xpm -t "$pkgdir"/usr/share/pixmaps/PortfolioPerformance.xpm
+ install -Dm 644 portfolio-performance-bin.desktop -t "$pkgdir"/usr/share/applications
+ install -Dm 644 portfolio-performance-bin.svg -t "$pkgdir"/usr/share/pixmaps
}
-md5sums=('e84e63bc3401d4b5c00e999a8993a77d')
+
+sha512sums=('bbe9abe284c6c879a83098f8bcaaa2039512d0da69b8374acda244fa942248c4dd8fabe0d184ddb41b5fc534d83b523f98c86179d3c58b45bd9349b7231ed239'
+ '177215db98deb3999d04ed097e880fe3cd0dc529051e3bf6aaf5f00f06aed08d1bbca77f298623a50376a71a256d0c41d3c86b17b70241dbe9c06f96a8eb4e63'
+ 'a3ae95fe94bf738c53d99557b6136b599f80fbfdd2bd52db4ad0a02b261b375979cfa7ee332afe0467ea0e00eb27767b2bf27c69048ae8df0e890a148437ce86')
diff --git a/portfolio-performance-bin.desktop b/portfolio-performance-bin.desktop
index 5a5c95b45818..6b1e312aa0e5 100644
--- a/portfolio-performance-bin.desktop
+++ b/portfolio-performance-bin.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Exec=PortfolioPerformance
-Icon=visual-studio-code
+Icon=portfolio-performance-bin
Terminal=false
Type=Application
Name=Portfolio Performance