summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHalosGhost2015-06-26 23:08:42 -0500
committerHalosGhost2015-06-26 23:08:42 -0500
commit9179945248555f62bb11ff319897b08127a65432 (patch)
tree59185e46b8edfc84a4228d28f4dfef0deef75d48
downloadaur-9179945248555f62bb11ff319897b08127a65432.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a43e5f5aef77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = portspoof-git
+ pkgdesc = A lightweight, fast, portable and secure addition to any firewall system or security infrastructure.
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://portspoof.org/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = git
+ source = portspoof::git://github.com/drk1wi/portspoof.git
+ sha256sums = SKIP
+
+pkgname = portspoof-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e94db9c93b09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+_name='portspoof'
+pkgname="${_name}-git"
+pkgver=1.3
+pkgrel=1
+pkgdesc='A lightweight, fast, portable and secure addition to any firewall system or security infrastructure.'
+url='http://portspoof.org/'
+arch=('i686' 'x86_64')
+license=('GPLv2')
+makedepends=('git')
+source=("${_name}::git://github.com/drk1wi/${_name}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ echo "$(git describe --always|cut -d 'v' -f2|sed -e 's|-|.|g' )"
+}
+
+build() {
+ cd "${srcdir}/${_name}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ install -d "${pkgdir}"/{usr/bin,etc/"${_name}"}
+
+ cd "${srcdir}/${_name}/src"
+ install -Dm755 "${_name}" "${pkgdir}/usr/bin/${_name}"
+
+ cd "${srcdir}/${_name}/tools"
+ install -m644 -t "${pkgdir}/etc/${_name}/" "${_name}.conf" "${_name}_signatures"
+}