summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2023-04-10 13:54:01 +0200
committerJose Riha2023-04-10 13:54:01 +0200
commit3e877c14180d7d98574688f645f6eb0c9699b6a0 (patch)
tree3c12135aa4b4e41313d99d382896ed5b6554dc07
parentffd986eed457101ee54ded1ba932b84c8270bc13 (diff)
downloadaur-3e877c14180d7d98574688f645f6eb0c9699b6a0.tar.gz
Initial commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8298919e6d11..54732913cb86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = python-pospell
+pkgbase = pospell
pkgdesc = Spellcheck .po files containing reStructuredText translations
pkgver = 1.1
pkgrel = 1
@@ -12,4 +12,4 @@ pkgbase = python-pospell
sha256sums = 622be800caf4b1c5c880d972f5fc91501ffc6194978d9006158e3da182eb5a78
sha256sums = 65ebc5bb0383d5f7374c177f3638e346071b8ab9f08aaf58f118cc5cc08aaae2
-pkgname = python-pospell
+pkgname = pospell
diff --git a/PKGBUILD b/PKGBUILD
index 220e071bd037..e8bcb2a5311c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Jose Riha <jose1711 gmail com>
#
-pkgbase='python-pospell'
-pkgname=('python-pospell')
-_module='pospell'
+pkgname=pospell
+pkgname='pospell'
pkgver='1.1'
pkgrel=1
pkgdesc="Spellcheck .po files containing reStructuredText translations"
@@ -11,22 +10,22 @@ depends=('python')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
"https://github.com/AFPy/pospell/commit/c4feb4d25f23c3584959ba861267f669fbfcc98d.diff")
sha256sums=('622be800caf4b1c5c880d972f5fc91501ffc6194978d9006158e3da182eb5a78'
'65ebc5bb0383d5f7374c177f3638e346071b8ab9f08aaf58f118cc5cc08aaae2')
prepare() {
- cd "${srcdir}/${_module}-${pkgver}/"
+ cd "${srcdir}/${pkgname}-${pkgver}/"
patch -i ../c4feb4d25f23c3584959ba861267f669fbfcc98d.diff
}
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}