summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Giuliani2017-05-11 16:09:05 +0200
committerLorenzo Giuliani2017-05-11 16:09:05 +0200
commit3fe5a1bca986cbf1b9eef31fc48cb96915848cb9 (patch)
tree6de876825f9924f4d6de32707dfb6e2600cc3ff5
parent0e831ffcf689b5bdad877b7c36b32f2909f09726 (diff)
downloadaur-3fe5a1bca986cbf1b9eef31fc48cb96915848cb9.tar.gz
update license and deps
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
-rw-r--r--postage.sh3
3 files changed, 20 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
index 2b4f00f3bdb8..e457f43a9893 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg
src
*.rpm
*.tar.xz
+LICENSE.postage.txt
diff --git a/PKGBUILD b/PKGBUILD
index 0a7f86fd81ee..42053c7c83c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,34 @@
pkgname=postage-bin
pkgver=3.2.9
-pkgrel=1
+pkgrel=2
pkgdesc="Postage - A fast replacement for PGAdmin"
arch=('i686' 'x86_64')
url="https://www.workflowproducts.com/postage.html"
-license=('APL')
+license=('custom:postage', 'custom:electron', 'custom:chromium')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss')
makedepends=('')
-source_i686=("${pkgname}-${pkgver}-${CARCH}.rpm::https://github.com/workflowproducts/postage/releases/download/eV3.2.9/Postage-3.2.9-ia32.rpm")
-source_x86_64=("${pkgname}-${pkgver}-${CARCH}.rpm::https://github.com/workflowproducts/postage/releases/download/eV3.2.9/Postage-3.2.9.rpm")
+source=("LICENSE.postage.txt::https://raw.githubusercontent.com/workflowproducts/postage/master/LICENSE"
+ "postage.sh")
+source_i686=("${pkgname}-${pkgver}-i686.rpm::https://github.com/workflowproducts/postage/releases/download/eV3.2.9/Postage-3.2.9-ia32.rpm")
+source_x86_64=("${pkgname}-${pkgver}-x86_64.rpm::https://github.com/workflowproducts/postage/releases/download/eV3.2.9/Postage-3.2.9.rpm")
+sha256sums=('SKIP' 'SKIP')
sha256sums_i686=('20e62bc7e7eed0653cb662cf9726c73c054743b3c8a8a70fed52e93ceddaacf0')
sha256sums_x86_64=('ec5d2123d1d8459e20d20f1a797ecc7f3372d3a892db4f40ff6a15bacecb60f1')
package() {
install -d "${pkgdir}"/opt/Postage
+ install -d "${pkgdir}"/usr/bin
install -d "${pkgdir}"/usr/share/applications
install -d "${pkgdir}"/usr/share/share/icons
+ install -d "${pkgdir}"/usr/share/licenses/postage
+
cp --preserve=mode -r "${srcdir}"/opt/Postage/* "${pkgdir}"/opt/Postage
cp --preserve=mode -r "${srcdir}"/usr/share/applications/* "${pkgdir}"/usr/share/applications
cp --preserve=mode -r "${srcdir}"/usr/share/icons/* "${pkgdir}"/usr/share/icons
+
+ install -Dm644 "${srcdir}"/opt/Postage/LICENSES.chromium.html "${pkgdir}"/usr/share/licenses/postage/LICENSES.chromium.html
+ install -Dm644 "${srcdir}"/opt/Postage/LICENSE.electron.txt "${pkgdir}"/usr/share/licenses/postage/LICENSE.electron.txt
+ install -Dm644 "${srcdir}"/LICENSE.postage.txt "${pkgdir}"/usr/share/licenses/postage/LICENSE.postage.txt
+ install -m755 postage.sh "${pkgdir}"/usr/bin/postage
}
diff --git a/postage.sh b/postage.sh
new file mode 100644
index 000000000000..5a4308d27893
--- /dev/null
+++ b/postage.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /opt/Postage/postage