summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2017-11-06 11:30:36 +0200
committerChristoph Fink2017-11-06 11:30:36 +0200
commit992933f924d214edb3eb6f0282743d266f8ad86b (patch)
treee47d086da2c5ebad5bc1abfbf35c32ff42fd7b4f
downloadaur-992933f924d214edb3eb6f0282743d266f8ad86b.tar.gz
postgis-svn 2.5.0dev
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de2da385eac2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = postgis-svn
+ pkgdesc = Postgres GIS extensions (from git)
+ pkgver = r16091
+ pkgrel = 1
+ url = http://postgis.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = postgresql
+ depends = gdal
+ depends = geos
+ depends = json-c
+ depends = libxml2
+ depends = libxslt
+ conflicts = postgis
+ source = postgis-svn::svn+http://svn.osgeo.org/postgis/trunk/
+ md5sums = SKIP
+
+pkgname = postgis-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..94548af5beba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+*/
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21ed8b495d68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: peippo <christoph.fink@gmail.com>
+pkgname=postgis-svn
+pkgver=r16091
+pkgrel=1
+
+pkgdesc="Postgres GIS extensions (from git)"
+url="http://postgis.net/"
+license=('GPL')
+
+arch=('i686' 'x86_64')
+depends=('postgresql' 'gdal' 'geos' 'json-c' 'libxml2' 'libxslt')
+makedepends=('subversion')
+conflicts=(postgis)
+
+source=("${pkgname}::svn+http://svn.osgeo.org/postgis/trunk/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "${pkgname}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}