summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbanzay2018-10-30 04:30:03 +0300
committerbanzay2018-10-30 04:30:03 +0300
commitda50672a5f172d879dc4430eadedd7f2601b5561 (patch)
tree702b36d3f5078489c0e460af6db04e6f92792aac
parenta9c239ddf14e0935cb042c32533bb5f8162ede78 (diff)
downloadaur-da50672a5f172d879dc4430eadedd7f2601b5561.tar.gz
Update to 10.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD64
2 files changed, 10 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdbed95281c..1feac4f5469 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Tue Oct 30 00:14:48 UTC 2018
+# Tue Oct 30 01:29:53 UTC 2018
pkgbase = postgresql-1c
- pkgdesc = Sophisticated object-relational DBMS
+ pkgdesc = Custom version of PostgreSQL for 1C system
pkgver = 10.3
pkgrel = 3
url = https://www.postgresql.org/
@@ -15,6 +15,8 @@ pkgbase = postgresql-1c
makedepends = openssl>=1.0.0
makedepends = pam
makedepends = zlib
+ conflicts = postgresql
+ replaces = postgresql
source = https://ftp.postgresql.org/pub/source/v10.3/postgresql-10.3.tar.bz2
source = http://www.r-s-v.ru/1c-patch/1c-patch.tgz
source = postgresql-run-socket.patch
@@ -37,24 +39,10 @@ pkgbase = postgresql-1c
sha512sums = acd60166ff513b16778705e824944945cd0a98abc519fa5f0232252e0e9c85460c6f8b85459d9692d1f3df1caaaf8909c3e7f785be99c2d3fb98a10b2641a795
sha512sums = 56974ef34a8d94596068413154b1a7ed5a71f5a3942bd79427f05e6f6b7853036874dedd8d988bb94306023f2a675996d500b075eaf8a192ef5c24026eb28eb0
-pkgname = postgresql-libs-1c
- pkgdesc = Libraries for use with PostgreSQL
- depends = krb5
- depends = openssl>=1.0.0
- depends = readline>=6.0
- depends = zlib
- provides = postgresql-client
- provides = postgresql-libs=10.3
- conflicts = postgresql-client
-
-pkgname = postgresql-docs-1c
- pkgdesc = HTML documentation for PostgreSQL
- options = docs
-
pkgname = postgresql-1c
pkgdesc = Sophisticated object-relational DBMS
install = postgresql.install
- depends = postgresql-libs-1c>=10.3
+ depends = postgresql-libs>=10.3
depends = krb5
depends = libxml2
depends = readline>=6.0
diff --git a/PKGBUILD b/PKGBUILD
index fee53747e65..a3db7dd2324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
# Contributor: Ivan Agarkov <ivan.agarkov@gmail.com>
pkgbase=('postgresql-1c')
-pkgname=('postgresql-libs-1c' 'postgresql-docs-1c' 'postgresql-1c')
+pkgname=('postgresql-1c')
pkgver=10.3
_majorver=${pkgver%.*}
pkgrel=3
-pkgdesc='Sophisticated object-relational DBMS'
+pkgdesc='Custom version of PostgreSQL for 1C system'
url='https://www.postgresql.org/'
arch=('x86_64')
license=('custom:PostgreSQL')
+conflicts=('postgresql')
+replaces=('postgresql')
makedepends=('krb5' 'libxml2' 'python2' 'perl' 'tcl>=8.6.0' 'openssl>=1.0.0' 'pam' 'zlib')
source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
http://www.r-s-v.ru/1c-patch/1c-patch.tgz
@@ -65,66 +67,10 @@ build() {
make world
}
-package_postgresql-libs-1c() {
- pkgdesc="Libraries for use with PostgreSQL"
- depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0' 'zlib')
- provides=('postgresql-client' "postgresql-libs=${pkgver}")
- conflicts=('postgresql-client')
-
- cd postgresql-${pkgver}
-
- # install license
- install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
-
- # install libs and non-server binaries
- for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
- make -C ${dir} DESTDIR="${pkgdir}" install
- done
-
- for util in pg_config pg_dump pg_dumpall pg_restore psql \
- clusterdb createdb createuser dropdb dropuser pg_isready reindexdb vacuumdb; do
- install -Dm 644 doc/src/sgml/man1/${util}.1 "${pkgdir}"/usr/share/man/man1/${util}.1
- done
-
- cd src/include
-
- mkdir -p "${pkgdir}"/usr/include/{libpq,postgresql/internal/libpq}
-
- # these headers are needed by the public headers of the interfaces
- install -m 644 pg_config.h "${pkgdir}/usr/include"
- install -m 644 pg_config_os.h "${pkgdir}/usr/include"
- install -m 644 pg_config_ext.h "${pkgdir}/usr/include"
- install -m 644 postgres_ext.h "${pkgdir}/usr/include"
- install -m 644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq"
- install -m 644 pg_config_manual.h "${pkgdir}/usr/include"
-
- # these he aders are needed by the not-so-public headers of the interfaces
- install -m 644 c.h "${pkgdir}/usr/include/postgresql/internal"
- install -m 644 port.h "${pkgdir}/usr/include/postgresql/internal"
- install -m 644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal"
- install -m 644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq"
-}
-
-package_postgresql-docs-1c() {
- pkgdesc="HTML documentation for PostgreSQL"
- options=('docs')
-
- cd postgresql-${pkgver}
-
- install -Dm 644 COPYRIGHT -t "${pkgdir}/usr/share/licenses/${pkgname}"
-
- make -C doc/src/sgml DESTDIR="${pkgdir}" install-html
- chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html"
-
- # clean up
- rmdir "${pkgdir}"/usr/share/man/man{1,3,7}
- rmdir "${pkgdir}"/usr/share/man
-}
-
package_postgresql-1c() {
pkgdesc='Sophisticated object-relational DBMS'
backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
- depends=("postgresql-libs-1c>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0' 'pam')
+ depends=("postgresql-libs>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0' 'pam')
optdepends=('python2: for PL/Python support'
'perl: for PL/Perl support'
'tcl: for PL/Tcl support'