summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Popper2017-04-28 22:03:19 -0400
committerAriel Popper2017-04-28 22:03:19 -0400
commit0cdd445d3c1918d0d914095812ce1cb0d49c6253 (patch)
tree9323763f1df659c663550860ed0fef844a452ab5
parentf3183ac1fd2161da552c9e60ce3cad413a9499c8 (diff)
downloadaur-0cdd445d3c1918d0d914095812ce1cb0d49c6253.tar.gz
Build with OpenSSL 1.0 for now
It looks like the patch to enable building with OpenSSL 1.1 will make it into the May release. https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=4e91330
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04f776383bc1..3234c74c3935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,6 +33,11 @@ build() {
patch -Np1 < ../postgresql-run-socket.patch
+ #build with OpenSSL 1.0 for now
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+ CFLAGS+=" -I/usr/include/openssl-1.0"
+ LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl"
+
./configure --prefix=/usr \
--mandir=/usr/share/man \
--datadir=/usr/share/postgresql \