summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Arnhold2017-11-26 10:59:16 +0100
committerThomas Arnhold2017-11-26 10:59:50 +0100
commit3362cf500405dbd938a57a3d66a9e9d1dbc2e3e1 (patch)
treeecc1631571e8d5650f2a5135b28e9d3bd4e2c512
downloadaur-3362cf500405dbd938a57a3d66a9e9d1dbc2e3e1.tar.gz
postgresql-9.6.6
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD81
-rw-r--r--postgresql-check-db-dir49
-rw-r--r--postgresql-run-socket.patch12
-rw-r--r--postgresql.install25
-rw-r--r--postgresql.logrotate4
-rw-r--r--postgresql.pam3
-rw-r--r--postgresql.service34
8 files changed, 250 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aac5325b8323
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = postgresql-9.6
+ pkgdesc = A powerful, open source object-relational database system
+ pkgver = 9.6.6
+ pkgrel = 1
+ url = http://www.postgresql.org/
+ install = postgresql.install
+ arch = i686
+ arch = x86_64
+ license = custom:PostgreSQL
+ makedepends = python2
+ makedepends = perl
+ makedepends = tcl>=8.6.0
+ depends = libxml2
+ depends = krb5
+ depends = openssl>=1.0.0
+ depends = readline>=6.0
+ optdepends = python2: for PL/Python support
+ optdepends = perl: for PL/Perl support
+ optdepends = tcl: for PL/Tcl support
+ optdepends = postgresql-old-upgrade: upgrade from previous major version using pg_upgrade
+ provides = postgresql=9.6.6
+ provides = postgresql-libs=9.6.6
+ provides = postgresql-client=9.6.6
+ conflicts = postgresql
+ conflicts = postgresql-libs
+ conflicts = postgresql-testing
+ conflicts = postgresql-client
+ source = https://ftp.postgresql.org/pub/source/v9.6.6/postgresql-9.6.6.tar.bz2
+ source = postgresql-run-socket.patch
+ source = postgresql.pam
+ source = postgresql.logrotate
+ source = postgresql.service
+ source = postgresql-check-db-dir
+ sha256sums = 399cdffcb872f785ba67e25d275463d74521566318cfef8fe219050d063c8154
+ sha256sums = 8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9
+ sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
+ sha256sums = 6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e
+ sha256sums = b48fe97f8e43ed0d2041d519119a4dafb70fcae72870951bf4fb7350fe169ac8
+ sha256sums = 2340da0947bcb1c5602008d0ca00588ca0bfa8aca4fa6947a8bdb2c6df800b0e
+
+pkgname = postgresql-9.6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6eaa06dc586c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Thomas Arnhold <thomas@arnhold.org
+# Contributor: Kuba Kuźma <kuba@jah.pl>
+# Contributor: Matthew Carter <m@ahungry.com>
+# Contributor: Ariel Popper <a@arielp.com>
+
+pkgname=postgresql-9.6
+pkgver=9.6.6
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.postgresql.org/"
+pkgdesc="A powerful, open source object-relational database system"
+license=('custom:PostgreSQL')
+conflicts=('postgresql' 'postgresql-libs' 'postgresql-testing' 'postgresql-client')
+provides=("postgresql=$pkgver" "postgresql-libs=$pkgver" "postgresql-client=$pkgver")
+depends=('libxml2' 'krb5' 'openssl>=1.0.0' 'readline>=6.0')
+makedepends=('python2' 'perl' 'tcl>=8.6.0')
+optdepends=('python2: for PL/Python support'
+ 'perl: for PL/Perl support'
+ 'tcl: for PL/Tcl support'
+ 'postgresql-old-upgrade: upgrade from previous major version using pg_upgrade')
+install=postgresql.install
+source=(https://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
+ postgresql-run-socket.patch
+ postgresql.pam
+ postgresql.logrotate
+ postgresql.service
+ postgresql-check-db-dir)
+sha256sums=('399cdffcb872f785ba67e25d275463d74521566318cfef8fe219050d063c8154'
+ '8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e'
+ 'b48fe97f8e43ed0d2041d519119a4dafb70fcae72870951bf4fb7350fe169ac8'
+ '2340da0947bcb1c5602008d0ca00588ca0bfa8aca4fa6947a8bdb2c6df800b0e')
+
+build() {
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ patch -Np1 < ../postgresql-run-socket.patch
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/postgresql \
+ --sysconfdir=/etc \
+ --with-krb5 \
+ --with-gssapi \
+ --with-libxml \
+ --with-openssl-1.0 \
+ --with-perl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl \
+ --with-pam \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --enable-nls \
+ --enable-thread-safety
+
+ make
+ make -C contrib
+}
+
+package() {
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ make DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+
+# install -D -m644 "${srcdir}/postgresql.tmpfiles.conf" \
+# "${pkgdir}/usr/lib/tmpfiles.d/postgresql.conf"
+ install -D -m644 "${srcdir}/postgresql.service" \
+ "${pkgdir}/usr/lib/systemd/system/postgresql.service"
+ install -D -m755 "${srcdir}/postgresql-check-db-dir" \
+ "${pkgdir}/usr/bin/postgresql-check-db-dir"
+
+ install -D -m644 "${srcdir}/postgresql.pam" \
+ "${pkgdir}/etc/pam.d/postgresql"
+
+ install -D -m644 "${srcdir}/postgresql.logrotate" \
+ "${pkgdir}/etc/logrotate.d/postgresql"
+}
diff --git a/postgresql-check-db-dir b/postgresql-check-db-dir
new file mode 100644
index 000000000000..aa51d7643535
--- /dev/null
+++ b/postgresql-check-db-dir
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# This script verifies that the postgresql data directory has been correctly
+# initialized. We do not want to automatically initdb it, because that has
+# a risk of catastrophic failure (ie, overwriting a valuable database) in
+# corner cases, such as a remotely mounted database on a volume that's a
+# bit slow to mount. But we can at least emit a message advising newbies
+# what to do.
+
+PGDATA="$1"
+
+if [ -z "$PGDATA" ]
+then
+ echo "Usage: $0 database-path"
+ exit 1
+fi
+
+# PGMAJORVERSION is major version
+PGMAJORVERSION=9.6
+# PREVMAJORVERSION is the previous major version
+PREVMAJORVERSION=9.5
+
+# Check for the PGDATA structure
+if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` = x"$PGMAJORVERSION" ]
+ then
+ : A-OK
+ elif [ x`cat "$PGDATA/PG_VERSION"` = x"$PREVMAJORVERSION" ]
+ then
+ echo $"An old version of the database format was found."
+ echo $"See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL"
+ exit 1
+ else
+ echo $"An old version of the database format was found."
+ echo $"You need to dump and reload before using PostgreSQL $PGMAJORVERSION."
+ echo $"See http://www.postgresql.org/docs/$PGMAJORVERSION/static/upgrading.html"
+ exit 1
+ fi
+else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo $"\"$PGDATA\" is missing or empty. Use a command like"
+ echo $" su - postgres -c \"initdb --locale en_US.UTF-8 -D '$PGDATA'\""
+ echo $"with relevant options, to initialize the database cluster."
+ exit 1
+fi
+
+exit 0
diff --git a/postgresql-run-socket.patch b/postgresql-run-socket.patch
new file mode 100644
index 000000000000..b558c7b74961
--- /dev/null
+++ b/postgresql-run-socket.patch
@@ -0,0 +1,12 @@
+diff -Naur postgresql-9.2.0.sockets/src/include/pg_config_manual.h postgresql-9.2.0/src/include/pg_config_manual.h
+--- postgresql-9.2.0.sockets/src/include/pg_config_manual.h 2012-09-06 17:26:17.000000000 -0400
++++ postgresql-9.2.0/src/include/pg_config_manual.h 2012-09-06 18:13:18.183092471 -0400
+@@ -144,7 +144,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
diff --git a/postgresql.install b/postgresql.install
new file mode 100644
index 000000000000..0d23d474a0c2
--- /dev/null
+++ b/postgresql.install
@@ -0,0 +1,25 @@
+post_install() {
+ if [ ! -d '/var/lib/postgres' ]; then
+ mkdir -p '/var/lib/postgres'
+ fi
+ if ! getent group postgres >/dev/null; then
+ groupadd -g 88 postgres
+ fi
+ if ! getent passwd postgres >/dev/null; then
+ useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
+ passwd -l postgres >/dev/null
+ fi
+ if [ ! -d '/var/lib/postgres/data' ]; then
+ mkdir -p '/var/lib/postgres/data'
+ chown postgres:postgres '/var/lib/postgres/data'
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+ # FS#23858, fix postgres user shell issue
+ postgres_shell=$(getent passwd postgres | cut -d: -f7)
+ if [ "$postgres_shell" = "/sbin/nologin" ]; then
+ chsh -s /bin/bash postgres
+ fi
+}
diff --git a/postgresql.logrotate b/postgresql.logrotate
new file mode 100644
index 000000000000..9c36918be5e5
--- /dev/null
+++ b/postgresql.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}
diff --git a/postgresql.pam b/postgresql.pam
new file mode 100644
index 000000000000..53724d1f86a7
--- /dev/null
+++ b/postgresql.pam
@@ -0,0 +1,3 @@
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/postgresql.service b/postgresql.service
new file mode 100644
index 000000000000..37fcae996352
--- /dev/null
+++ b/postgresql.service
@@ -0,0 +1,34 @@
+[Unit]
+Description=PostgreSQL database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/postgres
+
+SyslogIdentifier=postgres
+PIDFile=/var/lib/postgres/data/postmaster.pid
+RuntimeDirectory=postgresql
+RuntimeDirectoryMode=755
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+# Additional security-related features
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=full
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target