summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrvv2016-07-01 11:51:45 +0800
committercrvv2016-07-01 11:51:45 +0800
commitc0f9709f40d6420785f48e7657d0fd9f3bc4c631 (patch)
tree561f7dd199d04c51ececffe534f0a8debd0a1814
parent7eb4c6f1e89167f1360e9393a0f78718ab9fe1da (diff)
downloadaur-c0f9709f40d6420785f48e7657d0fd9f3bc4c631.tar.gz
update to postgresql 9.6beta
-rw-r--r--.SRCINFO77
-rw-r--r--PKGBUILD185
-rwxr-xr-xpostgresql-check-db-dir49
-rw-r--r--postgresql-run-socket.patch12
-rw-r--r--postgresql.confd4
-rw-r--r--postgresql.install25
-rw-r--r--postgresql.logrotate4
-rw-r--r--postgresql.rc59
-rw-r--r--postgresql.service34
9 files changed, 331 insertions, 118 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba21ae6d2ddd..d0e481895bc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,67 @@
pkgbase = postgresql-beta
- pkgdesc = Beta version of the PostgreSQL database (includes both server and libs)
- pkgver = 9.1beta3
+ pkgver = 9.6beta2
pkgrel = 1
- url = http://www.postgresql.org/developer/alpha
+ url = http://www.postgresql.org/
arch = i686
arch = x86_64
license = custom:PostgreSQL
- makedepends = python2
+ makedepends = krb5
+ makedepends = libxml2
+ makedepends = python
makedepends = perl
- depends = libxml2
- depends = readline>=6.0
- depends = openssl
- depends = bash
- provides = postgresql-libs=9.1beta3
- provides = postgresql=9.1beta3
- conflicts = postgresql-libs
- conflicts = postgresql
- options = !strip
- backup = etc/conf.d/postgresql
- backup = etc/pam.d/postgresql
- source = http://ftp.de.postgresql.org/packages/databases/PostgreSQL/source/v9.1beta3/postgresql-9.1beta3.tar.bz2
- source = postgresql.rc
- source = postgresql.confd
+ makedepends = tcl>=8.6.0
+ makedepends = openssl>=1.0.0
+ source = http://ftp.postgresql.org/pub/source/v9.6beta2/postgresql-9.6beta2.tar.bz2
+ source = postgresql-run-socket.patch
source = postgresql.pam
- md5sums = b40a59b229750505152c8f07caf30137
- md5sums = 86e0161343ce80e544aba999f284bc88
- md5sums = df6ddf9e2ab4700a3415f17c0f4f4172
+ source = postgresql.logrotate
+ source = postgresql.service
+ source = postgresql-check-db-dir
+ md5sums = 23600491f6422cd34be443d679ff723b
+ md5sums = 75c579eed03ffb2312631f0b649175b4
md5sums = 96f82c38f3f540b53f3e5144900acf17
+ md5sums = d28e443f9f65a5712c52018b84e27137
+ md5sums = 5a7933453a572bbe12320b088272ee71
+ md5sums = 6eb990a98cdd2e385de2c53c288a388c
+ sha256sums = cf4e28263eeb855632545b778445e2591847df0587178b21e0346540c4c344eb
+ sha256sums = 8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9
+ sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
+ sha256sums = 6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e
+ sha256sums = b48fe97f8e43ed0d2041d519119a4dafb70fcae72870951bf4fb7350fe169ac8
+ sha256sums = 40da687da4fb1f6b35f406dd0f48922065d8c905d678e2a27da05806f874b780
+
+pkgname = postgresql-beta-libs
+ pkgdesc = Libraries for use with PostgreSQL
+ depends = krb5
+ depends = openssl>=1.0.0
+ depends = readline>=6.0
+ provides = postgresql-client
+ provides = postgresql-libs
+ conflicts = postgresql-client
+ conflicts = postgresql-libs
+
+pkgname = postgresql-beta-docs
+ pkgdesc = HTML documentation for PostgreSQL
+ provides = postgresql-docs
+ conflicts = postgresql-docs
+ options = docs
pkgname = postgresql-beta
+ pkgdesc = A sophisticated object-relational DBMS
+ install = postgresql.install
+ depends = postgresql-beta-libs>=9.6beta2
+ depends = krb5
+ depends = libxml2
+ depends = readline>=6.0
+ depends = openssl>=1.0.0
+ depends = pam
+ optdepends = python: for PL/Python support
+ optdepends = perl: for PL/Perl support
+ optdepends = tcl: for PL/Tcl support
+ optdepends = postgresql-old-upgrade: upgrade from previous major version using pg_upgrade
+ provides = postgresql
+ conflicts = postgresql
+ options = staticlibs
+ backup = etc/pam.d/postgresql
+ backup = etc/logrotate.d/postgresql
diff --git a/PKGBUILD b/PKGBUILD
index e217c664ae73..8c7510eeed72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,161 @@
-# Maintainer: Marti Raudsepp <marti@juffo.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Maintainer: crvv <crvv.pku@gmail.com>
-pkgname=postgresql-beta
-pkgver=9.1beta3
+pkgbase=postgresql-beta
+pkgname=('postgresql-beta-libs' 'postgresql-beta-docs' 'postgresql-beta')
+pkgver=9.6beta2
+_majorver=9.6
pkgrel=1
-pkgdesc="Beta version of the PostgreSQL database (includes both server and libs)"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
+url="http://www.postgresql.org/"
license=('custom:PostgreSQL')
-backup=('etc/conf.d/postgresql' 'etc/pam.d/postgresql')
-url="http://www.postgresql.org/developer/alpha"
-options=(!strip) # to facilitate debugging of testing builds
-depends=('libxml2' 'readline>=6.0' 'openssl' 'bash')
-makedepends=('python2' 'perl')
-conflicts=('postgresql-libs' 'postgresql')
-provides=("postgresql-libs=$pkgver" "postgresql=$pkgver")
-source=(http://ftp.de.postgresql.org/packages/databases/PostgreSQL/source/v$pkgver/postgresql-$pkgver.tar.bz2
- postgresql.rc postgresql.confd postgresql.pam)
+makedepends=('krb5' 'libxml2' 'python' 'perl' 'tcl>=8.6.0' 'openssl>=1.0.0')
+source=(http://ftp.postgresql.org/pub/source/v${pkgver}/postgresql-${pkgver}.tar.bz2
+ postgresql-run-socket.patch
+ postgresql.pam postgresql.logrotate
+ postgresql.service postgresql-check-db-dir)
+md5sums=('23600491f6422cd34be443d679ff723b'
+ '75c579eed03ffb2312631f0b649175b4'
+ '96f82c38f3f540b53f3e5144900acf17'
+ 'd28e443f9f65a5712c52018b84e27137'
+ '5a7933453a572bbe12320b088272ee71'
+ '6eb990a98cdd2e385de2c53c288a388c')
+sha256sums=('cf4e28263eeb855632545b778445e2591847df0587178b21e0346540c4c344eb'
+ '8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9'
+ '57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5'
+ '6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e'
+ 'b48fe97f8e43ed0d2041d519119a4dafb70fcae72870951bf4fb7350fe169ac8'
+ '40da687da4fb1f6b35f406dd0f48922065d8c905d678e2a27da05806f874b780')
build() {
- cd $srcdir/postgresql-$pkgver
+ cd "${srcdir}/postgresql-${pkgver}"
- ./configure --prefix=/usr --mandir=/usr/share/man --with-libxml \
- --with-openssl --with-perl \
- --with-python PYTHON=/usr/bin/python2 --with-pam \
- --with-system-tzdata=/usr/share/zoneinfo --enable-nls \
- --datadir=/usr/share/postgresql --enable-thread-safety
+ patch -Np1 < ../postgresql-run-socket.patch
- make
- make DESTDIR=$pkgdir install
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/postgresql \
+ --sysconfdir=/etc \
+ --with-gssapi \
+ --with-libxml \
+ --with-openssl \
+ --with-perl \
+ --with-python PYTHON=/usr/bin/python \
+ --with-tcl \
+ --with-pam \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --with-uuid=e2fs \
+ --enable-nls \
+ --enable-thread-safety
- # build all contrib modules
- make -C contrib
- make -C contrib DESTDIR=$pkgdir install
+ make world -j8
+}
+
+package_postgresql-beta-libs() {
+ pkgdesc="Libraries for use with PostgreSQL"
+ depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0')
+ provides=('postgresql-client' 'postgresql-libs')
+ conflicts=('postgresql-client' 'postgresql-libs')
+
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/postgresql-libs/LICENSE"
+
+ # install libs and non-server binaries
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
+ make -C ${dir} DESTDIR="${pkgdir}" install
+ done
+
+ for util in pg_config pg_dump pg_dumpall pg_restore psql \
+ clusterdb createdb createlang createuser dropdb droplang dropuser pg_isready reindexdb vacuumdb; do
+ install -D -m644 doc/src/sgml/man1/${util}.1 "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
+
+ cd src/include
+
+ mkdir -p "${pkgdir}"/usr/include/{libpq,postgresql/internal/libpq}
+
+ # these headers are needed by the public headers of the interfaces
+ install -m644 pg_config.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_os.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_ext.h "${pkgdir}/usr/include/"
+ install -m644 postgres_ext.h "${pkgdir}/usr/include/"
+ install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
+ install -m644 pg_config_manual.h "${pkgdir}/usr/include/"
+
+ # these headers are needed by the not-so-public headers of the interfaces
+ install -m644 c.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 port.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 postgres_fe.h "${pkgdir}/usr/include/postgresql/internal/"
+ install -m644 libpq/pqcomm.h "${pkgdir}/usr/include/postgresql/internal/libpq/"
+}
+
+package_postgresql-beta-docs() {
+ pkgdesc="HTML documentation for PostgreSQL"
+ options=('docs')
+ provides=('postgresql-docs')
+ conflicts=('postgresql-docs')
+
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/postgresql-docs/LICENSE"
+
+ make -C doc/src/sgml DESTDIR="${pkgdir}" install-html
+ chown -R root:root "${pkgdir}/usr/share/doc/postgresql/html/"
+
+ # clean up
+ rmdir "${pkgdir}"/usr/share/man/man{1,3,7}
+ rmdir "${pkgdir}"/usr/share/man
+}
+
+package_postgresql-beta() {
+ pkgdesc="A sophisticated object-relational DBMS"
+ backup=('etc/pam.d/postgresql' 'etc/logrotate.d/postgresql')
+ depends=("postgresql-beta-libs>=${pkgver}" 'krb5' 'libxml2' 'readline>=6.0' 'openssl>=1.0.0' 'pam')
+ optdepends=('python: for PL/Python support'
+ 'perl: for PL/Perl support'
+ 'tcl: for PL/Tcl support'
+ 'postgresql-old-upgrade: upgrade from previous major version using pg_upgrade')
+ options=('staticlibs')
+ provides=('postgresql')
+ conflicts=('postgresql')
+ install=postgresql.install
+
+ cd "${srcdir}/postgresql-${pkgver}"
+
+ # install
+ make DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+ make -C doc/src/sgml DESTDIR="${pkgdir}" install-man
+
+ # we don't want these, they are in the -libs package
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
+ make -C ${dir} DESTDIR="${pkgdir}" uninstall
+ done
+ for util in pg_config pg_dump pg_dumpall pg_restore psql \
+ clusterdb createdb createlang createuser dropdb droplang dropuser pg_isready reindexdb vacuumdb; do
+ rm "${pkgdir}"/usr/share/man/man1/${util}.1
+ done
+
+ # install license
+ install -D -m644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+
+ # clean up unneeded installed items
+ rm -rf "${pkgdir}/usr/include/postgresql/internal"
+ rm -rf "${pkgdir}/usr/include/libpq"
+ find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
+ rmdir "${pkgdir}/usr/share/doc/postgresql/html"
+
+ install -D -m644 "${srcdir}/postgresql.service" \
+ "${pkgdir}/usr/lib/systemd/system/postgresql.service"
+ install -D -m755 "${srcdir}/postgresql-check-db-dir" \
+ "${pkgdir}/usr/bin/postgresql-check-db-dir"
+
+ install -D -m644 "${srcdir}/postgresql.pam" \
+ "${pkgdir}/etc/pam.d/postgresql"
- install -D -m755 $srcdir/postgresql.rc $pkgdir/etc/rc.d/postgresql
- install -D -m644 COPYRIGHT $pkgdir/usr/share/licenses/$pkgname/LICENSE
- install -D -m644 $srcdir/postgresql.confd $pkgdir/etc/conf.d/postgresql
- install -D -m644 $srcdir/postgresql.pam $pkgdir/etc/pam.d/postgresql
+ install -D -m644 "${srcdir}/postgresql.logrotate" \
+ "${pkgdir}/etc/logrotate.d/postgresql"
}
-md5sums=('b40a59b229750505152c8f07caf30137'
- '86e0161343ce80e544aba999f284bc88'
- 'df6ddf9e2ab4700a3415f17c0f4f4172'
- '96f82c38f3f540b53f3e5144900acf17')
diff --git a/postgresql-check-db-dir b/postgresql-check-db-dir
new file mode 100755
index 000000000000..bc706db5ab5d
--- /dev/null
+++ b/postgresql-check-db-dir
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# This script verifies that the postgresql data directory has been correctly
+# initialized. We do not want to automatically initdb it, because that has
+# a risk of catastrophic failure (ie, overwriting a valuable database) in
+# corner cases, such as a remotely mounted database on a volume that's a
+# bit slow to mount. But we can at least emit a message advising newbies
+# what to do.
+
+PGDATA="$1"
+
+if [ -z "$PGDATA" ]
+then
+ echo "Usage: $0 database-path"
+ exit 1
+fi
+
+# PGMAJORVERSION is major version
+PGMAJORVERSION=9.6
+# PREVMAJORVERSION is the previous major version, e.g., 8.4, for upgrades
+PREVMAJORVERSION=9.5
+
+# Check for the PGDATA structure
+if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` = x"$PGMAJORVERSION" ]
+ then
+ : A-OK
+ elif [ x`cat "$PGDATA/PG_VERSION"` = x"$PREVMAJORVERSION" ]
+ then
+ echo $"An old version of the database format was found."
+ echo $"See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL"
+ exit 1
+ else
+ echo $"An old version of the database format was found."
+ echo $"You need to dump and reload before using PostgreSQL $PGMAJORVERSION."
+ echo $"See http://www.postgresql.org/docs/$PGMAJORVERSION/static/upgrading.html"
+ exit 1
+ fi
+else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo $"\"$PGDATA\" is missing or empty. Use a command like"
+ echo $" su - postgres -c \"initdb --locale en_US.UTF-8 -D '$PGDATA'\""
+ echo $"with relevant options, to initialize the database cluster."
+ exit 1
+fi
+
+exit 0
diff --git a/postgresql-run-socket.patch b/postgresql-run-socket.patch
new file mode 100644
index 000000000000..b558c7b74961
--- /dev/null
+++ b/postgresql-run-socket.patch
@@ -0,0 +1,12 @@
+diff -Naur postgresql-9.2.0.sockets/src/include/pg_config_manual.h postgresql-9.2.0/src/include/pg_config_manual.h
+--- postgresql-9.2.0.sockets/src/include/pg_config_manual.h 2012-09-06 17:26:17.000000000 -0400
++++ postgresql-9.2.0/src/include/pg_config_manual.h 2012-09-06 18:13:18.183092471 -0400
+@@ -144,7 +144,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
diff --git a/postgresql.confd b/postgresql.confd
deleted file mode 100644
index 7bbf0160316a..000000000000
--- a/postgresql.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# Parameters to be passed to postgresql
-#
-PGROOT="/var/lib/postgres" \ No newline at end of file
diff --git a/postgresql.install b/postgresql.install
new file mode 100644
index 000000000000..0d23d474a0c2
--- /dev/null
+++ b/postgresql.install
@@ -0,0 +1,25 @@
+post_install() {
+ if [ ! -d '/var/lib/postgres' ]; then
+ mkdir -p '/var/lib/postgres'
+ fi
+ if ! getent group postgres >/dev/null; then
+ groupadd -g 88 postgres
+ fi
+ if ! getent passwd postgres >/dev/null; then
+ useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
+ passwd -l postgres >/dev/null
+ fi
+ if [ ! -d '/var/lib/postgres/data' ]; then
+ mkdir -p '/var/lib/postgres/data'
+ chown postgres:postgres '/var/lib/postgres/data'
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+ # FS#23858, fix postgres user shell issue
+ postgres_shell=$(getent passwd postgres | cut -d: -f7)
+ if [ "$postgres_shell" = "/sbin/nologin" ]; then
+ chsh -s /bin/bash postgres
+ fi
+}
diff --git a/postgresql.logrotate b/postgresql.logrotate
new file mode 100644
index 000000000000..9c36918be5e5
--- /dev/null
+++ b/postgresql.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}
diff --git a/postgresql.rc b/postgresql.rc
deleted file mode 100644
index ea5727c30059..000000000000
--- a/postgresql.rc
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/postgresql
-
-case "$1" in
- start)
- stat_busy "Starting PostgreSQL"
- # initialization
- if [ ! `egrep '^postgres:' /etc/group` ]; then
- stat_busy "Adding postgres group"
- groupadd -g 88 postgres
- stat_done
- fi
- if [ ! `egrep '^postgres:' /etc/passwd` ]; then
- stat_busy "Adding postgres user"
- useradd -u 88 -g postgres -d $PGROOT -s /bin/bash postgres
- [ -d $PGROOT ] && chown -R postgres.postgres $PGROOT
- stat_done
- fi
- if [ ! -d $PGROOT ]; then
- mkdir -p $PGROOT/data && chown postgres.postgres $PGROOT/data
- su - postgres -c "/usr/bin/initdb -D $PGROOT/data --locale $LOCALE"
- fi
- if [ ! -e /var/log/postgresql.log ]; then
- touch /var/log/postgresql.log
- chown postgres /var/log/postgresql.log
- fi
- # start the process
- su - postgres -c \
- "/usr/bin/pg_ctl -D $PGROOT/data -l /var/log/postgresql.log -W start"
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon postgresql
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping PostgreSQL"
- su - postgres -c \
- "/usr/bin/pg_ctl -D $PGROOT/data -l /var/log/postgresql.log -w stop"
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon postgresql
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 3
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/postgresql.service b/postgresql.service
new file mode 100644
index 000000000000..37fcae996352
--- /dev/null
+++ b/postgresql.service
@@ -0,0 +1,34 @@
+[Unit]
+Description=PostgreSQL database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/postgres
+
+SyslogIdentifier=postgres
+PIDFile=/var/lib/postgres/data/postmaster.pid
+RuntimeDirectory=postgresql
+RuntimeDirectoryMode=755
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+# Additional security-related features
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=full
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target