summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Popper2017-04-28 21:47:15 -0400
committerAriel Popper2017-04-28 21:47:15 -0400
commitf35c96280e9a39fa3d7dfa19ca734c56d9a1942a (patch)
tree0adad78269eb95a421914e7579c985a2d646188f
parent69975624336d1b4676cca79ec7141bb35b0627c0 (diff)
downloadaur-f35c96280e9a39fa3d7dfa19ca734c56d9a1942a.tar.gz
Build with OpenSSL 1.0 for now.
It looks like the patch to enable building with OpenSSL 1.1 will make it into the May release. https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=bb132cd
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25cee01b5db9..ea096332e3a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,11 @@ build() {
patch -Np1 < ../postgresql-run-socket.patch
+ #build with OpenSSL 1.0 for now
+ PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+ CFLAGS+=" -I/usr/include/openssl-1.0"
+ LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl"
+
./configure \
--prefix=/usr --mandir=/usr/share/man \
--datadir=/usr/share/postgresql --sysconfdir=/etc --with-gssapi \