summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsvexican2017-07-04 19:48:18 +0200
committersvexican2017-07-04 19:48:18 +0200
commit53d6b91dc37ef051b570ecb8617537db53072a13 (patch)
tree32955e180a356222df92760d1629d0d47f80e008
downloadaur-53d6b91dc37ef051b570ecb8617537db53072a13.tar.gz
First commit: v0.4.2.0-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7f3d72963f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = postgrest-bin
+ pkgdesc = REST API for any Postgres database
+ pkgver = 0.4.2.0
+ pkgrel = 1
+ url = https://github.com/begriffs/postgrest
+ arch = x86_64
+ license = MIT
+ depends = postgresql-libs
+ provides = postgrest
+ provides = postgrest-bin
+ conflicts = postgrest
+ source = https://github.com/begriffs/postgrest-bin/releases/download/v0.4.2.0/postgrest-bin-0.4.2.0-ubuntu.tar.xz
+ sha512sums = e6e208345b83ed6a7113dfbc6cd30ac12bfa5cff1c97d2c94ba94981827560c178ae7402742e13a1892710dab3c443260fda8966e67622540afab2ad1fc6cc3c
+
+pkgname = postgrest-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d0bf5c3816a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Svexican <svexican@gmail.com>
+pkgname=postgrest-bin
+pkgver=0.4.2.0
+pkgrel=1
+epoch=
+pkgdesc="REST API for any Postgres database"
+arch=('x86_64')
+url="https://github.com/begriffs/postgrest"
+license=('MIT')
+groups=()
+depends=('postgresql-libs')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=('postgrest' 'postgrest-bin')
+conflicts=('postgrest')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/begriffs/postgrest/releases/download/v$pkgver/postgrest-$pkgver-ubuntu.tar.xz")
+noextract=()
+sha512sums=('e6e208345b83ed6a7113dfbc6cd30ac12bfa5cff1c97d2c94ba94981827560c178ae7402742e13a1892710dab3c443260fda8966e67622540afab2ad1fc6cc3c')
+validpgpkeys=()
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ ln -f postgrest "$pkgdir/usr/bin/"
+}