summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Porunov2020-06-24 18:14:44 +0000
committerDmitry Porunov2020-06-24 18:14:44 +0000
commit654183802a38b96d1892b2356877eacaaa10f912 (patch)
treeedc80bb8bb4141f3957329c883c2c64748adbc04
parentffce8a396e5e2701778f9dc7df6962f743c4e6c7 (diff)
downloadaur-654183802a38b96d1892b2356877eacaaa10f912.tar.gz
Release v3.7.10
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
2 files changed, 28 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ce997199fe1..f10a818cdbbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = posy-cursors
pkgdesc = Port of Posy's improved cursors
- pkgver = 3.7
- pkgrel = 3
- url = https://git.synh.me/dmitry/posy-cursors
+ pkgver = 3.7.10
+ pkgrel = 1
+ url = https://gitlab.com/ykkzde/posy-cursors
arch = any
license = unknown
- source = posy-cursors-3.7.tar.gz::https://git.synh.me/dmitry/posy-cursors/-/archive/v3.7/posy-cursors-v3.7.tar.gz?path=themes
- sha256sums = 3c4b7e4293143057e7a5a90b63bebee9c785ca4552e5dddbf538b8322036d471
+ source = posy-cursors-3.7.10-1.tar.gz::https://gitlab.com/ykkzde/posy-cursors/-/archive/v3.7.10/posy-cursors-v3.7.10.tar.gz?path=themes
+ sha256sums = SKIP
pkgname = posy-cursors
diff --git a/PKGBUILD b/PKGBUILD
index 830087d366ac..9c914e45bbfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
-# Maintainer: Synhme <dmitry@synh.me>
+# Maintainer: Ykkzde <dmitry@ykkz.de>
pkgname=posy-cursors
-pkgver=3.7
-pkgrel=3
+pkgver=3.7.10
+pkgrel=1
pkgdesc="Port of Posy's improved cursors"
arch=(any)
-url="https://git.synh.me/dmitry/posy-cursors"
+url="https://gitlab.com/ykkzde/posy-cursors"
license=(unknown)
-source=("$pkgname-$pkgver.tar.gz::https://git.synh.me/dmitry/posy-cursors/-/archive/v3.7/posy-cursors-v3.7.tar.gz?path=themes")
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/-/archive/v$pkgver/posy-cursors-v$pkgver.tar.gz?path=themes") # automatically set in CI, see: /.gitlab-ci.yml
-sha256sums=('3c4b7e4293143057e7a5a90b63bebee9c785ca4552e5dddbf538b8322036d471')
+sha256sums=('SKIP') # automatically set in CI, see: /.gitlab-ci.yml
package() {
- cd posy-cursors-v$pkgver-themes/themes
- install -Ddm755 "$pkgdir/usr/share/icons"
- cp -dr --no-preserve=ownership posy-white/ "$pkgdir/usr/share/icons/posy-white"
- cp -dr --no-preserve=ownership posy-black/ "$pkgdir/usr/share/icons/posy-black"
- cp -dr --no-preserve=ownership posy-white-tiny/ "$pkgdir/usr/share/icons/posy-white-tiny"
- cp -dr --no-preserve=ownership posy-black-tiny/ "$pkgdir/usr/share/icons/posy-black-tiny"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ ls -l
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ ls -l *
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ echo "-------------------------------------------------------"
+ cd $pkgname-v$pkgver-themes/themes
+ install -Ddm755 "$pkgdir/usr/share/icons"
+ cp -dr --no-preserve=ownership posy-white/ "$pkgdir/usr/share/icons/posy-white"
+ cp -dr --no-preserve=ownership posy-black/ "$pkgdir/usr/share/icons/posy-black"
+ cp -dr --no-preserve=ownership posy-white-tiny/ "$pkgdir/usr/share/icons/posy-white-tiny"
+ cp -dr --no-preserve=ownership posy-black-tiny/ "$pkgdir/usr/share/icons/posy-black-tiny"
}