summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEchoCheddar2018-01-06 22:50:50 -0500
committerEchoCheddar2018-01-06 22:50:50 -0500
commitee1874b73c3b87ba5e8d43ec04c42b0c72fce406 (patch)
treea598d5dba86d55d4596213cc344e7a0c79856dc1
downloadaur-ee1874b73c3b87ba5e8d43ec04c42b0c72fce406.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77e5491038d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = potatomu
+ pkgdesc = A cross-platform graphical MUSH client written in Tcl/Tk.
+ pkgver = 2.0.0b18
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ depends = tcl>=8.6.0
+ depends = tk>=8.6.0
+ depends = tcltls
+ conflicts = potato
+ source = http://www.potatomushclient.com/download/2.0.0b18/potato-2.0.0b18-src.tar.gz
+ md5sums = 42b42fcefebd35e6ab48c13c4bdb1f95
+
+pkgname = potatomu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..961619f472d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=potatomu
+pkgver=2.0.0b18
+pkgrel=1
+pkgdesc="A cross-platform graphical MUSH client written in Tcl/Tk."
+arch=("x86_64")
+license=('MIT')
+depends=('tcl>=8.6.0' 'tk>=8.6.0' 'tcltls')
+source=("http://www.potatomushclient.com/download/${pkgver}/potato-${pkgver}-src.tar.gz")
+md5sums=("42b42fcefebd35e6ab48c13c4bdb1f95")
+conflicts=("potato")
+
+package() {
+ install -d "${pkgdir}/opt/potato"
+ cp -a "${srcdir}/potato.vfs/." "${pkgdir}/opt/potato"
+ install -D "${srcdir}/potato.vfs/tools/linux/potato" "${pkgdir}/usr/bin/potato"
+ install -Dm644 "${srcdir}/potato.vfs/tools/linux/potato.desktop" "${pkgdir}/usr/share/applications/potato.desktop"
+ install -Dm644 "${srcdir}/potato.vfs/tools/linux/potato.png" "${pkgdir}/usr/share/pixmaps/potato.png"
+ install -Dm644 "${srcdir}/potato.vfs/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ chmod +x "${pkgdir}/usr/bin/potato"
+}