summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2018-06-10 13:51:53 +0200
committerEduardo Sánchez Muñoz2018-06-10 13:51:53 +0200
commit8c3d890ef4633f5824792017c49e97ab6ce5e23d (patch)
tree567bf0068c716ca784d15d009845a49ef491f346
parentc7665bf3a17e84d47fc00283ce72fda439c1e496 (diff)
downloadaur-8c3d890ef4633f5824792017c49e97ab6ce5e23d.tar.gz
Workaround build with Qt 5.11.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rw-r--r--spuce-qt-workaround.diff20
3 files changed, 28 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0618160cfa61..f10bb947c1c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,8 +14,10 @@ pkgbase = pothos
depends = soapysdr-git
depends = portaudio
source = git+https://github.com/pothosware/PothosCore.git#tag=pothos-0.6.1
+ source = spuce-qt-workaround.diff
source = PothosFlow.desktop
sha256sums = SKIP
+ sha256sums = 3bc94fcdd8a944a58906294d35ec8e2bde2ae6d53806f3413c8c302172058f3f
sha256sums = 4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4
pkgname = pothos
diff --git a/PKGBUILD b/PKGBUILD
index 1264e95d1e67..2b26b627965c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,12 @@ depends=('python' 'poco' 'qwt' 'soapysdr-git' 'portaudio')
makedepends=('git' 'nlohmann-json')
source=(
"git+https://github.com/pothosware/PothosCore.git#tag=pothos-$pkgver"
+ "spuce-qt-workaround.diff"
"PothosFlow.desktop"
)
sha256sums=(
'SKIP'
+ '3bc94fcdd8a944a58906294d35ec8e2bde2ae6d53806f3413c8c302172058f3f'
'4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
)
@@ -23,7 +25,10 @@ prepare() {
cd "$srcdir/PothosCore"
git submodule init
git submodule deinit poco
- git submodule update --recursive
+ git submodule update --recursive --force
+
+ cd spuce
+ git apply "$srcdir/spuce-qt-workaround.diff"
}
build() {
diff --git a/spuce-qt-workaround.diff b/spuce-qt-workaround.diff
new file mode 100644
index 000000000000..1a575f538f31
--- /dev/null
+++ b/spuce-qt-workaround.diff
@@ -0,0 +1,20 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5a1fe0a..6ce4b17 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,10 +28,11 @@ SET(SPUCE_SOVER "${SPUCE_LIBVER}")
+ set(SPUCE_VERSION "${SPUCE_LIBVER}")
+
+ add_subdirectory(spuce)
+-FIND_PACKAGE(Qt5 COMPONENTS Gui Core Widgets)
+-if (NOT Qt5_FOUND)
+- message(STATUS "QT5 not found - will skip building QT5 Apps")
+-endif()
++#FIND_PACKAGE(Qt5 COMPONENTS Gui Core Widgets)
++#if (NOT Qt5_FOUND)
++# message(STATUS "QT5 not found - will skip building QT5 Apps")
++#endif()
++SET(Qt5_FOUND FALSE)
+ cmake_dependent_option(ENABLE_GUI "Enable QT application" ON "Qt5_FOUND" OFF)
+ add_feature_info(ENABLE_GUI ENABLE_GUI "This enables the QT applications to be built")
+ if (ENABLE_GUI)