summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastien Chassot (sinux)2017-02-27 19:43:55 +0100
committerSebastien Chassot (sinux)2017-02-27 19:43:55 +0100
commit0aa139654c236ab2eede440065a6b65788471426 (patch)
tree6a6cd4f6ce88b6a0668a9d1c217954e7a0fb31c3
downloadaur-0aa139654c236ab2eede440065a6b65788471426.tar.gz
Pothos toolkits to make it easy to install the entire Pothos softwaredefined radio (SDR) suite in one build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fedeb7c260e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pothos-git
+ pkgdesc = Pothos SDR development environment
+ pkgver = r324.3587629
+ pkgrel = 1
+ url = https://github.com/pothosware/Pothos
+ arch = any
+ license = Boost Software License
+ makedepends = git
+ depends = python
+ depends = poco
+ depends = soapysdr-git
+ depends = portaudio
+ provides = pothos-git
+ source = pothos-git::git+https://github.com/pothosware/Pothos.git
+ sha256sums = SKIP
+
+pkgname = pothos-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ad1ae27d813
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sebastien Chassot (sinux) <seba.ptl@sinux.net>
+
+pkgname=pothos-git
+pkgver=r324.3587629
+pkgrel=1
+pkgdesc="Pothos SDR development environment"
+arch=('any')
+url="https://github.com/pothosware/Pothos"
+license=('Boost Software License')
+depends=('python' 'poco' 'soapysdr-git' 'portaudio')
+makedepends=('git')
+provides=('pothos-git')
+source=(${pkgname}::"git+https://github.com/pothosware/Pothos.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $srcdir/$pkgname
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make -j4
+}
+
+package() {
+ make -C "${srcdir}/${pkgname}/build" DESTDIR="${pkgdir}" install
+}