summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2018-02-02 17:57:39 +0100
committerEduardo Sánchez Muñoz2018-02-02 17:57:39 +0100
commite549cce4551dbb32ca16ffff04e961721ca92857 (patch)
tree6ad6e74b5c94f7eb7f9eab7c0b6e10d2b6ce0b1d
parent4908962135b37c26c6227adb83e3dab61f1f1169 (diff)
downloadaur-e549cce4551dbb32ca16ffff04e961721ca92857.tar.gz
Add menu entry.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--PothosFlow.desktop7
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c72425c758bd..bdfa1ab01845 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Dec 27 17:28:24 UTC 2017
pkgbase = pothos-git
pkgdesc = The Pothos data-flow framework
- pkgver = r2979.9da168ef
+ pkgver = r2989.cefd4db6
pkgrel = 1
url = https://github.com/pothosware/PothosCore/wiki
arch = i686
@@ -17,7 +15,9 @@ pkgbase = pothos-git
provides = pothos
conflicts = pothos
source = git+https://github.com/pothosware/PothosCore.git
+ source = PothosFlow.desktop
sha256sums = SKIP
+ sha256sums = 4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4
pkgname = pothos-git
diff --git a/PKGBUILD b/PKGBUILD
index 182d5eeadef6..ea66595a3039 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sebastien Chassot (sinux) <seba.ptl@sinux.net>
pkgname=pothos-git
-pkgver=r2979.9da168ef
+pkgver=r2989.cefd4db6
pkgrel=1
pkgdesc="The Pothos data-flow framework"
arch=('i686' 'x86_64')
@@ -12,8 +12,14 @@ depends=('python' 'poco' 'soapysdr-git' 'portaudio')
makedepends=('git' 'nlohmann-json')
provides=('pothos')
conflicts=('pothos')
-source=("git+https://github.com/pothosware/PothosCore.git")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/pothosware/PothosCore.git"
+ "PothosFlow.desktop"
+)
+sha256sums=(
+ 'SKIP'
+ '4ace40dfff405cf861845cc0f9cf772a39aabc7f3447f5fdf2d0cb74f9b166c4'
+)
pkgver() {
cd "$srcdir/PothosCore"
@@ -22,7 +28,9 @@ pkgver() {
prepare() {
cd "$srcdir/PothosCore"
- git submodule update --init --recursive
+ git submodule init
+ git submodule deinit poco
+ git submodule update --recursive
}
build() {
@@ -31,6 +39,9 @@ build() {
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DENABLE_INTERNAL_POCO=OFF \
+ -DENABLE_INTERNAL_MUPARSERX=ON \
+ -DENABLE_INTERNAL_SPUCE=ON \
"$srcdir/PothosCore"
make
}
@@ -38,4 +49,7 @@ build() {
package() {
cd "$srcdir/pothos-build"
make DESTDIR="$pkgdir" install
+
+ install -Dm644 "$srcdir/PothosFlow.desktop" "$pkgdir/usr/share/applications/PothosFlow.desktop"
+ install -Dm644 "$srcdir/PothosCore/flow/icons/PothosFlow.png" "$pkgdir/usr/share/pixmaps/PothosFlow.png"
}
diff --git a/PothosFlow.desktop b/PothosFlow.desktop
new file mode 100644
index 000000000000..8e3450da8f84
--- /dev/null
+++ b/PothosFlow.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Pothos Flow
+Exec=/usr/bin/PothosFlow %F
+Icon=/usr/share/pixmaps/PothosFlow.png
+Terminal=false
+Type=Application
+Categories=Development;