summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgilbus2023-07-15 21:18:28 +0000
committergilbus2023-07-15 21:18:28 +0000
commit9d40169836c7f50de0ef6268708b3546714d09f6 (patch)
tree443788d26cf112163e4c2d8b69e57ef09bcced8c
downloadaur-9d40169836c7f50de0ef6268708b3546714d09f6.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..217edda5ae6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = potoo
+ pkgdesc = Markdown presentation tool build on top of textual
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/gilbus/potoo
+ arch = any
+ license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-pdm-backend
+ depends = python-textual
+ source = https://files.pythonhosted.org/packages/source/p/potoo/potoo-0.1.0.tar.gz
+ sha256sums = 4db34694f41438d5f60671ec7433d4d960ffa0f0a325505c7cd24a1ee30bd827
+
+pkgname = potoo
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7735b4612827
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad6878c2e225
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: gilbus <aur (AT) tinkershell dot eu>
+pkgname=potoo
+_name=potoo
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Markdown presentation tool build on top of textual"
+arch=('any')
+url="https://gitlab.com/gilbus/potoo"
+license=('GPL3')
+depends=('python-textual')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'python-pdm-backend')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('4db34694f41438d5f60671ec7433d4d960ffa0f0a325505c7cd24a1ee30bd827')
+
+prepare() {
+ cd "$_name-$pkgver"
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}