summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKusoneko2022-09-21 03:59:48 -0400
committerKusoneko2022-09-21 03:59:48 -0400
commit01263e40b1e14b75a2bb97885bcfb611c6ffdd9f (patch)
treee52ca80f7c9fbb7d2eebeaae69103c0334cc4afc
downloadaur-01263e40b1e14b75a2bb97885bcfb611c6ffdd9f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57f8673a706c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pounce-git
+ pkgdesc = A multi-client, TLS-only IRC bouncer
+ pkgver = 3.0.r462.f2ca5b0
+ pkgrel = 1
+ url = https://git.causal.agency/pounce
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = libretls
+ depends = libxcrypt
+ provides = pounce
+ conflicts = pounce
+ source = pounce::git+https://git.causal.agency/pounce.git
+ md5sums = SKIP
+
+pkgname = pounce-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..136570eebd9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kusoneko <kusoneko@kusoneko.moe>
+
+pkgname=pounce-git
+pkgver=3.0.r462.f2ca5b0
+pkgrel=1
+pkgdesc="A multi-client, TLS-only IRC bouncer"
+arch=('x86_64')
+url="https://git.causal.agency/pounce"
+license=('GPL3')
+depends=('libretls' 'libxcrypt')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://git.causal.agency/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s.r%s.%s" "$(git describe --tags --abbrev=0)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make all
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}