summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2020-12-24 17:29:08 -0800
committerJonathan Knapp2020-12-24 17:36:12 -0800
commit65c5f88eb2df75df77c4da139859232d7d94f2c0 (patch)
tree323fb1378daad9cee2e44e2ac62f7447d7e9c56b
parentca92f01dd7cc0474697f61a0b0f7b0875299eb1b (diff)
downloadaur-65c5f88eb2df75df77c4da139859232d7d94f2c0.tar.gz
Mesonification
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD32
-rw-r--r--powder-toy.patch13
3 files changed, 17 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b064455d8e49..08cc9e45aa42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powder-toy-git
pkgdesc = Desktop version of the classic falling sand physics sandbox, simulates air pressure, velocity & heat!
- pkgver = snapshot.204.2.ga3c2a0d6
+ pkgver = snapshot.206.1.g55c14fc1
pkgrel = 1
url = http://powdertoy.co.uk/
arch = x86_64
@@ -19,14 +19,14 @@ pkgbase = powder-toy-git
provides = powder-toy
conflicts = powder-toy
source = powder-toy::git+https://github.com/ThePowderToy/The-Powder-Toy.git#branch=master
- source = powder-toy.patch
source = powder-toy.sh
+ source = powder-toy.patch
source = powder-toy.desktop
source = powder-toy-open.desktop
source = powder-toy-ptsave.desktop
sha256sums = SKIP
- sha256sums = 4b75d58bfff9278bceb27fa14738e9a1abef6fe60680bb9f5eb0592f3d69a02a
sha256sums = b5d181c3141715b7dced8813cae6d07d2adc03bca2a7efe527592740de2d45e2
+ sha256sums = 2b3a51ed0f41be065da71c6f9b48d4b8e75111dd8ea6028b5ad069817c31b7bf
sha256sums = 265f530be7597fcc7bbaf2690fd517fe4f8f18372c808a90ddef49a604c8d455
sha256sums = 398f6d068dd37e12989f4132ea5966886b14036bac07a589991b283d242b4ca5
sha256sums = fcbf035d286d805dced55f147d649aa0bc74d3be873d5430de92d175d9f59431
diff --git a/PKGBUILD b/PKGBUILD
index ae1f0678bd34..e40917157cae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ _branch=master
_ogname=powder-toy
pkgname=powder-toy-git
-pkgver=snapshot.204.2.ga3c2a0d6
+pkgver=snapshot.206.1.g55c14fc1
pkgrel=1
pkgdesc="Desktop version of the classic falling sand physics sandbox, simulates air pressure, velocity & heat!"
arch=(x86_64 i686)
@@ -24,14 +24,14 @@ makedepends=('scons' 'libicns')
url="http://powdertoy.co.uk/"
license=('GPL3')
source=("${_ogname}::git+https://github.com/ThePowderToy/The-Powder-Toy.git#branch=$_branch"
- "${_ogname}.patch"
"${_ogname}.sh"
+ "${_ogname}.patch"
"${_ogname}.desktop"
"${_ogname}-open.desktop"
"${_ogname}-ptsave.desktop")
sha256sums=('SKIP'
- '4b75d58bfff9278bceb27fa14738e9a1abef6fe60680bb9f5eb0592f3d69a02a'
'b5d181c3141715b7dced8813cae6d07d2adc03bca2a7efe527592740de2d45e2'
+ '2b3a51ed0f41be065da71c6f9b48d4b8e75111dd8ea6028b5ad069817c31b7bf'
'265f530be7597fcc7bbaf2690fd517fe4f8f18372c808a90ddef49a604c8d455'
'398f6d068dd37e12989f4132ea5966886b14036bac07a589991b283d242b4ca5'
'fcbf035d286d805dced55f147d649aa0bc74d3be873d5430de92d175d9f59431')
@@ -54,30 +54,26 @@ build() {
local extra_flags=()
- case "$CARCH" in
- x86_64) extra_flags+=(--64bit) ;;
- i686) extra_flags+=(--32bit) ;;
- esac
-
if grep -q -i pni /proc/cpuinfo; then
- extra_flags+=(--sse3)
+ extra_flags+=("-D x86_sse=sse3")
elif grep -q -i sse2 /proc/cpuinfo; then
- extra_flags+=(--sse2)
+ extra_flags+=("-D x86_sse=sse2")
elif grep -q -i sse /proc/cpuinfo; then
- extra_flags+=(--sse)
+ extra_flags+=("-D x86_sse=sse")
else
- extra_flags+=(--no-sse)
+ extra_flags+=("-D x86_sse=none")
fi
case "$_lua" in
- luajit) extra_flags+=(--luajit) ;;
- lua51) ;; # lua51 support is enabled by default
- lua52) extra_flags+=(--lua52) ;;
- "") extra_flags+=(--nolua) ;;
+ luajit) extra_flags+=("-D lua=luajit") ;;
+ lua51) extra_flags+=("-D lua=lua5.1") ;;
+ lua52) extra_flags+=("-D lua=lua5.2") ;;
esac
msg2 "building ${_ogname} with the following extra flags: ${extra_flags[*]}"
- scons --lin --release --output="${_ogname}" ${MAKEFLAGS} "${extra_flags[@]}"
+ meson build_debug -D "ignore-updates=true" "${extra_flags[@]}"
+ cd build_debug
+ ninja
}
package() {
@@ -88,7 +84,7 @@ package() {
cd ${_ogname}
- install -Dm755 "build/${_ogname}" "${pkgdir}/usr/lib/${_ogname}/${_ogname}"
+ install -Dm755 "build_debug/powder" "${pkgdir}/usr/lib/${_ogname}/${_ogname}"
install -Dm644 "resources/powdertoy-save.xml" "${pkgdir}/usr/share/mime/packages/${_ogname}-save.xml"
install -Dm644 "resources/powder.appdata.xml" "${pkgdir}/usr/share/metainfo/${_ogname}.appdata.xml"
diff --git a/powder-toy.patch b/powder-toy.patch
index 9a5630ee6d2f..9ce1f4237b73 100644
--- a/powder-toy.patch
+++ b/powder-toy.patch
@@ -9,16 +9,3 @@ diff --unified --recursive --text --color The-Powder-Toy-94.1.orig/resources/pow
<comment>Powder Toy save</comment>
<glob pattern="*.cps"/>
<glob pattern="*.stm"/>
-diff --unified --recursive --text --color The-Powder-Toy-94.1.orig/src/Config.h The-Powder-Toy-94.1/src/Config.h
---- The-Powder-Toy-94.1.orig/src/Config.h 2019-02-21 07:23:45.000000000 +0200
-+++ The-Powder-Toy-94.1/src/Config.h 2019-10-06 01:33:00.610003177 +0300
-@@ -40,7 +40,8 @@
- #endif
- //VersionInfoEnd
-
--//#define IGNORE_UPDATES //uncomment this for mods, to not get any update notifications
-+#define IGNORE_UPDATES
-+#define NO_INSTALL_CHECK
-
- #if !(defined(MACOSX) && defined(DEBUG))
- #define HIGH_QUALITY_RESAMPLE //High quality image resampling, slower but much higher quality than my terribad linear interpolation