summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheSola102023-11-23 21:13:43 +0100
committerTheSola102023-11-23 21:13:43 +0100
commit3f2d63d75ebf772e685cf789370c5028cde368da (patch)
treeefbcbe32a1cf3e7540620631f836ee2b76cae766
downloadaur-3f2d63d75ebf772e685cf789370c5028cde368da.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..668c891f926b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = power-profiles-hooks-git
+ pkgdesc = Daemon to launch commands on power-profiles-daemon profile change
+ pkgver = r5.8338b75
+ pkgrel = 1
+ url = https://github.com/thesola10/power-profiles-hooks
+ arch = x86_64
+ license = CC0-1.0
+ makedepends = git
+ makedepends = make
+ makedepends = gettext
+ depends = power-profiles-daemon
+ depends = python
+ depends = dbus-python
+ depends = python-gobject
+ source = git+https://github.com/thesola10/power-profiles-hooks.git
+ sha256sums = SKIP
+
+pkgname = power-profiles-hooks-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec06a9830c7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=power-profiles-hooks-git
+_pkgname=power-profiles-hooks
+pkgver=r5.8338b75
+pkgrel=1
+pkgdesc="Daemon to launch commands on power-profiles-daemon profile change"
+arch=('x86_64')
+url="https://github.com/thesola10/power-profiles-hooks"
+license=('CC0-1.0')
+depends=('power-profiles-daemon'
+ 'python'
+ 'dbus-python'
+ 'python-gobject')
+makedepends=('git'
+ 'make'
+ 'gettext')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/usr/lib/systemd/system" "$pkgdir/usr/bin" $pkgdir/etc/power-profiles.d/{balanced,power-saver,performance}
+ make DESTDIR="$pkgdir" install
+}