summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Gacogne2020-10-04 14:36:00 +0200
committerRemi Gacogne2020-10-04 14:36:00 +0200
commit1970b0e32fabc380e4c9616c6b3e1075a8bca80d (patch)
tree6fd5d0edf6169734e4e86e9222ce287627d6b884
parent2e449ef879d0de9b7249a69efa991b3086386ac7 (diff)
downloadaur-1970b0e32fabc380e4c9616c6b3e1075a8bca80d.tar.gz
powerdns-recursor-git: Call autoreconf in prepare, better pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19eb434d092c..ba73f6a86556 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = powerdns-recursor-git
pkgdesc = Resolving DNS server
- pkgver = r19561.e5e184cb8
+ pkgver = 4.5.0alpha0.r133.gfb8b7ee85
pkgrel = 1
url = https://www.powerdns.com/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c58187ccc737..0fa740460ef9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Remi Gacogne <rgacogne-arch at archlinux dot org>
pkgname=powerdns-recursor-git
-pkgver=r19561.e5e184cb8
+pkgver=4.5.0alpha0.r133.gfb8b7ee85
pkgrel=1
pkgdesc='Resolving DNS server'
arch=('x86_64')
@@ -16,14 +16,18 @@ provides=('powerdns-recursor')
conflicts=('powerdns-recursor')
backup=('etc/powerdns/recursor.conf')
+prepare() {
+ cd "${pkgname}/pdns/recursordist"
+ autoreconf -i
+}
+
pkgver() {
cd "${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --tags --match 'rec-*' | sed 's/rec-//;s/.\(\(rc\|alpha\|beta\)\d*\)/\1/;s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${pkgname}/pdns/recursordist"
- autoreconf -i
./configure \
--prefix=/usr \
--sbindir=/usr/bin \