summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Christensen2015-06-08 10:29:41 -0600
committerDevin Christensen2015-06-08 10:29:41 -0600
commit75f58a34a95d79710cddbbb2f7fa8c3612c361bf (patch)
tree2ffb03d4705824672772ce3929ffa7e9dd5622d4
downloadaur-75f58a34a95d79710cddbbb2f7fa8c3612c361bf.tar.gz
Create package
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD54
-rw-r--r--powerline-fonts-git.install15
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc8255d068ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = powerline-fonts-git
+ pkgdesc = Powerline fonts for X11 and the console
+ pkgver = r71.39c99c0
+ pkgrel = 1
+ url = https://github.com/powerline/fonts
+ install = powerline-fonts-git.install
+ arch = any
+ license = CPL
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = otf-droid-sans-mono-powerline-git
+ conflicts = otf-inconsolata-dz-powerline-git
+ conflicts = otf-inconsolata-g-powerline-git
+ conflicts = otf-inconsolata-powerline-git
+ conflicts = otf-meslo-powerline-git
+ conflicts = otf-sauce-code-powerline-git
+ conflicts = powerline-fonts
+ conflicts = terminess-powerline-font-git
+ conflicts = ttf-anonymice-powerline-git
+ conflicts = ttf-dejavu-sans-mono-powerline-git
+ conflicts = ttf-literation-mono-powerline-git
+ conflicts = ttf-monofur-powerline-git
+ conflicts = ttf-ubuntu-mono-derivative-powerline-git
+ conflicts = monaco-powerline-font-git
+ conflicts = otf-droidsansmono-powerline-git
+ conflicts = otf-source-code-pro-powerline-git
+ conflicts = source-code-pro-fonts-powerline
+ conflicts = terminess-powerline-font
+ conflicts = ttf-anonymous-pro-powerline
+ conflicts = ttf-anonymous-pro-powerline-git
+ conflicts = ttf-dejavusansmono-powerline-git
+ conflicts = ttf-inconsolata-dz-powerline
+ conflicts = ttf-liberation-mono-powerline-git
+ conflicts = ttf-meslo-powerline-git
+ conflicts = ttf-powerline-fonts-git
+ conflicts = ttf-ubuntu-mono-powerline-git
+ source = git://github.com/powerline/fonts.git
+ md5sums = SKIP
+
+pkgname = powerline-fonts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70dc593c6774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=powerline-fonts-git
+pkgver=r71.39c99c0
+pkgrel=1
+pkgdesc="Powerline fonts for X11 and the console"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('CPL')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(
+ otf-droid-sans-mono-powerline-git
+ otf-inconsolata-dz-powerline-git
+ otf-inconsolata-g-powerline-git
+ otf-inconsolata-powerline-git
+ otf-meslo-powerline-git
+ otf-sauce-code-powerline-git
+ powerline-fonts
+ terminess-powerline-font-git
+ ttf-anonymice-powerline-git
+ ttf-dejavu-sans-mono-powerline-git
+ ttf-literation-mono-powerline-git
+ ttf-monofur-powerline-git
+ ttf-ubuntu-mono-derivative-powerline-git
+ monaco-powerline-font-git
+ otf-droidsansmono-powerline-git
+ otf-source-code-pro-powerline-git
+ source-code-pro-fonts-powerline
+ terminess-powerline-font
+ ttf-anonymous-pro-powerline
+ ttf-anonymous-pro-powerline-git
+ ttf-dejavusansmono-powerline-git
+ ttf-inconsolata-dz-powerline
+ ttf-liberation-mono-powerline-git
+ ttf-meslo-powerline-git
+ ttf-powerline-fonts-git
+ ttf-ubuntu-mono-powerline-git
+)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts
+ find . -iname "*.ttf" -execdir install -Dm644 {} $pkgdir/usr/share/fonts/TTF/{} \;
+ find . -iname "*.otf" -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+ find . -iname "*.pcf.gz" -execdir install -Dm644 {} $pkgdir/usr/share/fonts/misc/{} \;
+ find . -iname "*.psf.gz" -execdir install -Dm644 {} $pkgdir/usr/share/kbd/consolefonts/{} \;
+}
diff --git a/powerline-fonts-git.install b/powerline-fonts-git.install
new file mode 100644
index 000000000000..1e8ba5091faf
--- /dev/null
+++ b/powerline-fonts-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ mkfontscale /usr/share/fonts/TTF /usr/share/fonts/OTF /usr/share/fonts/misc > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/TTF /usr/share/fonts/OTF /usr/share/fonts/misc > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}