summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb10n2019-01-12 22:59:36 +0100
committerb10n2019-01-12 22:59:36 +0100
commit8621b40d58b1f1a7980d692ab655a9ad8f4c4c22 (patch)
tree72815e596616af6153380b59aa8480381813a1a6
parent13b0b70195f9aec11ad80117da49f7ea928e13eb (diff)
downloadaur-8621b40d58b1f1a7980d692ab655a9ad8f4c4c22.tar.gz
add tomlc99 submodule
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38311eac4617..8d1c99754235 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = powermate-git
pkgdesc = A small Linux userspace driver for the Griffin PowerMate.
- pkgver = v5.r8.gc6ff4c1
+ pkgver = v5.r20.g3f6459f
pkgrel = 1
url = https://github.com/stefansundin/powermate-linux
arch = x86_64
license = GPL3
- makedepends = libnotify
depends = libpulse
source = git+https://github.com/stefansundin/powermate-linux.git
+ source = git+https://github.com/cktan/tomlc99.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = powermate-git
diff --git a/PKGBUILD b/PKGBUILD
index 41b46a4bd99d..a885f07b5e92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,22 @@
# Maintainer: b10n <b10n@dittes.nl>
pkgname=powermate-git
-pkgver=v5.r8.gc6ff4c1
+pkgver=v5.r20.g3f6459f
pkgrel=1
pkgdesc="A small Linux userspace driver for the Griffin PowerMate."
arch=('x86_64')
url="https://github.com/stefansundin/powermate-linux"
license=('GPL3')
depends=('libpulse')
-makedepends=('libnotify')
-source=("git+https://github.com/stefansundin/powermate-linux.git")
-md5sums=('SKIP')
+source=("git+https://github.com/stefansundin/powermate-linux.git"
+ "git+https://github.com/cktan/tomlc99.git")
+md5sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd powermate-linux
+ git submodule init
+ git config submodule.tomlc99.url "$srcdir/tomlc99"
+ git submodule update
+}
pkgver() {
cd "$srcdir/powermate-linux"
@@ -23,8 +30,6 @@ build() {
package() {
cd "$srcdir/powermate-linux"
- mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/etc/udev/rules.d"
- cp powermate "$pkgdir/usr/bin"
- cp 60-powermate.rules "$pkgdir/etc/udev/rules.d"
+ install -D -m755 powermate "$pkgdir/usr/bin/powermate"
+ install -D -m644 60-powermate.rules "$pkgdir/etc/udev/rules.d/60-powermate.rules"
}